Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge portage fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
donjames
Apprentice
Apprentice


Joined: 19 Dec 2004
Posts: 188
Location: Henderson, Texas USA

PostPosted: Wed Mar 02, 2016 8:33 pm    Post subject: emerge portage fails Reply with quote

I am trying to do emerge world and the system tells me to update portage.

Here's the error I get when I try to emerge portage:
Code:

emerge -uDNv portage

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-devel/gnuconfig-20151214::gentoo [20150727::gentoo] 47 KiB
[ebuild     U  ] app-shells/bash-4.3_p42::gentoo [4.3_p39-r1::gentoo] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 7,995 KiB
[ebuild     U  ] net-misc/rsync-3.1.2::gentoo [3.1.1::gentoo] USE="acl iconv ipv6 xattr -static -stunnel%" 872 KiB
[ebuild     U  ] dev-libs/openssl-1.0.2f::gentoo [1.0.2e::gentoo] USE="asm static-libs tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp {-test} -vanilla" CPU_FLAGS_X86="sse2" 5,136 KiB
[ebuild     U  ] dev-lang/python-exec-2.1:2::gentoo [2.0.2:2::gentoo] PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_3) (python3_4) (python3_5)" 81 KiB
[ebuild     U  ] app-eselect/eselect-python-20151117-r2::gentoo [20140125::gentoo] 62 KiB
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)
[ebuild   R    ] app-arch/tar-1.28-r1::gentoo  USE="acl nls xattr -minimal (-selinux) -static" ELIBC="(glibc%*)" 2,631 KiB
[ebuild     U  ] sys-apps/help2man-1.47.3::gentoo [1.47.2::gentoo] USE="nls" 181 KiB
[ebuild     U  ] sys-devel/automake-1.15-r1:1.15::gentoo [1.15:1.15::gentoo] 1,462 KiB
[ebuild     U  ] dev-libs/icu-56.1:0/56::gentoo [55.1:0/55::gentoo] USE="static-libs -debug -doc -examples" 25,120 KiB
[ebuild     U  ] dev-db/sqlite-3.10.0:3::gentoo [3.9.2:3::gentoo] USE="icu readline static-libs -debug -doc -secure-delete -tcl {-test} -tools" 2,277 KiB
[ebuild     U  ] dev-lang/python-2.7.11-r2:2.7::gentoo [2.7.10-r3:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -libressl -tk -wininst" 12,003 KiB
[blocks b      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r2)
[ebuild  NS    ] dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo [2.7.10-r3:2.7::gentoo, 3.3.5-r2:3.3::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -examples -hardened -libressl -tk -wininst" 14,096 KiB
[ebuild     U  ] dev-libs/libxml2-2.9.3:2::gentoo [2.9.2-r4:2::gentoo] USE="icu ipv6 python readline static-libs -debug -examples -lzma {-test}" PYTHON_TARGETS="python2_7 python3_4* -python3_3* -python3_5" 5,349 KiB
[ebuild     U  ] app-misc/ca-certificates-20151214.3.21::gentoo [20150426.3.20-r1::gentoo] USE="cacert" 287 KiB
[ebuild   R    ] dev-python/pyelftools-0.23-r1::gentoo  USE="-examples" PYTHON_TARGETS="python2_7 python3_4* -python3_3*" 392 KiB
[ebuild   R    ] sys-apps/file-5.25::gentoo  USE="python static-libs zlib" PYTHON_TARGETS="python2_7 python3_4* -pypy -python3_3*" 0 KiB
[ebuild   R    ] dev-python/six-1.10.0::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4* -pypy -pypy3 -python3_3* -python3_5" 0 KiB
[ebuild     U  ] sys-apps/sandbox-2.10-r1::gentoo [2.9::gentoo] USE="(-multilib)" 408 KiB
[ebuild     U  ] dev-python/packaging-16.0::gentoo [15.3-r2::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4* -pypy -pypy3 -python3_3* -python3_5" 40 KiB
[ebuild     U  ] dev-python/setuptools-19.4::gentoo [19.2::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4* -pypy -pypy3 -python3_3* -python3_5" 627 KiB
[ebuild  N     ] dev-python/pyparsing-2.0.7::gentoo  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_3 -python3_5" 1,115 KiB
[ebuild   R    ] dev-python/certifi-2015.11.20.1::gentoo  PYTHON_TARGETS="python2_7 python3_4* -pypy -pypy3 -python3_3* -python3_5" 0 KiB
[ebuild   R    ] dev-python/pyxattr-0.5.5::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4* -pypy -python3_3*" 27 KiB
[ebuild     U  ] sys-apps/portage-2.4.1::gentoo [2.4.0::gentoo] USE="(ipc) xattr -build -doc -epydoc (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4* -pypy -python3_3* -python3_5%" 955 KiB
[ebuild     U  ] app-admin/python-updater-0.14::gentoo [0.13::gentoo] 11 KiB
[blocks B      ] <dev-lang/python-3.3.5-r4:3.3 ("<dev-lang/python-3.3.5-r4:3.3" is blocking app-eselect/eselect-python-20151117-r2)

Total: 26 packages (18 upgrades, 1 new, 1 in new slot, 6 reinstalls), Size of downloads: 81,163 KiB
Conflict: 3 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-56.1:0/56::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-55.1:0/55::gentoo, installed) pulled in by
    dev-libs/icu:0/55=[abi_x86_32(-)] required by (dev-qt/qtcore-4.8.7-r1:4/4::gentoo, installed)
                ^^^^^^                                                                                                               
    (and 4 more with the same problem)

dev-python/six:0

  (dev-python/six-1.10.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/six-1.10.0[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           

  (dev-python/six-1.10.0:0/0::gentoo, installed) pulled in by
    >=dev-python/six-1.5.2[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyopenssl-0.15.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                   
    >=dev-python/six-1.9[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pip-7.1.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    >=dev-python/six-1.4.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/cryptography-1.1.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                     
    >=dev-python/six-1.4[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/unittest2-1.1.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       
    >=dev-python/six-1.7.0[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/retrying-1.3.3:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         
    dev-python/six[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/html5lib-0.9999999:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

dev-python/setuptools:0

  (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyparsing-2.0.7:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         

  (dev-python/setuptools-19.2:0/0::gentoo, installed) pulled in by
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/numpy-1.10.2-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/chardet-2.3.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       
    >=dev-python/setuptools-18.2[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pip-7.1.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/unittest2-1.1.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/cryptography-1.1.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                   

dev-python/certifi:0

  (dev-python/certifi-2015.11.20.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/certifi-2015.11.20[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

  (dev-python/certifi-2015.11.20.1:0/0::gentoo, installed) pulled in by
    >=dev-python/certifi-2015.11.20[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-19.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

dev-python/packaging:0

  (dev-python/packaging-16.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/packaging-15.3-r1[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-19.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

  (dev-python/packaging-15.3-r2:0/0::gentoo, installed) pulled in by
    >=dev-python/packaging-15.3[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pip-7.1.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         
    >=dev-python/packaging-15.3-r1[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-19.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

sys-apps/portage:0

  (sys-apps/portage-2.4.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.4.0:0/0::gentoo, installed) pulled in by
    sys-apps/portage[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-3.3.5-r2:3.3/3.3::gentoo, installed) pulled in by
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/unittest2-1.1.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/CacheControl-0.11.5:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-apps/kmod-19:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pbr-1.8.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-libs/libcap-ng-0.7.7:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-boot/boot-update-1.7.3-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/numpy-1.10.2-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-apps/util-linux-2.27.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/lockfile-0.12.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/ndg-httpsclient-0.4.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/mimeparse-0.1.4-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/six-1.10.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[xml(+)] required by (dev-python/html5lib-0.9999999:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/extras-0.0.3:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pycparser-2.14:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/enum34-1.0.4:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pip-7.1.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/colorama-0.3.5:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/cryptography-1.1.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyasn1-0.1.9:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/requests-2.9.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/testtools-1.8.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/setuptools-19.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pycairo-1.10.0-r5:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[bzip2(+)] required by (sys-apps/portage-2.4.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/linecache2-1.0.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/subunit-1.2.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/chardet-2.3.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[xml] required by (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/ply-3.8:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/distlib-0.2.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/retrying-1.3.3:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/py-1.4.31:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/cffi-1.4.2:0/1.4.2::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/progress-1.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pyopenssl-0.15.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/idna-2.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/traceback2-1.4.0:0/0::gentoo, installed)

  (app-eselect/eselect-python-20151117-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo, ebuild scheduled for merge)
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-2.7.11-r2:2.7/2.7::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-3.3.5-r2:3.3/3.3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

foundindumpster emergeprob #


Here is emerge --info for my computer:
Code:

emerge --info
Portage 2.2.20.1 (python 3.3.5-final-0, funtoo/1.0/linux-gnu/arch/x86-32bit, gcc-4.9.3, glibc-2.20-r2, 4.3.3-gentoo i686)
=================================================================
System uname: Linux-4.3.3-gentoo-i686-AMD_Athlon-tm-_64_Processor_3800+-with-gentoo-2.2.0
KiB Mem:     1999000 total,    116304 free
KiB Swap:    2097148 total,   2096156 free
sh bash 4.3_p39-r1
ld GNU ld (Funtoo 2.25) 2.25.0
app-shells/bash:          4.3_p39-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.10-r3::gentoo, 3.3.5-r2::gentoo
dev-util/cmake:           3.4.1::gentoo
sys-apps/baselayout:      2.2.0-r6::gentoo
sys-apps/openrc:          0.18.3-r1::gentoo
sys-apps/sandbox:         2.9::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25-r2::gentoo
sys-devel/gcc:            4.9.3-r1::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.0::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: git://github.com/funtoo/ports-2012.git
    priority: -1000

ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -mtune=generic -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -mtune=generic -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -march=i686 -mtune=generic -pipe"
GENTOO_MIRRORS="  http://mirrors.cs.wmich.edu/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo/ rsync://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://lug.mtu.edu/gentoo/ http://gentoo.osuosl.org/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://mirror.lug.udel.edu/pub/gentoo/ http://mirror.its.uidaho.edu/pub/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa apache apache2 apng berkdb bzip2 cdr consolekit cracklib crypt ctype cups cxx dbus device-mapper dvd extras filter frascend gd gdbm gnutls gtk gtk2 gtk3 hal hpcups iconv icu imap ipv6 kde lua lxde minizip mng modules mp3 mudflap ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pcre php png policykit polkit python qt3 qt3support qt4 readline resolvconf samba sdl session snmp sql sqlite ssl static-libs svg tcltk tcpd tftp tkinter unicode vorbis x86 xattr xml zlib" ABI_X86="32" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext sse sse2 sse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-32 pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby20 ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="noveau fbdev vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS

foundindumpster emergeprob #


Can someone give me a clue about how to fix this?

Thanks,

Don James
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5879

PostPosted: Wed Mar 02, 2016 8:43 pm    Post subject: Reply with quote

Put =dev-libs/icu-56.1 in package.mask - it'll fail to compile anyway.
Back to top
View user's profile Send private message
donjames
Apprentice
Apprentice


Joined: 19 Dec 2004
Posts: 188
Location: Henderson, Texas USA

PostPosted: Wed Mar 02, 2016 8:49 pm    Post subject: Reply with quote

Hi Ant P.

I tried putting
=dev-libs/icu-56.1 in package.mask

emerge portage fails.

What else can I try?

Thanks,

Don James
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1053
Location: Massachusetts USA

PostPosted: Wed Mar 02, 2016 11:58 pm    Post subject: Reply with quote

Try
Code:
emerge -1 dev-lang/python:3.4
python-updater

Make python 3.4 the active version for python 3.

Your USE flags for python are for 2.7 and 3.4 but you have 2.7 and 3.3 installed.
Back to top
View user's profile Send private message
donjames
Apprentice
Apprentice


Joined: 19 Dec 2004
Posts: 188
Location: Henderson, Texas USA

PostPosted: Thu Mar 03, 2016 1:23 am    Post subject: Reply with quote

I get:

Code:

emerge -1 dev-lang/python:3.4

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild  NS    ] dev-lang/python-3.4.3-r7 [2.7.10-r3, 3.3.5-r2] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -examples -hardened -libressl -tk -wininst"
[ebuild     U  ] dev-lang/python-exec-2.1 [2.0.2]
[ebuild     U  ] app-eselect/eselect-python-20151117-r2 [20140125]
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)
[blocks B      ] <dev-lang/python-3.3.5-r4:3.3 ("<dev-lang/python-3.3.5-r4:3.3" is blocking app-eselect/eselect-python-20151117-r2)
[blocks B      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-2.7.10-r3:2.7/2.7::gentoo, installed) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyelftools-0.23-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycairo-1.10.0-r5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (app-admin/syslog-ng-3.7.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/testtools-1.8.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ipaddress-1.0.16:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-print/cups-2.0.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (dev-python/html5lib-0.9999999:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (net-fs/samba-4.2.7:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/file-5.25:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-libs/vte-0.28.2-r207:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-libs/libcap-ng-0.7.7:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/enum34-1.0.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/cffi-1.4.2:0/1.4.2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxslt-1.1.28-r5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/keybinder-0.3.1-r200:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (sys-libs/tevent-0.9.26:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/requests-2.9.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/py-1.4.31:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/progress-1.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/git-2.6.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/six-1.10.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-analyzer/net-snmp-5.7.3-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/lockfile-0.12.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/linecache2-1.0.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/setuptools-19.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/CacheControl-0.11.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (sys-libs/talloc-2.1.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pyopenssl-0.15.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/subunit-1.2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pbr-1.8.1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/mimeparse-0.1.4-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ndg-httpsclient-0.4.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/extras-0.0.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/cryptography-1.1.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/colorama-0.3.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/retrying-1.3.3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/unittest2-1.1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/distlib-0.2.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (net-libs/libproxy-0.4.11-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/usbutils-007:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (sys-libs/tdb-1.3.8:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads] required by (sys-libs/ldb-1.1.24:0/1.1.24::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/ply-3.8:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (sys-libs/ntdb-1.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/numpy-1.10.2-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/idna-2.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/traceback2-1.4.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (media-libs/alsa-lib-1.1.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/chardet-2.3.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (sys-apps/kmod-19:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyasn1-0.1.9:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pycparser-2.14:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pip-7.1.2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+)] required by (sys-apps/portage-2.4.0:0/0::gentoo, installed)

  (dev-lang/python-3.3.5-r2:3.3/3.3::gentoo, installed) pulled in by
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/extras-0.0.3:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/linecache2-1.0.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pbr-1.8.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/cffi-1.4.2:0/1.4.2::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-apps/kmod-19:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/cryptography-1.1.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyelftools-0.23-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[xml(+)] required by (dev-python/html5lib-0.9999999:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/setuptools-19.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/idna-2.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyasn1-0.1.9:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/ndg-httpsclient-0.4.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-apps/util-linux-2.27.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/numpy-1.10.2-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/CacheControl-0.11.5:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/distlib-0.2.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[xml] required by (dev-util/gdbus-codegen-2.44.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/unittest2-1.1.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-apps/file-5.25:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (virtual/python-ipaddress-1.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pyopenssl-0.15.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/progress-1.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/lockfile-0.12.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/retrying-1.3.3:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-libs/libcap-ng-0.7.7:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (sys-boot/boot-update-1.7.3-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/testtools-1.8.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pip-7.1.2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[bzip2(+)] required by (sys-apps/portage-2.4.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/requests-2.9.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/six-1.10.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/pycparser-2.14:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/chardet-2.3.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/colorama-0.3.5:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/subunit-1.2.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/mimeparse-0.1.4-r1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/py-1.4.31:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3[threads(+)] required by (dev-python/pycairo-1.10.0-r5:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/traceback2-1.4.0:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/enum34-1.0.4:0/0::gentoo, installed)
    >=dev-lang/python-3.3.2-r2:3.3 required by (dev-python/ply-3.8:0/0::gentoo, installed)

  (app-eselect/eselect-python-20151117-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-3.3.5-r2:3.3/3.3::gentoo, installed)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r3:2.7/2.7::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


What can I try next?

Thanks,

donjames
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1053
Location: Massachusetts USA

PostPosted: Thu Mar 03, 2016 5:12 am    Post subject: Reply with quote

In /etc/portage/make.conf add
Code:
PYTHON_TARGETS="python2_7 python3_3 python3_4"

Do the emerge.
Make python 3.4 the active version of python.
Run python-updater
Remove the PYTHON_TARGETS line from make.conf
Remove unused version of python by running emerge --depclean dev-lang/python
Back to top
View user's profile Send private message
donjames
Apprentice
Apprentice


Joined: 19 Dec 2004
Posts: 188
Location: Henderson, Texas USA

PostPosted: Thu Mar 03, 2016 1:06 pm    Post subject: Reply with quote

emerge python doesn't work.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5879

PostPosted: Thu Mar 03, 2016 5:54 pm    Post subject: Reply with quote

Remove PYTHON_TARGETS and PYTHON_SINGLE_TARGET if they're in make.conf.
Go in /var/lib/portage/world and make sure you don't have any mention of dev-lang/python or dev-python/* in there, if you do remove them.

Then try: emerge -D1pvu --with-bdeps=y --backtrack=30 python:2.7 python:3.3
Back to top
View user's profile Send private message
donjames
Apprentice
Apprentice


Joined: 19 Dec 2004
Posts: 188
Location: Henderson, Texas USA

PostPosted: Thu Mar 03, 2016 7:09 pm    Post subject: Reply with quote

I tried:

emerge -D1pvu --with-bdeps=y --backtrack=30 python:2.7 python:3.3

Here's what I got:
Code:

emerge -D1pvu --with-bdeps=y --backtrack=30 python:2.7 python:3.3

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-devel/gnuconfig-20151214::gentoo [20150727::gentoo] 47 KiB
[ebuild     U  ] app-shells/bash-4.3_p42::gentoo [4.3_p39-r1::gentoo] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 7,995 KiB
[ebuild     U  ] net-misc/rsync-3.1.2::gentoo [3.1.1::gentoo] USE="acl iconv ipv6 xattr -static -stunnel%" 872 KiB
[ebuild     U  ] dev-libs/openssl-1.0.2f::gentoo [1.0.2e::gentoo] USE="asm static-libs tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp {-test} -vanilla" CPU_FLAGS_X86="sse2" 5,136 KiB
[ebuild     U  ] dev-lang/python-exec-2.1:2::gentoo [2.0.2:2::gentoo] PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_3) (python3_4) (python3_5)" 81 KiB
[ebuild     U  ] sys-apps/help2man-1.47.3::gentoo [1.47.2::gentoo] USE="nls" 181 KiB
[ebuild     U  ] sys-devel/automake-1.15-r1:1.15::gentoo [1.15:1.15::gentoo] 1,462 KiB
[ebuild     U  ] dev-db/sqlite-3.10.0:3::gentoo [3.9.2:3::gentoo] USE="icu readline static-libs -debug -doc -secure-delete -tcl {-test} -tools" 2,277 KiB
[ebuild     U  ] dev-lang/python-2.7.11-r2:2.7::gentoo [2.7.10-r3:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -libressl -tk -wininst" 12,003 KiB
[ebuild     U  ] dev-lang/python-3.3.5-r7:3.3/3.3m::gentoo [3.3.5-r2:3.3/3.3::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -doc -examples -hardened -libressl -tk -wininst" 11,845 KiB
[ebuild     U  ] app-eselect/eselect-python-20151117-r2::gentoo [20140125::gentoo] 62 KiB
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)
[ebuild     U  ] sys-apps/sandbox-2.10-r1::gentoo [2.9::gentoo] USE="(-multilib)" 408 KiB
[ebuild     U  ] app-admin/python-updater-0.14::gentoo [0.13::gentoo] 11 KiB
[ebuild  NS    ] dev-lang/python-3.4.3-r7:3.4/3.4m::gentoo [2.7.10-r3:2.7::gentoo, 3.3.5-r2:3.3::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -examples -hardened -libressl -tk -wininst" 14,096 KiB
[ebuild     U  ] dev-libs/libxml2-2.9.3:2::gentoo [2.9.2-r4:2::gentoo] USE="icu ipv6 python readline static-libs -debug -examples -lzma {-test}" PYTHON_TARGETS="python2_7 python3_4* -python3_3* -python3_5" 5,349 KiB
[ebuild     U  ] app-misc/ca-certificates-20151214.3.21::gentoo [20150426.3.20-r1::gentoo] USE="cacert" 287 KiB

Total: 16 packages (15 upgrades, 1 in new slot), Size of downloads: 62,105 KiB
Conflict: 1 block

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-apps/portage:0

  (sys-apps/portage-2.4.1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
                                                                                                                                                                                                                   


What can I try next?

Thanks,

donjames
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5879

PostPosted: Thu Mar 03, 2016 8:05 pm    Post subject: Reply with quote

Take the -p out, let it run, then try your original command again.
Back to top
View user's profile Send private message
donjames
Apprentice
Apprentice


Joined: 19 Dec 2004
Posts: 188
Location: Henderson, Texas USA

PostPosted: Sun Mar 06, 2016 3:10 pm    Post subject: Reply with quote

Still not working.
Back to top
View user's profile Send private message
cavalier911
n00b
n00b


Joined: 06 Mar 2016
Posts: 1

PostPosted: Mon Mar 07, 2016 6:40 am    Post subject: Reply with quote

Try to update currently installed versions of python and install python3_4 :
Code:
 # emerge -av1 =app-eselect/eselect-python-20151117-r2 =dev-lang/python:2.7 =dev-lang/python:3.3 =dev-lang/python-3.4.3-r7 =dev-lang/python-exec-2.1


If python update succeeds update portage and gentoolkit:
Code:
 # emerge -av1 =sys-apps/portage-2.4.1 =app-portage/gentoolkit-0.3.1
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1805
Location: Here and Away Again

PostPosted: Thu Mar 10, 2016 12:20 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.

This seems to be about Funtoo, so it will fit better here. :]
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum