Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wer will Okular?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Thu Mar 03, 2016 7:25 pm    Post subject: Wer will Okular? Reply with quote

Ich hab vor kurzem mal das KDE-Overlay eingebunden und versucht, das System weitestgehend auf KDE5 umzustellen. Bis auf die Tatsache, dass mir Breeze nicht gefällt und ich lieber ein Thema mit etwas mehr Abgrenzung der Elemente voneinander hätte, funktioniert das Meiste soweit.

Allerdings hab ich einen Konflikt bei Okular und weiß nicht, wie ich den beseitigen soll:
emerge -puDN world --verbose-conflicts:
* Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/okular-5.9999:5/5::kde, installed) pulled in by
    >=kde-apps/okular-5.9999:5 required by (app-editors/kile-9999:5/5::kde, installed)
    >=kde-apps/okular-5.9999:5[pdf?] (>=kde-apps/okular-5.9999:5[pdf]) required by (app-editors/kile-9999:5/5::kde, installed)

  (kde-apps/okular-15.12.2:4/15.12::kde, ebuild scheduled for merge) pulled in by
    kde-apps/okular required by @selected[/list]

An Use-Flags, die irgendwie Okular betreffen sind gesetzt:
[list][*]kde
[*]chm


Also hab ich dann in die package.use eingetragen:
/etc/portage/package.use/kde5.use:
kde-apps/okular:4 -kde -chm


Wie krieg ich den okular:4 aus der Liste raus?


Last edited by musv on Thu Mar 03, 2016 8:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Thu Mar 03, 2016 7:42 pm    Post subject: Reply with quote

Füge doch noch die tree option (-t) beim emerge aufruf hinzu.
Dann sollte man heraus welches paket okular:4 haben möchte.
Und ich glaube kaum, dass das ändern von useflags fürs okular ebuild hier was ändern wird.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Thu Mar 03, 2016 8:16 pm    Post subject: Reply with quote

-t gibt mir 'ne Liste von 336 Paketen.

Aber ich bin jetzt wieder zurück auf okular:4. Die 5-er Version kann irgendwie keine PDFs lesen (unknown mimetype).
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3686
Location: Hamburg

PostPosted: Thu Mar 03, 2016 8:17 pm    Post subject: Reply with quote

hilft auch bei solchen Fragen #gentoo-kde mE.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Thu Mar 03, 2016 11:58 pm    Post subject: Reply with quote

Beachte das kde-apps/okular-15.12.2:4
von der Version her eine höhere ist wie
kde-apps/okular-5.9999:5
Da portage stets die höchste freigeschaltete Version versucht (sofern keine Version oder ein Slot mit angegeben wird), wird hier die aus Slot:4 genommen (da sie die höhere Versionsnummer hat).
Siehe auch
musv wrote:
Code:
  (kde-apps/okular-15.12.2:4/15.12::kde, ebuild scheduled for merge) pulled in by
    kde-apps/okular required by @selected[/list]


Okular mit Angabe des Fünfer-Slots mit in @world aufnehmen sollte das Problem lösen
Code:
emerge -av --deselect kde-apps/okular
emerge -avn kde-apps/okular:5


musv wrote:
Aber ich bin jetzt wieder zurück auf okular:4. Die 5-er Version kann irgendwie keine PDFs lesen (unknown mimetype).
Hm, kann ich nicht bestätigen - tut hier einwandfrei.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri Mar 04, 2016 7:36 am    Post subject: Reply with quote

Die ganze KDE4->5-Problematik ist noch etwas neu für mich.

Heißt das im Klartext, dass kde-xxx/xxx-15.xxx:4 ist "mehr" KDE5 und neuer als kde-xxx/xxx-5.xxx:5?
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Fri Mar 04, 2016 7:59 am    Post subject: Reply with quote

musv wrote:
Die ganze KDE4->5-Problematik ist noch etwas neu für mich.

Heißt das im Klartext, dass kde-xxx/xxx-15.xxx:4 ist "mehr" KDE5 und neuer als kde-xxx/xxx-5.xxx:5?

Nein. Im Slot 4 ist immer noch auf basis von kde4
KDE hat vor ca einem halbe jahr die versionierung von applications umgestellt auf Jahr.Monat.
Durch diese Änderung ist die "Versionsnummer" größer (aus sicht von portage = neuer) als 5.x, wenn man ein Paket ohne slot angabe portage übergibt.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Mon Mar 07, 2016 8:04 am    Post subject: Reply with quote

15.12.2 ist die aktuelle Version von okular. Viele "Apps" sind noch nicht 100% auf Plasma 5 umgezogen.
Ich glaube daher auch nicht, dass es schon möglich ist, ein Plasma 5 System komplett ohne KDE-4 Pakete aufzubauen, ohne auf sehr viele Programme zu verzichten.

Auf meinem System sind noch 83 Pakete aus kde-* aus Slot 4.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum