Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireless drivers fail, go to fall back, then noad slowly.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
nullbites
n00b
n00b


Joined: 03 Mar 2016
Posts: 1

PostPosted: Thu Mar 03, 2016 8:22 pm    Post subject: Wireless drivers fail, go to fall back, then noad slowly. Reply with quote

The issue I am having is on the 4.5-rc6 kernel, I just downloaded and installed it a few days ago. I am using a Dell Latitude E6430 with a Centrino Ultimate-N 6300 card in it.

When I boot is that the wireless drivers don't load at first. They fail and fall back, but doing so almost always takes around 128 seconds. I tried building the correct firmware (iwlwifi-6000-4.ucode) into the kernel, but couldn't figure out how to do so. That might not be the right answer here, so I'll leave those errors out.

Here is the relevant parts of `dmesg`:

Code:
[   68.730983] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
[   68.730987] iwlwifi 0000:02:00.0: Falling back to user helper
[  128.756291] iwlwifi 0000:02:00.0: loaded firmware version 9.221.4.1 build 25532 op_mode iwldvm
[  128.756310] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG disabled
[  128.756312] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[  128.756313] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[  128.756315] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
[  128.756470] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[  128.792808] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[  128.795497] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
[  128.806994] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  128.807283] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[  128.814223] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[  128.814326] iwlwifi 0000:02:00.0: Radio type=0x0-0x3-0x1
[  129.032713] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[  129.039654] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[  129.039753] iwlwifi 0000:02:00.0: Radio type=0x0-0x3-0x1
[  129.132753] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  129.147151] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[  132.348648] wlp2s0: authenticate with a0:63:91:70:3d:f2
[  132.395215] wlp2s0: send auth to a0:63:91:70:3d:f2 (try 1/3)
[  132.398151] wlp2s0: authenticated
[  132.398258] wlp2s0: waiting for beacon from a0:63:91:70:3d:f2
[  132.427079] wlp2s0: associate with a0:63:91:70:3d:f2 (try 1/3)
[  132.434051] wlp2s0: RX AssocResp from a0:63:91:70:3d:f2 (capab=0x431 status=0 aid=2)
[  132.439075] wlp2s0: associated
[  132.439114] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Sun Mar 06, 2016 9:06 pm    Post subject: Reply with quote

Did you emerge linux-firmware for your drivers?
Also, build the relevant parts of the kernel as modules only (the iwlwifi related stuff).
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
droide
n00b
n00b


Joined: 27 Jul 2007
Posts: 23

PostPosted: Sat Mar 19, 2016 3:42 pm    Post subject: Reply with quote

I have the same problem
Bug : https://bugs.gentoo.org/show_bug.cgi?id=577774
_________________
https://blog.waccabac.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum