Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] USB headset doesn't use any of the SND_USB drivers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Bladesy
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2015
Posts: 113

PostPosted: Sat Mar 05, 2016 6:38 pm    Post subject: [SOLVED] USB headset doesn't use any of the SND_USB drivers Reply with quote

Hello all, I'm currently trying to get my USB headset working at the minute, and so to find out what driver it uses, I enabled all of the drivers in SND_USB, but oddly it doesn't seem to be using any, as it doesn't appear in pavucontrol and there's no extra drivers being used when I run lsmod. I get the feeling that maybe I havent investigated if its using a driver or not well enough, but I'm not exactly sure how to check an individual device for driver use. Even so, it doesn't seem to be appearing for use in any of my audio applications.
Does anyone have an idea of what's going on with my headset?
I initially thought this was a driver problem and not one with my audio set up, as I had the exact same setup on arch linux with a non-custom kernel - and the headset worked straight off the bat.
I'm not sure how relevant this is, but the headset is a Plantronics RIG, and I'm controlling pulseaudio through pavucontrol along with alsaplugin.
Also, I noticed some usb audio-related drivers under USB Support, like CONFIG_USB_EMI62 - but their description says something about MIDI devices.
Thanks in advance, just ask if you need me to run anything and gather more information about the headset or drivers.


Last edited by Bladesy on Fri Mar 25, 2016 4:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
Bladesy
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2015
Posts: 113

PostPosted: Fri Mar 18, 2016 8:41 pm    Post subject: Reply with quote

I wonder if it's good forum etiquette to bump an older thread...
Its just that I still haven't got around to fixing my headset, I'm pretty much out of ideas at this point.
Does anyone have any suggestions of things I could try?
Back to top
View user's profile Send private message
Bladesy
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2015
Posts: 113

PostPosted: Fri Mar 25, 2016 4:21 pm    Post subject: Reply with quote

Well, I've sorted it out - but I'm not sure what exactly what it was that did the trick.
You see, I recompiled all of my packages before and after reconfiguring my kernel, which was a little while ago - and I've just noticed the plantronics headset in pavucontrol.
So I guess this could mean that I never recompiled the kernel right the first few times, which is probably more likely than not setting up pulseaudio or alsa right the first time I compiled them.
The only problem is, the audio quality isn't too great - is this a known thing to happen with usb headsets using linux drivers? It could just be the fact that my non-usb headset sounds far better though.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum