Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Getting AMD R7 M265 to work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ShanaXXII
Apprentice
Apprentice


Joined: 29 Jun 2014
Posts: 281
Location: Canada

PostPosted: Mon Mar 07, 2016 11:57 pm    Post subject: Getting AMD R7 M265 to work Reply with quote

So I've been avoiding this for a while now..
My laptop has Intel graphics along with AMD graphics.
For the longest time, I was only using the Intel graphics because it was easy to get working.
But now, I would like to put my amd graphics to work. (:
I am not sure how I would go about getting it to work though :/
I believe this graphics card is one of those hybrid ones where it only draws the lines or something?
Don't know if amdgpu supports my graphics card (wiki says "R7 260", but mine is the mobile version "R7 M265") and not sure how to configure X to work with it(xorg.conf.d?, vgaswitcheroo?)
Code:
~ # lspci -k
...
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
   Subsystem: Lenovo Broadwell-U Integrated Graphics
   Kernel driver in use: i915
...
05:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265]
   Subsystem: Lenovo Opal XT [Radeon R7 M265]
...
Code:
~ $ dmesg | grep -i "amd"
[    0.127037] ACPI: Power Resource [PUBS] (on)
[    0.128418] ACPI: Power Resource [AMD3] (on)
[    0.128442] ACPI: Power Resource [AMD2] (on)

Would also like to know if this graphics card works on wayland via open-source drivers
Thank you :D
Back to top
View user's profile Send private message
Yggdrasil
n00b
n00b


Joined: 08 Jul 2004
Posts: 64
Location: Maybe on Earth, Maybe in the Future

PostPosted: Wed Mar 16, 2016 4:07 am    Post subject: Reply with quote

It seems like it should be supported through amdgpu, but only on a kernel of 4.5 or newer - this chipset was marked experimental before and it seems like your version in particular had an issue where it wouldn't load.

https://phoronix.com/scan.php?page=news_item&px=AMD-Iceland-Now-Stable

You'll probably want to configure your kernel like this, and also enable powerplay which I think should be under Graphics support.
https://wiki.gentoo.org/wiki/Amdgpu

However, I've never done anything with multiple graphic cards so I can't give much direction on that, from some searching it seems that some people on Arch had luck using PRIME fwiw.

Don't use wayland, so can't comment on that either. Hope that helps a little. :/
_________________
"We have/need art, so that we don't die of the truth." -- Friedrich Nietzsche
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum