Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201603-05 ] LibreOffice, OpenOffice
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Wed Mar 09, 2016 7:26 pm    Post subject: [ GLSA 201603-05 ] LibreOffice, OpenOffice Reply with quote

Gentoo Linux Security Advisory

Title: LibreOffice, OpenOffice: Multiple vulnerabilities (GLSA 201603-05)
Severity: normal
Exploitable: remote
Date: March 09, 2016
Bug(s): #521136, #522060, #528438, #534684, #547880, #547900, #565028
ID: 201603-05

Synopsis

Multiple vulnerabilities have been found in both LibreOffice and
OpenOffice allowing remote attackers to execute arbitrary code or cause
Denial of Service.


Background

Apache OpenOffice is the leading open-source office software suite for
word processing, spreadsheets, presentations, graphics, databases and
more.
LibreOffice is a powerful office suite; its clean interface and powerful
tools let you unleash your creativity and grow your productivity.


Affected Packages

Package: app-office/libreoffice
Vulnerable: < 4.4.2
Unaffected: >= 4.4.2
Architectures: All supported architectures

Package: app-office/libreoffice-bin
Vulnerable: < 4.4.2
Unaffected: >= 4.4.2
Architectures: All supported architectures

Package: app-office/libreoffice-bin-debug
Vulnerable: < 4.4.2
Unaffected: >= 4.4.2
Architectures: All supported architectures

Package: app-office/openoffice-bin
Vulnerable: < 4.1.2
Unaffected: >= 4.1.2
Architectures: All supported architectures


Description

Multiple vulnerabilities were found in both LibreOffice and OpenOffice
that allow the remote execution of arbitrary code and potential Denial of
Service. These vulnerabilities may be exploited through multiple vectors
including crafted documents, link handling, printer setup in ODF document
types, DOC file formats, and Calc spreadsheets. Please review the
referenced CVE’s for specific information regarding each.


Impact

A remote attacker could entice a user to open a specially crafted file
using the LibreOffice or OpenOffice suite of software. Execution of
these attacks could possibly result in the execution of arbitrary code
with the privileges of the process or a Denial of Service condition.


Workaround

There is no known work around at this time.

Resolution

All LibreOffice users should upgrade their respective packages to the
latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-office/libreoffice-4.4.2"
      # emerge --ask --oneshot --verbose
      ">=app-office/libreoffice-bin-4.4.2"# emerge --ask --oneshot --verbose
      ">=app-office/libreoffice-bin-debug-4.4.2"
   
All OpenOffice users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-office/openoffice-bin-4.1.2"
   


References

CVE-2014-3524
CVE-2014-3575
CVE-2014-3693
CVE-2014-9093
CVE-2015-1774
CVE-2015-4551
CVE-2015-5212
CVE-2015-5213
CVE-2015-5214
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum