Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201603-10 ] QtGui
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Sat Mar 12, 2016 3:26 pm    Post subject: [ GLSA 201603-10 ] QtGui Reply with quote

Gentoo Linux Security Advisory

Title: QtGui: Multiple vulnerabilities (GLSA 201603-10)
Severity: normal
Exploitable: remote
Date: March 12, 2016
Bug(s): #546174
ID: 201603-10

Synopsis

Multiple vulnerabilities have been found in QtGui allowing remote
attackers to execute arbitrary code or cause Denial of Service.


Background

QtGui is the GUI module and platform plugins for the Qt framework

Affected Packages

Package: dev-qt/qtgui
Vulnerable: < 5.4.1-r1
Unaffected: >= 5.4.1-r1
Unaffected: >= 4.8.6-r4 < 4.8.7
Unaffected: >= 4.8.7 < 4.8.8
Architectures: All supported architectures


Description

Multiple buffer overflow vulnerabilities have been discovered in QtGui.
It is possible for remote attackers to construct specially crafted BMP,
ICO, or GIF images that lead to buffer overflows. After successfully
overflowing the buffer the remote attacker can then cause a Denial of
Service or execute arbitrary code.


Impact

A remote attacker could possibly execute arbitrary code or cause Denial
of Service.


Workaround

There is no known work around at this time.

Resolution

All QtGui 4.8 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-qt/qtgui-4.8.6-r4"
   
All QtGui 5.4 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-qt/qtgui-5.4.1-r1"
   


References

CVE-2015-1858
CVE-2015-1859
CVE-2015-1860
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum