Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NTFS drive needs to be fixed after Windows shutdown [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
alienjon
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1689

PostPosted: Sun Mar 13, 2016 5:32 pm    Post subject: NTFS drive needs to be fixed after Windows shutdown [solved] Reply with quote

I dual boot Gentoo and Windows 10. I have a separate storage drive formatted as NTFS that is used by both OS. Since upgrading to Windows 10 I've found that often (though I don't think every time) I shutdown Windows, when I then boot into Gentoo I get complaints that the storage drive wasn't left in a stable state (I don't have the error right in front of me, but can post the next time it happens). Running ntfsfix on the partition fixes the problem, but I find that I have to do this each time. In trying to mount my Windows drive just now I got a similar problem:

mount /dev/sdb3:
Windows is hibernated, refused to mount.
Failed to mount '/dev/sdb3': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.


Mounting ro will allow the mount, but I'm not sure what's going on. It wasn't in hibernation and this was a shutdown, not restart (though maybe I'm guessing it's related to the latter). I feel this is an easy fix (probably need to disable some hibernation/booting option in Windows) but I'm not sure what I'm looking for.


Last edited by alienjon on Sun Mar 13, 2016 6:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 419

PostPosted: Sun Mar 13, 2016 5:59 pm    Post subject: Reply with quote

The reason is the new "fast startup" feature of windows 8, 8.1 and 10. The system hibernates instead of shutting down, which leaves the ntfs filesystem in a state which is dangerous to alter until windows is started again. Current linux software knows about that and prevents mounting rw.

http://itsfoss.com/solve-ntfs-mount-problem-ubuntu-windows-8-dual-boot/
Back to top
View user's profile Send private message
alienjon
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1689

PostPosted: Sun Mar 13, 2016 6:40 pm    Post subject: Reply with quote

That explains it then. It mentions disabling the fast startup feature as a 'permanent' solution. What about scripting ntfsfix to run at boot? Though, I suppose, that's not really addressing the issue...
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1696

PostPosted: Mon Mar 14, 2016 1:20 am    Post subject: Reply with quote

the thing is, there isn't much of a good solution as it's mostly because of Windows are not unmounting the drive specifically. By disabling fast startup in windows, it will cause windows to do the proper thing and shutdown the ntfs drives as they should be doing.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum