Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't transfer files with Bluetooth
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 973
Location: Stuart, Florida

PostPosted: Sun Mar 13, 2016 9:06 pm    Post subject: Can't transfer files with Bluetooth Reply with quote

I can't transfer files with Bluetooth on Gentoo and I don't understand why. This includes both my Android PC and an old EEE PC running Linux Mint.

I am able to pair with devices (although with difficulty). I wonder whether the various bluetooth packages I have installed are somehow stepping on each other.

I have gone through the Bluetooth HOWTO and the setup looks OK.

I am running an amd64 system using primarily KDE. The Bluetooth packages I have installed are the following.

I would appreciate your help.



    net-wireless/bluedevil-2.1.1
    net-libs/libbluedevil-2.1
    net-wireless/blueman-1.23_p20140717-r1:
    net-wireless/bluez-5.37
    net-wireless/bluez-hcidump-2.5
    sys-firmware/bluez-firmware-1.2


emerge --info follows:

    ]bopper download # emerge --info bluez
    Portage 2.2.26 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.21-r2, 4.1.15-gentoo-r1 x86_64)
    =================================================================
    System Settings
    =================================================================
    System uname: Linux-4.1.15-gentoo-r1-x86_64-AMD_Phenom-tm-_II_X4_970_Processor-with-gentoo-2.2
    KiB Mem: 16429452 total, 7735248 free
    KiB Swap: 1021948 total, 1021948 free
    Timestamp of repository gentoo: Sun, 13 Mar 2016 20:30:01 +0000
    sh bash 4.3_p42-r1
    ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
    app-shells/bash: 4.3_p42-r1::gentoo
    dev-java/java-config: 2.2.0::gentoo
    dev-lang/perl: 5.20.2::gentoo
    dev-lang/python: 2.7.10-r1::gentoo, 3.3.5-r2::gentoo, 3.4.3-r1::gentoo
    dev-util/cmake: 3.3.1-r1::gentoo
    dev-util/pkgconfig: 0.28-r2::gentoo
    sys-apps/baselayout: 2.2::gentoo
    sys-apps/openrc: 0.19.1::gentoo
    sys-apps/sandbox: 2.10-r1::gentoo
    sys-devel/autoconf: 2.13::gentoo, 2.69::gentoo
    sys-devel/automake: 1.10.3-r1::gentoo, 1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
    sys-devel/binutils: 2.25.1-r1::gentoo
    sys-devel/gcc: 4.9.3::gentoo
    sys-devel/gcc-config: 1.7.3::gentoo
    sys-devel/libtool: 2.4.6::gentoo
    sys-devel/make: 4.1-r1::gentoo
    sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
    sys-libs/glibc: 2.21-r2::gentoo
    Repositories:

    gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

    x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

    ACCEPT_KEYWORDS="amd64"
    ACCEPT_LICENSE="* -@EULA"
    CBUILD="x86_64-pc-linux-gnu"
    CFLAGS="-O2 -pipe"
    CHOST="x86_64-pc-linux-gnu"
    CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
    CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
    CXXFLAGS="-O2 -pipe"
    DISTDIR="/usr/portage/distfiles"
    FCFLAGS="-O2 -pipe"
    FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
    FFLAGS="-O2 -pipe"
    GENTOO_MIRRORS="http://distfiles.gentoo.org"
    LANG="en_US.UTF-8"
    LDFLAGS="-Wl,-O1 -Wl,--as-needed"
    MAKEOPTS="-j2"
    PKGDIR="/usr/portage/packages"
    PORTAGE_CONFIGROOT="/"
    PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
    PORTAGE_TMPDIR="/var/tmp"
    USE="3dnow X Xaw3d a52 aac aalib acl acpi aim alsa amd64 ao apache2 apm audiofile avahi berkdb bidi blas bluetooth branding bzip2 cairo calendar caps cdda cddb cdinstall cdparanoia cdr cgi clamav cli consolekit cracklib crypt css ctype cups curl cvs cxx dbi dbm dbus dbx dga directfb dri dts dv dvb dvd dvdr emboss encode enscript evo examples exif expat fam fastcgi fbcon firefox flac fontconfig foomaticdb fortran freetype ftp gcj gdbm gif gimp glamor glu gmp gnuplot gnutls gphoto2 gpm graphviz gsl gsm gstreamer guile gzip hal handbook hddtemp httpd iconv icq icu idn ieee1394 imagemagick imlib innodb introspection iodbc ipv6 jabber java java6 javascript jbig jingle jpeg jpeg2k kde kontact lapack lcms ldap libcaca libedit libgda libnotify libwww lm_sensors lua lzma lzo mad maildir matroska mikmod milter mime mmap mmx mmxext mng modules motif mozilla mp3 mp4 mpeg mpi mplayer msn multilib musepac mysql mysqli nas ncurses networkmanager nls nntp nptl nsplugin odbc offensive ofx ogg oggvorbis opengl openmp osc oscar oss pam pango pch pcntl pcre pdf perl php plasma plotutils png policykit portaudio posix postgres ppds pulseaudio python qt3support qt4 quicktime raw rdesktop readline rss ruby samba sasl sdl seccomp semantic-desktop session sharedext sharedmem simplexml smp sndfile snmp soap sockets socks5 speex spell sqlite sqlite3 sse sse2 ssl startup-notification stream subversion suid svg symlink syslog sysvipc szip tcl tcpd theora threads tidy tiff timiditytk tokenizer truetype udev udisks unicode upower usb v4l v4l2 vcd vlm vorbis win32codecs wmf wxwidgets x264 xattr xcb xcomposite xft xine xinerama xinetd xml xnlrpc xosd xv xvid yahoo zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="nvidia nouveau" XFCE_PLUGINS="brightness menu trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
    Unset: CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

    =================================================================
    Package Settings
    =================================================================

    net-wireless/bluez-5.37::gentoo was built with the following:
    USE="cups obex readline udev -debug -doc -extra-tools (-selinux) -systemd -test -test-programs" ABI_X86="64 -32 -x32" PYTHON_TARGETS="python2_7"

    bopper download #
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 812

PostPosted: Wed Apr 13, 2016 12:15 pm    Post subject: Reply with quote

you probably need a program/protocol to actually exchange data (eg app-mobilephone/obexftp), i think the bluetooth-setup just prepares your hardware for that.
search for obex in portage:
Code:
emerge -s obex

GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 973
Location: Stuart, Florida

PostPosted: Wed Apr 13, 2016 3:16 pm    Post subject: Reply with quote

I emerged obexftp and obexfs with the same result: File transfers still fail often before I have a chance to accept the file transfer.

Several applications seem to be involved with Bluetooth and I wonder whether they don't conflict.

There is for example, a "Blueman Applet" that runs but apparently has no controls. There is also another applet, Bluetooth that lets you see connected devices and supposedly set up these devices. It was promising that this applet has a button, "Setup NAP Network", that doesn't seem to do anything. I can send files to my phone, but this is not usually what I need to do. There is also a "Trusted" toggle that can be set but doesn't seem to do anything either.

The Bluetooth tab in SystemSettings seems to be the same as the Bluetooth applet.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum