Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mac Pro 2015 - Kernel 4.1.15 - Braodcom Wireless
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Fri Mar 18, 2016 2:42 pm    Post subject: Reply with quote

ankh2054 wrote:
f /lib/firmware/brcm/brcmfmac43602-pcie.bin did not exist, so I copied from /usr/src/linux-4.1.15-gentoo-r1/firmware/brcmfmac/brcmfmac43602-pcie.bin.]

Why not from https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/tree/brcm as suggested by https://wireless.wiki.kernel.org/en/users/drivers/brcm80211#brcmfmac? No clue if both are the same.
And then again check modinfo brcmfmac.
Back to top
View user's profile Send private message
ankh2054
n00b
n00b


Joined: 15 Mar 2016
Posts: 33
Location: London UK

PostPosted: Fri Mar 18, 2016 3:17 pm    Post subject: Reply with quote

all,

thanks for you help so far. I've got other issues no cropping up in that I cannot install git due to some python package failing.
My system doesn't boot now after using the driver from the GIT repository.

I also installed networkmanager so maybe it has something to do with that, not sure.


Once I have a bootable system ill be back :)
_________________
www.bommachine.co.uk
Back to top
View user's profile Send private message
ankh2054
n00b
n00b


Joined: 15 Mar 2016
Posts: 33
Location: London UK

PostPosted: Fri Mar 18, 2016 5:04 pm    Post subject: Reply with quote

Hi all,

I'm back with a booting system.

I've installed network manager and added it to state at bootup and removed the old ETH0 reference.
It now automatically brings up the interface wlp4s0.

Can I safely assume this is now working?

If so then I need to now find a way do make network-manager show up in XFCE, but I will do some research first.
_________________
www.bommachine.co.uk
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Fri Mar 18, 2016 5:13 pm    Post subject: Reply with quote

ankh2054 wrote:
It now automatically brings up the interface wlp4s0.

Can I safely assume this is now working?

If it works, yes.
Does it work? Do you get a reasonable IP number in ifconfig wlp4s0 and can you connect to your access point(s)?
Gnome networkmanager is unknown territory for me, sorry.
Back to top
View user's profile Send private message
ankh2054
n00b
n00b


Joined: 15 Mar 2016
Posts: 33
Location: London UK

PostPosted: Mon Mar 21, 2016 8:56 am    Post subject: Reply with quote

all,

many thanks for your help. It is all working now. The interface error has disappeared and I can connect to wireless networks.
_________________
www.bommachine.co.uk
Back to top
View user's profile Send private message
archenroot
Apprentice
Apprentice


Joined: 13 Dec 2011
Posts: 203
Location: Lake Macha, Czech republic

PostPosted: Fri Apr 28, 2017 7:54 am    Post subject: Reply with quote

I resolved this chip on Dell XPS 15 9550, but there are still networks which causes kernel-panic, probably related to specific channel issue.

I discussed this here and in general main issue was resolved, but still sometimes not so I even consider replace the chip in my laptop for different one...

https://forums.gentoo.org/viewtopic-p-8061774.html#8061774
_________________
Emperor wants to control outer space Yoda wants to explore inner space that's the fundamental difference between good and bad sides of the Force
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum