Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Wifi] Intel Wireless 8260 (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ruddy32
n00b
n00b


Joined: 07 May 2014
Posts: 40
Location: France

PostPosted: Sat Mar 19, 2016 8:46 am    Post subject: [Wifi] Intel Wireless 8260 (solved) Reply with quote

Hi,

After configuring wifi acces point in wpa configuration, wpa_supplicant show this information
Code:
wpa_supplicant : could not read interface p2p-dev-wlp4s0 flags: no such device


The system is configured with NetworkManager.

Journal logs :
Code:
# journalctl -b --no-pager|grep iwlwifi
Mar 14 19:06:47 lt002 kernel: iwlwifi 0000:04:00.0: enabling device (0000 -> 0002)
Mar 14 19:06:47 lt002 kernel: iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-8000C-19.ucode failed with error -2
Mar 14 19:06:47 lt002 kernel: iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-8000C-18.ucode failed with error -2
Mar 14 19:06:47 lt002 kernel: iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-8000C-17.ucode failed with error -2
Mar 14 19:06:47 lt002 kernel: iwlwifi 0000:04:00.0: Unsupported splx structure
Mar 14 19:06:47 lt002 kernel: iwlwifi 0000:04:00.0: loaded firmware version 16.242414.0 op_mode iwlmvm
Mar 14 19:06:48 lt002 kernel: iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x208
Mar 14 19:06:48 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 19:06:48 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 19:06:48 lt002 kernel: iwlwifi 0000:04:00.0: can't access the RSA semaphore it is write protected
Mar 14 19:06:48 lt002 kernel: iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0
Mar 14 19:06:51 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 19:06:51 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 19:06:51 lt002 kernel: iwlwifi 0000:04:00.0: [b]can't access the RSA semaphore it is write protected[/b]
Mar 14 19:06:51 lt002 NetworkManager[453]: <info>  rfkill1: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.2/0000:04:00.0/ieee80211/phy0/rfkill1) (driver iwlwifi)
Mar 14 19:06:51 lt002 NetworkManager[453]: <info>  (wlp4s0): new 802.11 WiFi device (carrier: UNKNOWN, driver: 'iwlwifi', ifindex: 3)
Mar 14 19:06:51 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 19:06:51 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 19:06:51 lt002 kernel: iwlwifi 0000:04:00.0: can't access the RSA semaphore it is write protected
Mar 14 20:13:33 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 20:13:33 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 20:13:33 lt002 kernel: iwlwifi 0000:04:00.0: can't access the RSA semaphore it is write protected
Mar 14 20:13:33 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 20:13:33 lt002 kernel: iwlwifi 0000:04:00.0: L1 Enabled - LTR Enabled
Mar 14 20:13:33 lt002 kernel: iwlwifi 0000:04:00.0: can't access the RSA semaphore it is write protected


wpa_supplicant return :
Code:
# wpa_supplicant -B -i wlp4s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Successfully initialized wpa_supplicant
Could not read interface [b]p2p-dev-[/b]wlp4s0 flags: No such device
nl80211: Could not set interface '[b]p2p-dev-[/b]wlp4s0' UP
nl80211: deinit ifname=[b]p2p-dev-[/b]wlp4s0 disabled_11b_rates=0
[b]p2p-dev-[/b]wlp4s0: Failed to initialize driver interface
P2P: Failed to enable P2P Device interface


A new firmware is available for Intel Wireless 8260 : iwlwifi-8000C-21.ucode. How to make this firmware loaded at boot time? (Currently the system try to load iwlwifi-8000C-19.ucode)

Is it a configuration or driver problem?[/b]
_________________
ruddy32


Last edited by ruddy32 on Tue Mar 22, 2016 8:55 am; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2599

PostPosted: Sat Mar 19, 2016 2:29 pm    Post subject: Reply with quote

No experience with journalctl, sorry.
What is the exact device according to your output of lspci?
On the wiki article you should find everything needed for iwlwifi.
Back to top
View user's profile Send private message
ruddy32
n00b
n00b


Joined: 07 May 2014
Posts: 40
Location: France

PostPosted: Sat Mar 19, 2016 5:05 pm    Post subject: Reply with quote

lspci -k shows
Code:
04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
   Subsystem: Intel Corporation Device 1010
   Kernel driver in use: iwlwifi
   Kernel modules: iwlwifi
[/code]

lsmod | grep iwl shows
Code:
iwlmvm                241664  0
mac80211              647168  1 iwlmvm
iwlwifi               163840  1 iwlmvm
cfg80211              483328  3 iwlwifi,mac80211,iwlmvm
led_class              16384  2 iwlmvm,input_leds


What does mean the following log ?
Code:
Mar 14 19:06:51 lt002 kernel: iwlwifi 0000:04:00.0: can't access the RSA semaphore it is write protected

Is it problem with the driver ? Or configuration ?
_________________
ruddy32
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2599

PostPosted: Mon Mar 21, 2016 3:17 pm    Post subject: Reply with quote

ruddy32 wrote:
What does mean the following log ?
Code:
Mar 14 19:06:51 lt002 kernel: iwlwifi 0000:04:00.0: can't access the RSA semaphore it is write protected

Is it problem with the driver ? Or configuration ?

ruddy32

The Intel Wireless 8260 device is still quite new and there might be unresolved bugs in its implementation.
There is evidence in this forum post for a kernel bug.

Which kernel version is causing your problem? Try one including this patch.
Back to top
View user's profile Send private message
ruddy32
n00b
n00b


Joined: 07 May 2014
Posts: 40
Location: France

PostPosted: Mon Mar 21, 2016 6:31 pm    Post subject: Reply with quote

The system is installed with kernel 4.4.5-1.
_________________
ruddy32
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2599

PostPosted: Tue Mar 22, 2016 5:40 am    Post subject: Reply with quote

ruddy32 wrote:
The system is installed with kernel 4.4.5-1.

Did you try sys-kernel/gentoo-sources:4.1.20?
And, in case you were having some misconfiguration, you should also try with the latest version of https://sysresccd.org/

Edit:
What about "rmmod iwlwifi iwlmvm" and "modprobe iwlwifi" fromhttps://www.reddit.com/r/archlinux/comments/412vbq/iwlwifi_sometimes_fails_to_load_the_device/?
Back to top
View user's profile Send private message
ruddy32
n00b
n00b


Joined: 07 May 2014
Posts: 40
Location: France

PostPosted: Tue Mar 22, 2016 8:53 am    Post subject: Reply with quote

I solve the problem after resetting the dhcp server nd the acces point, and then removing the wireless interface from the laptop.

I don't know what's going wrong. It works evenif I still have the RSA error message in the log.

Thanks.
_________________
ruddy32
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum