Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Ungewollter remount der externen HDD
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 92
Location: Erfurt

PostPosted: Thu Mar 31, 2016 1:10 pm    Post subject: [gelöst] Ungewollter remount der externen HDD Reply with quote

Hallo zusammen,

ich habe folgendes Problem mit meiner externen Festplatte, die ich gern als BackUpDrive nehmen möchte.
Nach dem Hochfahren oder ersten anstöpseln wird sie als /dev/sdc2 eingehängt. Dann kann ich sie ent-
schlüsseln und mounten. Doch während das rdiff-backup läuft, sorgt ein mir unbekannter Prozess dafür,
dass sie rausgeschmissen, d.h. ohne umount und Wiederverschlüsselung, und als /dev/sdd2 wieder
eingehängt und gemountet wird, allerdings nur read-only. Denn durch den ungewollten Rausschmiss muss
erstmal ein fsck drüberlaufen.
Ich hatte erst udisks in Veracht, da dass zumindest bei der 1er-Version in Konkurrenz zu fstab stehen kann.
Zudem fehlte mir udisks als ausführbare Datei, weswegen ich kein '--inhibit-polling' oder '--detach' ausführen
konnte. Daher habe ich udisks kurzerhand entfernt. Aber das Problem besteht weiterhin und gefühlt sogar
agressiver, denn jetzt tritt der Wechsel zwischen sdc und sdd bereist beim fsck auf.

Hat irgendjemand eine Idee oder schon mal ein ähnliches Problem gehabt?
Relevante Systemdaten poste ich gern auf Nachfrage, denn ich weiß nicht welche hier interessant sein könnten.


Beste Grüße und vielen lieben Dank, rogge


Last edited by rogge on Tue Jan 31, 2017 9:41 am; edited 1 time in total
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1733
Location: St. Wendel

PostPosted: Thu Mar 31, 2016 1:27 pm    Post subject: Reply with quote

Klingt eher nach einem USB, bzw. Verbindungsproblem. Wäre es ein Prozess, würdest du das im Log sehen. Ich würde mal im dmesg nach USB events schauen.
Back to top
View user's profile Send private message
frank9999
n00b
n00b


Joined: 20 Feb 2013
Posts: 61
Location: Germany

PostPosted: Thu Mar 31, 2016 1:43 pm    Post subject: Reply with quote

Ich hatte vor ein paar Wochen das gleiche Problem.
Bei mir was es nach einigem suchen, das USB 3 Kabel der HDD.
Zum Glück hat das externe Gehäuse eine Buchse für das Kabel gehabt und war nicht fest verbunden, so das ich es einfach tauschen konnte.
Back to top
View user's profile Send private message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 92
Location: Erfurt

PostPosted: Thu Mar 31, 2016 3:22 pm    Post subject: Reply with quote

@py-ro: Gut, dass du es sagst. Ich hatte tatsächlich schon on die Logs geschaut. Die geben folgendes wieder:

Quote:

[13336.605316] usb 1-1: USB disconnect, device number 18
[13336.605852] scsi 21:0:0:0: rejecting I/O to offline device
[13336.605854] scsi 21:0:0:0: [sdc] killing request
[13336.605857] scsi 21:0:0:0: rejecting I/O to offline device
[13336.605858] scsi 21:0:0:0: [sdc] killing request
[13336.605859] scsi 21:0:0:0: rejecting I/O to dead device
[13336.605863] quiet_error: 1717 callbacks suppressed
[13336.605865] Buffer I/O error on device dm-1, logical block 74935764
[13336.605866] lost page write due to I/O error on dm-1
...
[13336.605909] scsi 21:0:0:0: rejecting I/O to dead device
...
[13336.609485] scsi 21:0:0:0: [sdc]
[13336.609486] Result: hostbyte=0x01 driverbyte=0x00
[13336.609488] scsi 21:0:0:0: [sdc] CDB:
[13336.609489] cdb[0]=0x2a: 2a 00 27 75 05 7a 00 00 f0 00
[13336.609493] end_request: I/O error, dev sdc, sector 661980538
[13336.609527] scsi 21:0:0:0: [sdc]
[13336.609529] Result: hostbyte=0x01 driverbyte=0x00
[13336.609530] scsi 21:0:0:0: [sdc] CDB:
[13336.609530] cdb[0]=0x2a: 2a 00 27 75 06 6a 00 00 f0 00
[13336.609534] end_request: I/O error, dev sdc, sector 661980778
[13336.826050] usb 1-1: new high-speed USB device number 19 using ehci-pci
[13336.906974] REISERFS warning (device dm-1): sh-2029: %s: bitmap block (#%u) reading failed reiserfs_read_bitmap_block: reiserfs_read_bitmap_block
...
[13336.941013] usb 1-1: New USB device found, idVendor=1058, idProduct=1003
[13336.941016] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[13336.941018] usb 1-1: Product: External HDD
[13336.941019] usb 1-1: Manufacturer: Western Digital
[13336.941020] usb 1-1: SerialNumber: 57442D574341563537353939323903
[13336.941522] usb-storage 1-1:1.0: USB Mass Storage device detected
[13336.943093] scsi host22: usb-storage 1-1:1.0
...
[13337.948521] scsi 22:0:0:0: Direct-Access WD 10EADS External 1.75 PQ: 0 ANSI: 4
[13337.948702] sd 22:0:0:0: Attached scsi generic sg3 type 0
[13337.949532] sd 22:0:0:0: [sdd] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[13337.950268] sd 22:0:0:0: [sdd] Write Protect is off
[13337.950271] sd 22:0:0:0: [sdd] Mode Sense: 23 00 00 00
[13337.950889] sd 22:0:0:0: [sdd] No Caching mode page found
[13337.950891] sd 22:0:0:0: [sdd] Assuming drive cache: write through
...
[13337.969021] sdd: sdd1 sdd2
[13337.971894] sd 22:0:0:0: [sdd] Attached SCSI disk
...
[13338.475720] REISERFS abort (device dm-1): Journal write error in flush_commit_list
[13338.573464] rdiff-backup (15483) used greatest stack depth: 11328 bytes left
...
[13369.507059] quiet_error: 50375 callbacks suppressed
[13369.507062] Buffer I/O error on device dm-1, logical block 12713989


@frank9999: Kabel könnte sein, obwohl das Teil still steht und nicht angerührt wird. Das Originalkabel ist verschwunden, daher habe ich das vom Mp3-Player genommen, das da auch immer tadellos funktionierte.
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1733
Location: St. Wendel

PostPosted: Thu Mar 31, 2016 3:29 pm    Post subject: Reply with quote

Das ist zu 90% ein USB Problem.
Back to top
View user's profile Send private message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 92
Location: Erfurt

PostPosted: Thu Mar 31, 2016 3:51 pm    Post subject: Reply with quote

Dann halte ich mal Ausschau nach einem neuen/anderen Kabel. Danke!
Back to top
View user's profile Send private message
frank9999
n00b
n00b


Joined: 20 Feb 2013
Posts: 61
Location: Germany

PostPosted: Thu Mar 31, 2016 6:06 pm    Post subject: Reply with quote

Auf den ersten Blick sieht es sehr nach USB Problemen aus.
Ich würde zusätzlich dann aber trotzdem noch empfehlen, die SMART Werte der HDD genauer anzusehen.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Apr 15, 2016 9:23 am    Post subject: Hier gilt ausnahmsweise: je länger, desto schlechter... Reply with quote

Derlei Probleme habe ich schon relativ häufig, sowohl mit USB 2.0 als auch mit 3.0 gehabt.
Ich führe sie letztlich auf zu großen Spannungsabfall im Kabel zurück.

Besonders an passiven Kabeln/Hubs reichten häufig schon zwei 2,5" Platten aus um das bei mir zu reproduzieren.
Da half dann meist ein aktiver Hub weiter.

Nur nicht in einem Fall, bei dem die Leitungslänge einige Meter mit Zwischensteckern betrug und zwei aktive Hubs hintereinander hingen.
Nachdem ich einen aktiven alten Hub aus der Kette heraus nahm, wurde es besser.

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
rogge
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2006
Posts: 92
Location: Erfurt

PostPosted: Tue Jan 31, 2017 9:41 am    Post subject: Reply with quote

Es lag tatsächlich am Kabel. Ein originales WD-Kabel hat das Problem gelöst...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum