Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVED kernel 4.1.15-gentoo-r1 breaks Wi-Fi hotspot set up
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 523
Location: Germany

PostPosted: Tue Apr 05, 2016 6:06 pm    Post subject: SOLVED kernel 4.1.15-gentoo-r1 breaks Wi-Fi hotspot set up Reply with quote

I have small computer with Wi-Fi card configured to work as WLan hot spot, so that I can access internet for other devices over Wifi. Last week I've upgraded kernel from 4.1.12 to 4.1.15-gentoo-r1 and after reboot discovered that my set up does not work anymore. I used "make oldconfig" to configure new version. Any hints on what was changed that would break this functionality? For now I've booted old version, but I'm still curious if something can be adjusted for it to work with new kernel.

Last edited by v_andal on Wed Apr 06, 2016 10:13 am; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Tue Apr 05, 2016 8:55 pm    Post subject: Reply with quote

you may try a much newer kernel and see if it works or not(maybe it does).

The suggested way is to do a diff, build that diff kernel and step down where the bug was introduced.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Wed Apr 06, 2016 8:00 am    Post subject: Re: kernel 4.1.15-gentoo-r1 breaks Wi-Fi hotspot set up Reply with quote

v_andal wrote:
Last week I've upgraded kernel from 4.1.12 to 4.1.15-gentoo-r1 and after reboot discovered that my set up does not work anymore. I used "make oldconfig" to configure new version.

Within the same kernel line there's no need for the "oldconfig" target. You could have started "make && make modules_install" just using the .config file copied over from 4.1.12.
Could you do
Code:
diff /usr/src/linux-4.1.15-gentoo-r1/.config /usr/src/linux-4.1.12-gentoo/.config
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 564
Location: France

PostPosted: Wed Apr 06, 2016 8:05 am    Post subject: Reply with quote

Is the driver needed for your wifi card loaded (which one is it, by the way ?) ? If needed, did you emerge @module-rebuild after installing the new kernel ?
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 523
Location: Germany

PostPosted: Wed Apr 06, 2016 10:13 am    Post subject: Reply with quote

Sorry. To check all suggestions I've booted again into 4.1.15 and surprise, everything works. Weird.

The only thing that I've changed (aside from reboot) was the installation of gentoo-sources-4.5.0 (I've tried to boot that but it produced kernel panic)

So, for now I'll mark it as "solved", unless the glitch comes up again in near future.

Thank you for all input.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum