Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ATI fglrx and once again, HD 5430
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
fesst
n00b
n00b


Joined: 12 Apr 2016
Posts: 2

PostPosted: Wed Apr 13, 2016 10:19 am    Post subject: ATI fglrx and once again, HD 5430 Reply with quote

Can somebody tell me how I can find appropriate set of xorg-server, ati-drivers and kernel versions that will be work correctly for Radeon Evergreen HD 5430? I tried xorg-1.17 and xorg-1.16 with ati-drivers-15.9-r1, xorg-1.16 with ati-drivers-15.12; with kernel 4.1.15-r1. all the time I got the black screen. If I will light my notebook screen with flashlight from phone, I can see that xdm has been started and shows login, but it is absolutely unhighlighted. What info should I provide to get some help? :D

emerge --info
http://pastebin.com/gQ0isuJJ

.config
http://pastebin.com/0gsYdRKa


P.S. I'm totally disappointed, last time I had installed Gentoo, there was working ati-drivers-13.4 in repository, but it was cleaned and new versions are not working, there is no info about this changes in https://wiki.gentoo.org/wiki/Fglrx
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Wed Apr 13, 2016 1:22 pm    Post subject: Reply with quote

When does the screen go black - during boot or when it starts X?
May be a kernel problem too, my laptop screen goes black during kernel initialization, alas it uses intelhd graphics....
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
fesst
n00b
n00b


Joined: 12 Apr 2016
Posts: 2

PostPosted: Wed Apr 13, 2016 2:21 pm    Post subject: Reply with quote

eccerr0r wrote:
When does the screen go black - during boot or when it starts X?
May be a kernel problem too, my laptop screen goes black during kernel initialization, alas it uses intelhd graphics....


No, it is just happening after
# /etc/init.d/xdm start
with most popular ati's "black screen". But I can see mouse and other things, I have tried to find some Xorg/ati/kernel settings to change backlight but did not make a go of it.

i have installed x11-apps/xdm. Intentionally did not add xdm to any runlevel remembering about such problems, so, I can do whatever I want on ugly 640x480 (or even less) before starting xdm script.
The most upset thing is guide suggesting unexisted packages, I became to hope that ATI has fixed themselves. Haha.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum