Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Weird LVM issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Abraxas
l33t
l33t


Joined: 25 May 2003
Posts: 807

PostPosted: Thu Apr 14, 2016 4:29 pm    Post subject: Weird LVM issue Reply with quote

I rebooted after a kernel update and got a weird error about multipath not being able to find the target device or something like that. Now I don't even know what multipath does to be honest. I haven't used it before. I guess it installed when I installed gparted with all the USE FLAGS enabled. It was required by dmraid USE FLAG. Anyway I just rebuilt it and everything worked again after rebooting. I was working on making a bootable USB drive after that. I rebooted to test it. The test failed so I went back into my system and got the same error again. I don't use multipath so I decided to remove it and that fixed the issue, or so I thought. I rebooting and everything worked fine until another reboot after another bootable USB test. So this time I installed multipath but it still didn't work. Then I removed it again and it worked. After that I decided not to mess with the USB bootable drive anymore and rebooted my system several times to make sure it worked and it seems to be good now but I have no idea what is causing it. I'm guessing it is something with the USB bootable drive but it happened before without that. It's also weird that I was able to get it to work both with and without multipath installed and it also failed in both configurations. Any ideas?
_________________
Time makes more converts than reason. - Thomas Paine
Travel is fatal to prejudice, bigotry, and narrow-mindedness, and many of our people need it sorely on these accounts. - Mark Twain
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Wed Apr 20, 2016 9:39 pm    Post subject: Reply with quote

sys-fs/multipath-tools in case anyone else is wondering.

Hmm new one on me; according to the project page, it's been around since before 2005.
I've never needed it for lvm, that's for sure.

The page does not exactly add clarity:
Code:
Homepage of the upstream project used to drive the Device Mapper multipathing driver.
I don't understand why it says "of the upstream project used.." either.

So it drives a driver. Great. ;)

There is a patch to update the docs, but it doesn't shed much light. Still, we know there's a daemon.

Perhaps lvm needs it; I recall some other thing with lvm needing another daemon. Crashing out now, but will check back.
Back to top
View user's profile Send private message
ahferroin7
n00b
n00b


Joined: 26 Nov 2014
Posts: 10

PostPosted: Wed Jul 06, 2016 2:54 pm    Post subject: Reply with quote

Multipath-tools is for dealing with multipath storage hardware, which is used in some high-end server systems to provide hardware level failover. For a very hefty sum, you can get special disk drives which have multiple data and power connectors. These then get used with a pair of storage controllers and redundant power supplies so that there is no single point of failure in the communications path between the disk and the rest of the system. Normally, without multipath drivers, these will then show up as a pair of disks with identical contents. dm-multipath (the current kernel driver, used to be an MD driver) and multipath-tools (the userspace component) handle processing of data from the disk such that you get one device instead of two, and nothing above the block layer can see any difference between such a setup and using a regular disk.

I often have it installed even on systems I don't use it on though because it includes the kpartx command, which is extremely useful for a wide variety of reasons. I'm not sure why dmraid depends on it, but I don't know anyone who actually uses the dmraid tools instead of LVM, so I can't be sure.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum