Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] [KMS] drm report modesetting isn't supported.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ronnem
n00b
n00b


Joined: 17 Apr 2016
Posts: 12

PostPosted: Mon Apr 18, 2016 7:07 am    Post subject: [Solved] [KMS] drm report modesetting isn't supported. Reply with quote

I have problem with Xorg. I can run my KDE only with Xorg vesa driver. I've tryed run Xorg with amdgpu driver but everytime I've got this error [KMS] drm report modesetting isn't supported.

egrep "KMS|drm|radeon" /var/log/dmesg

[ 2.821189] device class 'drm': registering
[ 2.821198] [drm] Initialized drm 1.1.0 20060810
[ 2.821321] [drm] radeon kernel modesetting enabled.
[ 2.821434] bus: 'pci': add driver radeon

#egrep "FB|DRM|RADEON|amdgpu" /boot/config-4.1.15-amdgpu

http://pastebin.com/XNDF4Pxu

#cat /var/log/Xorg.0.log

http://pastebin.com/KPvh0PmD


#cat /etc/X11/xorg.conf.d/20-amdgpu.conf
Section "Device"
Identifier "Amdgpu"
Driver "amdgpu"
# Option "accelMethod" "glamor"
# Option "DRI3" "on"
# Option "TearFree" "on"
# Monitor "Samsung"
EndSection

Section "Module"
Load "modesetting"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
# DefaultDepth 24
Monitor "Samsung"
Subsection "Display"
Depth 24
Modes "1920x1080"
EndSubSection
EndSection

#lspci |grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tonga PRO [Radeon R9 285/380] (rev f1)

#ls -l /usr/lib64/xorg/modules/drivers/
total 612
-rwxr-xr-x 1 root root 122512 Feb 21 16:12 amdgpu_drv.so
-rwxr-xr-x 1 root root 10192 Apr 17 17:51 ati_drv.so
-rwxr-xr-x 1 root root 61128 Feb 21 12:21 modesetting_drv.so
-rwxr-xr-x 1 root root 429552 Apr 17 17:51 radeon_drv.so

#ls -l /dev/dri/*
ls: cannot access /dev/dri/*: No such file or directory


Last edited by ronnem on Wed Apr 20, 2016 12:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
ronnem
n00b
n00b


Joined: 17 Apr 2016
Posts: 12

PostPosted: Tue Apr 19, 2016 8:45 am    Post subject: Reply with quote

https://wiki.gentoo.org/wiki/Amdgpu

Code:
FamilyChipset name      Product name    OpenGL  OpenGL ES       VIDEO_CARDS
Volcanic Islands        TONGA   R9 285   4.1    3.0           amdgpu radeonsi


#grep VIDEO /etc/portage/make.conf
Quote:
VIDEO_CARDS="amdgpu radeonsi"
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5762

PostPosted: Tue Apr 19, 2016 4:14 pm    Post subject: Reply with quote

Try a newer kernel? 4.1 is ancient on an amdgpu driver timescale.
Back to top
View user's profile Send private message
ronnem
n00b
n00b


Joined: 17 Apr 2016
Posts: 12

PostPosted: Tue Apr 19, 2016 7:22 pm    Post subject: Reply with quote

Problem solved after updating to kernel 4.5.1 and after reinstalling xorg-server 1.18.3, xorg-drivers-1.18-r1...
Back to top
View user's profile Send private message
MarioCorleone
Guru
Guru


Joined: 29 Jun 2003
Posts: 327

PostPosted: Tue Apr 19, 2016 10:25 pm    Post subject: Reply with quote

ronnem wrote:
Problem solved after updating to kernel 4.5.1 and after reinstalling xorg-server 1.18.3, xorg-drivers-1.18-r1...


Please add [SOLVED] to the title
_________________
-Mario
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum