Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with compiling kernel due to nvidia card
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Apr 18, 2016 8:48 am    Post subject: Problems with compiling kernel due to nvidia card Reply with quote

Hi,
when I compile the kernel (make && make modules_install) I get this Warning:

Code:
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia-modeset.ko needs unknown symbol nvidia_get_rm_ops


I found an old entry here (https://forums.gentoo.org/viewtopic-t-837232-start-0-postdays-0-postorder-asc-highlight-.html) but it is not working and the entry:

Code:
CONFIG_AGP_NVIDIA=m


is not in my kernel anymore!

Any idears?
Back to top
View user's profile Send private message
MarioCorleone
Guru
Guru


Joined: 29 Jun 2003
Posts: 327

PostPosted: Mon Apr 18, 2016 9:14 am    Post subject: Reply with quote

So do you have nvidia-drivers installed or no?

Could you pastebin(pastebin.com) your kernel .config please
_________________
-Mario
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Apr 18, 2016 9:26 am    Post subject: Reply with quote

MarioCorleone wrote:
So do you have nvidia-drivers installed or no?


yes I have!

Code:
#emerge -S nvidia-drivers
 
[ Results for search key : nvidia-drivers ]
Searching...

*  x11-drivers/nvidia-drivers
      Latest version available: 340.93-r1
      Latest version installed: 340.93-r1
      Size of files: 68,178 KiB
      Homepage:      http://www.nvidia.com/ http://www.nvidia.com/Download/Find.aspx
      Description:   NVIDIA Accelerated Graphics Driver
      License:       GPL-2 NVIDIA-r2

[ Applications found : 1 ]


Quote:
Could you pastebin(pastebin.com) your kernel .config please


https://bpaste.net/show/77f63bd1d783

Thx!
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 802

PostPosted: Mon Apr 18, 2016 9:30 am    Post subject: Reply with quote

try
Quote:
CONFIG_AGP=n
CONFIG_DRM=n
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Apr 18, 2016 9:34 am    Post subject: Reply with quote

I did that and now i have:

Code:

...
  DEPMOD  4.1.15-gentoo-r1
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia-modeset.ko needs unknown symbol nvidia_get_rm_ops
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_open
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_poll
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_pci_init
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_gem_prime_handle_to_fd
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_gem_private_object_init
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_gem_mmap
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_ioctl
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_gem_object_free
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_read
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_gem_handle_create
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_prime_pages_to_sg
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_pci_set_busid
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_pci_exit
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_release
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia.ko needs unknown symbol drm_gem_prime_export
Back to top
View user's profile Send private message
MarioCorleone
Guru
Guru


Joined: 29 Jun 2003
Posts: 327

PostPosted: Mon Apr 18, 2016 9:44 am    Post subject: Reply with quote

Curious if you've looked at this yet --> https://wiki.gentoo.org/wiki/NVidia
_________________
-Mario
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Apr 18, 2016 9:45 am    Post subject: Reply with quote

MarioCorleone wrote:
Curious if you've looked at this yet --> https://wiki.gentoo.org/wiki/NVidia


yes and I did the installation according to: https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 564
Location: France

PostPosted: Mon Apr 18, 2016 11:05 am    Post subject: Reply with quote

Do you use Optimus ? If not :
- perhaps disabling KMS will help ;

Code:
#
# Direct Rendering Manager
#
(...)
CONFIG_DRM_KMS_HELPER=y
CONFIG_DRM_KMS_FB_HELPER=y
# CONFIG_DRM_LOAD_EDID_FIRMWARE is not set

- all the Intel stuff is useless.

Code:
#
# Graphics support
#
CONFIG_AGP=y
# CONFIG_AGP_AMD64 is not set
CONFIG_AGP_INTEL=y
# CONFIG_AGP_SIS is not set
# CONFIG_AGP_VIA is not set
CONFIG_INTEL_GTT=y
(...)

#
# I2C encoder or helper chips
#
(...)
CONFIG_DRM_I915=y
CONFIG_DRM_I915_KMS=y
CONFIG_DRM_I915_FBDEV=y
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Apr 18, 2016 11:18 am    Post subject: Reply with quote

Thx! No I don't use Optimus and I deactivated the KMS in the kernal and run
Code:
emerge --ask @module-rebuild


I get still the same error message!

If you say the intel stuff is useless shoud I than disable them in the kernel?
Back to top
View user's profile Send private message
324874
Apprentice
Apprentice


Joined: 26 Jul 2014
Posts: 168

PostPosted: Mon Apr 18, 2016 11:56 am    Post subject: Reply with quote

Hi chi86,

chi86 wrote:
when I compile the kernel (make && make modules_install) I get this Warning:
Quote:
depmod: WARNING: /lib/modules/4.1.15-gentoo-r1/video/nvidia-modeset.ko needs unknown symbol nvidia_get_rm_ops


Your warning message isn't informative (see Gentoo Bugzilla Guide).

Best regards,

neoptslap
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Mon Apr 18, 2016 12:18 pm    Post subject: Reply with quote

it means your modules have change, and the nvidia-modeset.ko module was build for your previous kernel.
howto fix it? just re-emerge nvidia-drivers and they will link against your "now current" kernel.
if really nvidia need something your kernel now lack, you'll get your answer as they will fail to build.
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 564
Location: France

PostPosted: Mon Apr 18, 2016 12:31 pm    Post subject: Reply with quote

chi86 wrote:
If you say the intel stuff is useless shoud I than disable them in the kernel?

Yes, you should. And you should disable all related to Framebuffer (incompatible with the Nvidia driver) too.
Code:
#
# Frame buffer Devices
#
CONFIG_FB=y
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Apr 18, 2016 12:39 pm    Post subject: Reply with quote

krinn wrote:
it means your modules have change, and the nvidia-modeset.ko module was build for your previous kernel.
howto fix it? just re-emerge nvidia-drivers and they will link against your "now current" kernel.
if really nvidia need something your kernel now lack, you'll get your answer as they will fail to build.


I did that and it is not failing but one message appears:

Code:

make[2]: Entering directory '/usr/src/linux-4.1.15-gentoo-r1'
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (      \
echo >&2;                     \
echo >&2 "  ERROR: Kernel configuration is invalid.";      \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";   \
echo >&2 ;                     \
/bin/false)


I put the whole output to:
Code:
https://bpaste.net/show/94b94d4c0db2


I also tried the suggested
Code:
make oldconfig && make prepare
!

Still the same warning appears at the end of compiling the kernel!

@Syl20:

I disabled the
Code:
CONFIG_FB=y


but also no improvement!
Back to top
View user's profile Send private message
324874
Apprentice
Apprentice


Joined: 26 Jul 2014
Posts: 168

PostPosted: Mon Apr 18, 2016 12:46 pm    Post subject: Reply with quote

chi86,

I advice you take great care of your configuration if you are using an nvidia card and
you have to know what you do.

neoptslap wrote:

Gentoo Handbook wrote:

2.1 Kernel

The kernel module (nvidia.ko) consists of a proprietary part (commonly known as the "binary blob") which drives the graphics chip(s), and an open source part (the "glue") which at runtime acts as intermediary between the proprietary part and the kernel. These all need to work nicely together as otherwise the user might be faced with data loss (through kernel panics, X servers crashing with unsaved data in X applications) and even hardware failure (overheating and other power management related issues should spring to mind).

See Nvidia wiki page

neoptslap wrote:

Gentoo Handbook wrote:

4.2 NVIDIA optimus

When using a laptop with NVIDIA's Optimus technology (usually found in laptops built in 2010 and later) then everything will be passed through your integrated graphics controller (usually Intel) before it gets to your discreet video card (NVIDIA), which can cause a lot of otherwise unexplained problems when enabled. There are a few ways to handle this, but the simplest is to disable Optimus through your BIOS (normally accessed by pressing F12 during boot). This will result in increased power consumption (decreased battery life, increased running temperature), as your NVIDIA card will now be handling all of the work all of the time.

See Nouveau wiki page


Best regards,

neoptslap
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Mon Apr 18, 2016 3:22 pm    Post subject: Reply with quote

Looking at your paste ... the kernel sources you are compiling against do not match the running kernel.
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Tue Apr 19, 2016 6:22 am    Post subject: Reply with quote

Buffoon wrote:
Looking at your paste ... the kernel sources you are compiling against do not match the running kernel.


It is a fresh installation and i just have the kernel:
Code:
linux-4.1.15-gentoo-r1

installed!

@neoptslap:

Thanks for the help!
I figured now out that the problem was the "nvidia-drivers-340.96" which was pulled by "nvidia-settings-340.58" (dependency of "xfce4-sensors-plugin")!

With the most recent "nvidia-drivers" Version "361.28" all warnings vanish when I recompile the kernel!

For now I unmerged "xfce4-sensors-plugin" and therefore I don't need the "nvidia-settings" and the most recent "nvidia-drivers" can be installed!
If a matching "nvidia-settings" is released I give it another try and post the result here!

Thx!
Back to top
View user's profile Send private message
324874
Apprentice
Apprentice


Joined: 26 Jul 2014
Posts: 168

PostPosted: Tue Apr 19, 2016 7:59 am    Post subject: Reply with quote

:)
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 564
Location: France

PostPosted: Tue Apr 19, 2016 12:12 pm    Post subject: Reply with quote

chi86 wrote:
Still the same warning appears at the end of compiling the kernel!

@Syl20:

I disabled the
Code:
CONFIG_FB=y


but also no improvement!

As it's a fresh install, and to be sure you install the good driver on the good kernel, you can try to unmerge nvidia-drivers, recompile and reinstall the lernel (the error message from nvidia should disappear), optionally reboot your computer on this new kernel, and then reinstall nvidia-drivers (emerge @module-rebuild should do the job, if you set VIDEO_CARDS to "nvidia").

Just in case, ensure the /usr/src/linux symlink points /usr/src/linux-4.1.15-gentoo-r1.

Could you post you emerge --info, please ?
Back to top
View user's profile Send private message
Xootneg
n00b
n00b


Joined: 19 Oct 2003
Posts: 23
Location: N. California

PostPosted: Wed Apr 20, 2016 1:21 am    Post subject: Reply with quote

chi86 wrote:
Buffoon wrote:
Looking at your paste ... the kernel sources you are compiling against do not match the running kernel.


It is a fresh installation and i just have the kernel:
Code:
linux-4.1.15-gentoo-r1

installed!

@neoptslap:

Thanks for the help!
I figured now out that the problem was the "nvidia-drivers-340.96" which was pulled by "nvidia-settings-340.58" (dependency of "xfce4-sensors-plugin")!

With the most recent "nvidia-drivers" Version "361.28" all warnings vanish when I recompile the kernel!

For now I unmerged "xfce4-sensors-plugin" and therefore I don't need the "nvidia-settings" and the most recent "nvidia-drivers" can be installed!
If a matching "nvidia-settings" is released I give it another try and post the result here!

Thx!



Hi chi86,

Your situation in installing a fresh install of Gentoo as well as your kernel error message was EXACTLY the same as my issue, on
my own fresh install. You are also using the same desktop as I, in Xfce4. You are also using the same kernel (linux-4.1.15-gentoo-r1).
For a fact, for many, many months I have been dealing with the block caused by "xfce4-sensors-plugin" by masking newer builds of
nvidia-drivers. I just never took the time to chase it down.

SO, your little fix, quoted above, fixed all of my issues too, the kernel error message and having a current
nvidia-drivers are both fixed. Thanks for that, and my hat of off to you! You made my day!

Very well done sir! Thanks so much....
_________________
Confucius Says: "Even monkeys fall out of trees"!

http://www.eldoradocountyweather.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum