Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem mit der Migration von Wallet
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Mon Apr 18, 2016 8:15 pm    Post subject: Problem mit der Migration von Wallet Reply with quote

Hallo

Ich habe die Migration von Kde4 zu Plasma so weit vollzogen. Allerdings bekommen ich die Migration von Kwallet 4 zu 5 nicht hin. Ich bin wie folgt vorgegangen.
kwalletd4 gestartet
kwalletd5 gestartet
Migrationsagent wird automatisch gestartet.
Passwortabfrage poppt auf.
Passwort für Wallet wird nicht akzeptiert. :(
Installiert sind:

kde-apps/kwalletd-15.12.3
kde-apps/kwalletmanager-15.04.3
kde-frameworks/kwallet-5.18.0
kde-plasma/kwallet-pam-5.6.2-r1
kde-apps/kdebase-runtime-meta-15.12.3 (oldwallet pam)

Irgendwelche Vorschläge was da nicht stimmt?

Danke
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Sat Apr 23, 2016 8:21 am    Post subject: Reply with quote

Bist Du da schon weitergekommen?

Ich habe das Problem, dass ich immer nach dem Anmelden mehrere Passwortabfragen bekomme.
Einmal wie es für mich aussieht vom neuen, dann vom Migrationsassistent und irgendwie noch mal vom neuen?!?

Es kommt kein Fehler wenn ich in alle mein Passwort eingebe, aber beim nächsten Anmelden geht das Gleiche von vorne los.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Mon May 30, 2016 7:53 am    Post subject: Reply with quote

Ich hab mit dem Walletmanager bis jetzt auch keine Lösung gefunden. Der "alte" funktioniert, hat auch Verbindung zum Walletmanager (ich vermute dem neuen) Aber dort bekomme ich immer einen Fehler bei der Passwortabfrage.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Mon Jun 06, 2016 1:07 pm    Post subject: Reply with quote

Hm ja, der kwallet-Migrationsassistent funktionierte hier zZt auch nicht :-/
(Auf einem anderen Rechner/System tat er das vor gut einem Jahr noch, ka warum er das nun nicht mehr mach).

Nungut, hab mir den neuen kwallet nun selbst via kwalletmanager5 eingerichtet (das funktionierte fein).
Damit der Kwallet-Migrationsassistent nicht bei jedem Login erneut gestartet wird hilft ein Eintrag in der
~/.config/kwalletrc
Code:
[Migration]
alreadyMigrated=true
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Mon Jun 06, 2016 1:19 pm    Post subject: Reply with quote

tazinblack wrote:
Ich habe das Problem, dass ich immer nach dem Anmelden mehrere Passwortabfragen bekomme.
Einmal wie es für mich aussieht vom neuen, dann vom Migrationsassistent und irgendwie noch mal vom neuen?!?

Es kommt kein Fehler wenn ich in alle mein Passwort eingebe, aber beim nächsten Anmelden geht das Gleiche von vorne los.

Wenn dein Passwort für kwallet das selbe ist, wie das welches du für deinen User verwendest, dann sollte das eigentlich automatisch via PAM funktionieren.
Sprich, damit die Kwallet Passwortabfrage nicht immer wieder kommt muss das Kwallet-Passwort das selbe sein wie das für deinen User-Login.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Mon Jun 06, 2016 2:27 pm    Post subject: Reply with quote

Bei mir hat es auch nicht funktioniert die automatische migration.
Am schluss habe ich über den kde4 kwalletmanager die entsprechenden wallets exportiert (AFAIK als XML) und diese dann in kwallet:5 über den kwalletmanager:5 importiert.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Mon Jun 06, 2016 6:47 pm    Post subject: Reply with quote

Im Angebot:

Code:
eix kwallet
* kde-apps/kwalletd
     Verfügbare Versionen:   (4) 4.14.3-r2(4/4.14)^t 15.08.3(4/15.08)^t 15.12.3(4/15.12)^t ~16.04.1(4/16.04)^t
       {aqua debug gpg}
     Startseite:             https://www.kde.org/
     Beschreibung:           KDE Password Server

* kde-apps/kwalletd-pam
     Verfügbare Versionen:   (4) 5.5.5
     Startseite:             https://www.kde.org/
     Beschreibung:           KWallet PAM module to not enter password again

[I] kde-apps/kwalletmanager
     Verfügbare Versionen:   
     (4)    4.14.3(4/4.14) 15.04.3(4/15.04) ~15.04.3-r1(4/15.04)
     (5)    15.12.3 ~16.04.1
       {aqua debug doc +handbook minimal}
     Installierte Versionen: 15.12.3(5)(20:13:47 28.05.2016)(handbook -debug -doc)
     Startseite:             https://www.kde.org/
     Beschreibung:           KDE Wallet management tool

* kde-apps/signon-kwallet-extension
     Verfügbare Versionen:   (5) ~15.12.3 ~16.04.1
       {debug}
     Startseite:             https://01.org/gsso/
     Beschreibung:           KWallet extension for signond

[I] kde-frameworks/kwallet
     Verfügbare Versionen:   (5) 5.21.0(5/5.21) ~5.22.0(5/5.22)
       {debug doc gpg +man test}
     Installierte Versionen: 5.21.0(5)(19:48:51 28.05.2016)(man -debug -doc -gpg -test)
     Startseite:             https://www.kde.org/
     Beschreibung:           Framework providing desktop-wide storage for passwords

[I] kde-plasma/kwallet-pam
     Verfügbare Versionen:   (5) 5.6.4-r1
       {debug +oldwallet}
     Installierte Versionen: 5.6.4-r1(5)(18:00:24 28.05.2016)(oldwallet -debug)
     Startseite:             https://www.kde.org/
     Beschreibung:           KWallet PAM module to not enter password again

6 Treffer


Ich finde es doch etwas verwirrend:

Code:
* kde-apps/kwalletd-pam
     Verfügbare Versionen:   (4) 5.5.5
     Startseite:             https://www.kde.org/
     Beschreibung:           KWallet PAM module to not enter password again


Wie kann denn Version 5 Version 4 sein ???


Und hier:
Code:
 (4)    4.14.3(4/4.14) 15.04.3(4/15.04) ~15.04.3-r1(4/15.04)

Hier ist 15.04.3-r1(4/15.04) Version 4

aber

Code:
(5)    15.12.3 ~16.04.1


und hier ist dann Version 15.12.3 Version 5?

Also vielleicht werde ich jetzt einfach alt, aber schön durchgängig und übersichtlich ist was anderes.

Und ich glaube da fängt schon der Fisch an zu stinken.

Aber im Prinzip soll es halt tun und portage den Rest machen. :-)
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Tue Jun 07, 2016 10:37 am    Post subject: Reply with quote

tazinblack wrote:
Code:
[I] kde-plasma/kwallet-pam
     Verfügbare Versionen:   (5) 5.6.4-r1
       {debug +oldwallet}
     Installierte Versionen: 5.6.4-r1(5)(18:00:24 28.05.2016)(oldwallet -debug)
     Startseite:             https://www.kde.org/
     Beschreibung:           KWallet PAM module to not enter password again

Quote:
Aber im Prinzip soll es halt tun und portage den Rest machen. :-)

Das kde-plasma/kwallet-pam Paket macht bei der Installation auch ein paar Checks, und gibt hilfreiche Info nach dem mergen aus.
Installiere das kde-plasma/kwallet-pam Paket bitte noch mal (das baut sehr schnell), und schau dir die Ausgabe an :)
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Wed Jun 08, 2016 8:10 pm    Post subject: Reply with quote

Code:
* This package enables auto-unlocking of kde-frameworks/kwallet:5.
 * You have also selected support for legacy kde-apps/kwalletd:4.
 * List of things to make it work:
 * 1.  Use standard blowfish encryption instead of GPG
 * 2.  Use same password for login and kwallet
 * 3.  A display manager with support for PAM
 * 4.a Have the following lines in the display manager's pam.d file:
 *     -auth        optional        pam_kwallet5.so
 *     -session     optional        pam_kwallet5.so auto_start
 *     -auth        optional        pam_kwallet.so kdehome=.kde4
 *     -session     optional        pam_kwallet.so
 * 4.b Checking installed DMs...
 *     SDDM - /etc/pam.d/sddm ...GOOD


1: ?
2: hab ich
3: mein sddm hat das use flag "pam"
4a:
Code:
cat /etc/pam.d/sddm
#%PAM-1.0

auth            include         system-login
account         include         system-login
password        include         system-login
session         include         system-login
-auth           optional        pam_kwallet.so kdehome=.kde4
-auth           optional        pam_kwallet5.so
-session        optional        pam_kwallet.so
-session        optional        pam_kwallet5.so auto_start


4b: ist wohl auch ok


Das habe ich übrigens auch
Code:
[Migration]
alreadyMigrated=true

_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3690
Location: Hamburg

PostPosted: Sat Jun 11, 2016 9:56 am    Post subject: Reply with quote

Also meine Migration war ganz einfach - ich mußte beim neuen KWallet einfach nur noch mal alle meine Kennwörter eingeben, schon gings :-/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum