Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] unknown filesystem exfat
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jommes
n00b
n00b


Joined: 19 Mar 2016
Posts: 35

PostPosted: Wed Apr 20, 2016 3:15 pm    Post subject: [SOLVED] unknown filesystem exfat Reply with quote

Hello together,

I have an external exFat formatted device.

I emerged exfat-utils and fuse-exfat.

When trying to mount this device, I get:
Code:
Error mounting: mount: unknown filesystem type 'exfat'


Can someone help pls?

Best


Last edited by jommes on Wed Apr 20, 2016 3:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
axl
Guru
Guru


Joined: 11 Oct 2002
Posts: 537
Location: Romania

PostPosted: Wed Apr 20, 2016 3:33 pm    Post subject: Reply with quote

try with -t vfat? mount -t vfat.

if that doesn't work, you need to recompile your kernel with exfat support. see filesystems options.

EDIT: or emerge sys-fs/exfat-utils sys-fs/fuse-exfat ?


Last edited by axl on Wed Apr 20, 2016 3:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Wed Apr 20, 2016 3:36 pm    Post subject: Reply with quote

Maybe this post responds to your question:

https://forums.gentoo.org/viewtopic-t-936634-start-0.html
Back to top
View user's profile Send private message
jommes
n00b
n00b


Joined: 19 Mar 2016
Posts: 35

PostPosted: Wed Apr 20, 2016 3:39 pm    Post subject: Reply with quote

Hi axl,

thanks for fast reply.

Quote:
recompile your kernel with exfat support

Kernel supports vfat.

Quote:
try with -t vfat? mount -t vfat.


I tried, result:
Code:
mount: wrong fs type, bad option, bad superblock on 192.168.1.5:/home/shared, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program) 
In some cases useful info is found in syslog - try dmesg | tail or so.


dmesg output:
Code:
FAT-fs (sdc1): bogus number of reserved sectors
FAT-fs (sdc1): Can't find a valid FAT filesystem


Do you think something might be wrong with formation?

Best
Back to top
View user's profile Send private message
axl
Guru
Guru


Joined: 11 Oct 2002
Posts: 537
Location: Romania

PostPosted: Wed Apr 20, 2016 3:41 pm    Post subject: Reply with quote

no. it was my bad. didn't know exfat isn't support natively in kernel. see the later edit. most likely emerge sys-fs/exfat-utils or sys-fs/fuse-exfat. not sure which.
Back to top
View user's profile Send private message
jommes
n00b
n00b


Joined: 19 Mar 2016
Posts: 35

PostPosted: Wed Apr 20, 2016 3:49 pm    Post subject: Reply with quote

Thanks everyone.

Somehow ... I completely missed emerging fuse-exfat (I was so sure) ...

Now it's working fine ...

Thanks everyone :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum