Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Laptop - Lost Wifi After Crash
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jlpoole
Guru
Guru


Joined: 01 Nov 2005
Posts: 344
Location: Salem, OR

PostPosted: Tue Apr 26, 2016 3:14 pm    Post subject: [SOLVED] Laptop - Lost Wifi After Crash Reply with quote

I'm running Gentoo on a Dell Inspiron.
Quote:
themis jlpoole # uname -a
Linux themis 4.1.12-gentoo #1 SMP Wed Jan 6 18:28:34 PST 2016 x86_64 Intel(R) Core(TM) i5 CPU M 460 @ 2.53GHz GenuineIntel GNU/Linux
themis jlpoole #

I bought a new generic battery for it and have the misfortune that when the XFCE battery manager shows it near 50%, the system crashes.

I normally have the laptop connect to a cable and network cable. A few days ago, I was operating the laptop on battery mode and it crashed. Thereafter, the wifi adapter has disappeared from WPA Supplicant. I had not been current for several months, so I did a full emerge hoping that maybe something in the emerge process would fix whatever was preventing WPA Supplicant from seeing my wifi adapter.

Quote:
themis jlpoole # iwconfig
enp4s0 no wireless extensions.

enp0s29u1u5 no wireless extensions.

lo no wireless extensions.

wlp3s0 IEEE 802.11abgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

themis jlpoole #

The wifi does not appear to be blocked:
Quote:
themis jlpoole # rfkill list
0: i2400m-usb:2-1.5:1.0: WiMAX
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
themis jlpoole #

Quote:
themis jlpoole # ifconfig -a
enp0s29u1u5: flags=129<UP,NOARP> mtu 1400
ether [REDACTED by jlpoole] txqueuelen 20 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet [REDACTED by jlpoole]
inet6 [REDACTED by jlpoole] prefixlen 64 scopeid 0x20<link>
ether [REDACTED by jlpoole] txqueuelen 1000 (Ethernet)
RX packets 8777 bytes 5535711 (5.2 MiB)
RX errors 0 dropped 1 overruns 0 frame 0
TX packets 10007 bytes 2425903 (2.3 MiB)
TX errors 0 dropped 0 overruns 0 carrier 1 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlp3s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether [REDACTED by jlpoole] txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

themis jlpoole #


I'm thinking something in the crash has flipped a switch or bit causing the WIFI (different from WiMax which I have and do not use) to be hidden or de-activated, most likely a Power Management "feature" that is basically blocking me from using the wifi now.

dmesg has:
Quote:
[ 18.097592] Intel(R) Wireless WiFi driver for Linux
[ 18.097600] Copyright(c) 2003- 2015 Intel Corporation
[ 18.097874] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[ 18.249736] iwlwifi 0000:03:00.0: loaded firmware version 41.28.5.1 build 33926 op_mode iwldvm


I installed and ran fwts. Here's the log
Quote:
themis jlpoole # cat results.log
Results generated by fwts: Version V15.12.00 (2015-12-16 07:10:46).

Some of this work - Copyright (c) 1999 - 2015, Intel Corp. All rights reserved.
Some of this work - Copyright (c) 2010 - 2015, Canonical.

This test run on 26/04/16 at 07:25:50 on host Linux themis 4.1.12-gentoo #1 SMP
Wed Jan 6 18:28:34 PST 2016 x86_64.

Command: "fwts aspm".
Running tests: aspm.

aspm: PCIe ASPM test.
--------------------------------------------------------------------------------
Test 1 of 2: PCIe ASPM ACPI test.
PCIe ASPM is controlled by Linux kernel.

Test 2 of 2: PCIe ASPM registers test.
PASSED: Test 2, PCIe ASPM setting matched was matched.
WARNING: Test 2, RP 00h:1Ch.05h L0s not enabled.
WARNING: Test 2, Device 04h:00h.00h L0s not enabled.

ADVICE: The ASPM L0s low power Link state is optimized for short entry and exit
latencies, while providing substantial power savings. Disabling L0s of a PCIe
device may increases power consumption, and will impact the battery life of a
mobile system.

PASSED: Test 2, PCIe ASPM setting matched was matched.

================================================================================
2 passed, 0 failed, 2 warnings, 0 aborted, 0 skipped, 0 info only.
================================================================================


2 passed, 0 failed, 2 warnings, 0 aborted, 0 skipped, 0 info only.

Test Failure Summary
================================================================================

Critical failures: NONE

High failures: NONE

Medium failures: NONE

Low failures: NONE

Other failures: NONE

Test |Pass |Fail |Abort|Warn |Skip |Info |
---------------+-----+-----+-----+-----+-----+-----+
aspm | 2| | | 2| | |
---------------+-----+-----+-----+-----+-----+-----+
Total: | 2| 0| 0| 2| 0| 0|
---------------+-----+-----+-----+-----+-----+-----+
themis jlpoole #


I could not find anything else to troubleshoot in the Handbook:X86/Networking/Wireless

When I run WPA Supplicant, the Adapter picklist is empty. This phenomena occurred before and after I did the emerge --update -newuse --deep world. WPA Supplicant was updated.

Any suggestions on what to try or an approach to troubleshoot?


Last edited by jlpoole on Tue Apr 26, 2016 11:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
jlpoole
Guru
Guru


Joined: 01 Nov 2005
Posts: 344
Location: Salem, OR

PostPosted: Tue Apr 26, 2016 10:54 pm    Post subject: Reply with quote

I, as root, was able to successfully connect using the line command in "double debug" [-dd] mode:
Quote:
wpa_supplicant -Dnl80211 -iwlp3s0 -C/var/run/wpa_supplicant/ -c/etc/wpa_supplicant/wpa_supplicant.conf -dd


When I, as root, tried running wpa_gui, I had the same result: no adapters appearing, in the graphical window with "Status: Could not get status from wpa_supplicant"

So the problem lies in the wpa_gui client and/or a configuration file or its ability to ascertain what wifi adpaters are available to it.

Previously, I was able to run the wpa_supplicant gui as regular user jlpoole (member of wheel), so some permission somewhere got flipped, I'm guessing.
Back to top
View user's profile Send private message
jlpoole
Guru
Guru


Joined: 01 Nov 2005
Posts: 344
Location: Salem, OR

PostPosted: Tue Apr 26, 2016 11:07 pm    Post subject: Reply with quote

SOLVED

wpa_supplicant needs to run as a service.
Code:

themis wpa_supplicant # /etc/init.d/wpa_supplicant status
 * status: stopped
themis wpa_supplicant # /etc/init.d/wpa_supplicant start
 * Starting WPA Supplicant Daemon ...
Successfully initialized wpa_supplicant                                   [ ok ]
themis wpa_supplicant #


After I started the wpa_supplicant service, the wpa_gui worked fine.

=================================

I should note, these errors, possibly arising from QT?, appeared during my unsuccessful and successful attempt to connect using the graphical client:
Quote:
themis jlpoole # wpa_gui -iwlp3s0
QXcbConnection: XCB error: 149 (Unknown), sequence: 169, resource id: 0, major code: 141 (Unknown), minor code: 20
themis jlpoole #
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum