Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nouveau or nvidia module cause panic for kernel v4.5.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
tlix
n00b
n00b


Joined: 15 Jul 2015
Posts: 4

PostPosted: Tue Apr 26, 2016 10:46 pm    Post subject: nouveau or nvidia module cause panic for kernel v4.5.2 Reply with quote

I bought a laptop several days ago, and begin to build gentoo for it, after struggling for days, I finally configured the kernel properly for my hardware, but some strange behaviour is still there and I have no way to concel that.

first I tried the stable version gentoo-sources 4.1.15, configured with the configuration of kernel of version 4.0.5 that I have used for my old laptop, with only necessary hardware drivers modified, but it print so many warnings or errors, I have to configure it from 0 again. Finaly some the problem seems to have gone, and I tried to start x but the terminal just flick and I have no choice but poweroff. startx report error no screen at that time, but as I see there is no configuration mistake with the X.
then I switched to kernel 4.5.2, with the same configuration( directly load the configuration), startx works but gdm login screen just come into noresponding status after I input the password of the user. soon I found that when this happend, the command lspci also doesn't work(no responding and can't stop, after several minutes a kernel panic prints and also some ACPI ERRORS), what's the most amazing is that this problem occurs randomly, the chance of the lspci works is larger if I have poweroffed the computer for long time.
After looking into dmesg, modified and recompiled the kernel for several times, I found that the culprit seems to be nouveau module loaed by the kernel, If I blacklist nouveau, nearly all the problem went away, and everything works, as there is intel integrated GPU I can still use X.

besides there is nvcvideo, for kernel v4.4.8 is all right but for v4.5.2 with the same configuration print "Entity type for entity Extension 4 was not initialized!" and etc. on boot. for kernel v4.4.8, so long as I select the usb_gadget module in kernel the same message will also be printed on boot, but for kernel v4.5.2, even if I deselect the gadget module, the message is still there, while they toad the same kernel coniguration.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum