Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unable to print
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Tue May 03, 2016 10:47 am    Post subject: unable to print Reply with quote

I'm using hplip(hpijs) and cups to print using my hp laserjet p1102

[ebuild R ] net-print/cups-filters-1.5.0::gentoo USE="dbus foomatic -jpeg -ldap -perl -png -static-libs -tiff -zeroconf" 1,344 KiB
[ebuild R ] net-print/hplip-3.14.10::gentoo USE="X hpijs libnotify -doc -fax -hpcups -kde -libusb0 -minimal -parport -policykit -qt4 -scanner -snmp -static-ppds" PYTHON_TARGETS="python2_7" 21,272 KiB


using the following settings:
Description: HP LaserJet Professional P1102
Location:
Driver: HP LaserJet Professional p1102 hpijs, 3.14.10, requires proprietary plugin (color)
Connection: usb://HP/LaserJet%20Professional%20P1102?serial=000000000Q89FJNEPR1a
Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

it fails when I try to print with:
stopped
"Filter failed"

and in journalctl:
May 03 12:43:20 b5400 hpijs[7566]: prnt/hpijs/hpijs.cpp 271: unable to set device=HP LaserJet 1018, err=48
May 03 12:43:20 b5400 hpijs[7566]: prnt/hpijs/hpijs.cpp 292: unable to set device=HP LaserJet 1018, err=48


thanks
Back to top
View user's profile Send private message
Lebkoungcity
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2008
Posts: 125
Location: Lebkoungcity (='Gingerbreadcity' =Nuremberg)

PostPosted: Sun May 08, 2016 9:22 am    Post subject: Reply with quote

Hi,

I'm not really sure if could help you but I checked my installation and I have 'hplip' emerged with an activated 'hpcups' USE-flag.
The other thing I is that in your settings it is stated you would need a 'proprietary plugin (color)'. Do have this on your system?
And: In your settings it is the 'p1102' while the error says it was the 'HP LaserJet 1018' - I don't know if both models are using the same driver or settings...


How did you add your printer? Did you use the frontend of cups (http://localhost:631) or did you use the frontend of hplip?

For me I had some trouble when I tried to add my LaserJet 2100 within cups - I only succeeded using hplip. After this I could always change settings in cups.

So, the first thing I would do is to delete the printer, and start all over with the help of the 'add printer' function in hplip. If it doesn't work I would try different drivers with the help of the cups frontend.

If this doesn't help I would re-emerge 'hplip' with 'hpcups' and start all over new.


Oh, and have you checked http://www.openprinting.org ? There's lots of useful information!


Best wishes,
Andy
_________________
"The most dangerous world view is the world view of the ones who haven't viewed the world."
Alexander von Humboldt (1769-1859)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum