Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bluetooth und AutoEnable
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1559
Location: Schweiz

PostPosted: Tue May 10, 2016 10:25 am    Post subject: Bluetooth und AutoEnable Reply with quote

Ich habe wiedereinmal ein Problem mit Bluetooth bei dem ich echt nicht weiterkomme und nicht sicher bin ob es jetzt an mir oder irgendeinem BUG liegt.

Zum Problem:
In der Datei "/etc/bluetooth/main.conf" kann man ja angeben ob die vorhandenen Bluetooth-Geräte gleich eingeschaltet werden sollen eben nicht.
Bei mir sieht das nun so aus:
/etc/bluetooth/main.conf:
[Policy]
# AutoEnable defines option to enable all controllers when they are found.
# This includes adapters present on start as well as adapters that are plugged
# in later on. Defaults to 'false'.
AutoEnable=true

Aber trotzdem wird der Bluetooth-Chip erst vom bluez Daemon aktiviert wenn ich diesen über die Konsole nochmal neu starte.
In meinem Fall so:
Code:
slap ~ # hciconfig
hci0:   Type: BR/EDR  Bus: USB
        BD Address: B8:EE:65:92:A3:90  ACL MTU: 1021:8  SCO MTU: 64:1
        DOWN
        RX bytes:2172 acl:0 sco:0 events:205 errors:0
        TX bytes:31157 acl:0 sco:0 commands:203 errors:0
slap ~ # systemctl restart bluetooth
slap ~ # hciconfig
hci0:   Type: BR/EDR  Bus: USB
        BD Address: B8:EE:65:92:A3:90  ACL MTU: 1021:8  SCO MTU: 64:1
        UP RUNNING PSCAN ISCAN
        RX bytes:2936 acl:0 sco:0 events:257 errors:0
        TX bytes:32423 acl:0 sco:0 commands:253 errors:0

Zuerst dachte ich das Problem würde dadurch verursacht das der Daemon gestartet wird bevor der Bluetooth-Chip so weit ist aber selbst wenn der ganze Kram (Treiber und Firmware) fest im Kernel sitzt klappt es nicht. Außerdem besagt die auskommentierte Beschreibung in der Konfigurationsdatei ja das es auch mit Geräten funktionieren sollte die erst nachträglich "angeschlossen" werden. Im Wiki von ArchLinux gibt es eine Udev-Regel die benutzt werden kann um ein "hciconfig hci0 up" abzusetzen aber auf solche Hacks würde ich, wenn möglich, lieber verzichten.

Jemand eine Idee wie ich das ohne Hack in den Griff bekommen könnte?
Denn so funktionieren Geräte wie Bluetooth-Mäuse erst wenn ich manuell Hand anlege oder der KDE nach erfolgreichem Login das Gerät einschaltet und bei letzterem hat man auch noch den üblen Nebeneffekt das der KDE dabei dem Bluetooth-Gerät ständig den Namen ChromeLinux_XXXX verpasst.
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum