Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] kein shutdown/poweroff?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Mon May 30, 2016 2:39 pm    Post subject: Reply with quote

Nimm das "kde" Useflag bei www-plugins/gnash raus.
Das zieht dir kde-base/kdebase-startkde (kde4) mitsamt seinen Deps, die nicht mit deinem installierten plasma-5 kompatibel sind - daher auch die vielen Blocks.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Mon May 30, 2016 4:58 pm    Post subject: Reply with quote

ok, python-updater ist jetzt gelaufen....

emerge -uDtva --changed-use --verbose-conflicts --backtrack=300 @world läuft aber noch nicht durch:


Code:


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-57.1:0/57::gentoo, installed) pulled in by
    dev-libs/icu:0/57= required by (mail-mta/postfix-3.0.3-r1:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    >=dev-libs/icu-51.2-r1:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/libxml2-2.9.3:2/2::gentoo, installed)
                          ^^^^^^                                                                                                                             
    dev-libs/icu:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtcore-4.8.7-r2:4/4::gentoo, installed)
                ^^^^^^                                                                                                                             
    dev-libs/icu:0/57= required by (media-libs/raptor-2.0.9:2/2::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtwebkit-4.8.7:4/4::gentoo, installed)
                ^^^^^^                                                                                                                           
    dev-libs/icu:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-db/sqlite-3.12.0:3/3::gentoo, installed)
                ^^^^^^                                                                                                                           
    dev-libs/icu:0/57= required by (app-text/libmspub-0.1.2:0/0::gentoo, installed)
                ^^^^^^                                                                                                 
    >=dev-libs/icu-3.8.1-r1:0/57= required by (net-libs/webkit-gtk-2.10.9:4/37::gentoo, installed)
                           ^^^^^^                                                                                                     
    >=dev-libs/icu-3.6:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed)
                      ^^^^^^                                                                                                                                   
    dev-libs/icu:0/57= required by (gnome-extra/evolution-data-server-3.18.5:0/54::gentoo, installed)
                ^^^^^^                                                                                                                   
    >=dev-libs/icu-51.2-r1:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/harfbuzz-1.1.3:0/0.9.18::gentoo, installed)
                          ^^^^^^                                                                                                                                     
    dev-libs/icu:0/57= required by (net-nds/openldap-2.4.38-r2:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    dev-libs/icu:0/57= required by (dev-qt/qtcore-5.6.0:5/5.6::gentoo, installed)
                ^^^^^^                                                                                               
    dev-libs/icu:0/57= required by (media-libs/libvisio-0.1.5:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    >=dev-libs/icu-4.8.1.1:0/57= required by (app-office/libreoffice-5.1.2.2:0/0::gentoo, installed)
                          ^^^^^^                                                                                                       
    dev-libs/icu:0/57= required by (media-libs/libcdr-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/57= required by (app-text/libebook-0.1.2-r1:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    >=dev-libs/icu-3.8.1-r1:0/57= required by (net-libs/webkit-gtk-2.4.10-r200:2/2::gentoo, installed)
                           ^^^^^^                                                                                                         
    dev-libs/icu:0/57= required by (dev-qt/qtwebkit-5.6.0:5/5.6::gentoo, installed)
                ^^^^^^                                                                                                 
    >=dev-libs/icu-50:0/57= required by (app-text/texlive-core-2014-r4:0/0::gentoo, installed)
                     ^^^^^^                                                                                                       
    >=dev-libs/icu-4.4:0/57= required by (dev-tex/bibtexu-3.71_p20140525:0/0::gentoo, installed)
                      ^^^^^^                                                                                                       
    >=dev-libs/icu-3.8.1-r1:0/57= required by (net-libs/webkit-gtk-2.4.10:3/25::gentoo, installed)
                           ^^^^^^                                                                                                     

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/icu-4.4:0/55= required by (app-text/calibre-2.47.0:0/0::gentoo, installed)
                      ^^^^^^                                                                                                 

dev-java/icedtea-web:0

  (dev-java/icedtea-web-1.6.1-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-java/icedtea-web-1.6.1:0 required by (dev-java/icedtea-bin-3.0.1:8/8::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                           

  (dev-java/icedtea-web-1.5.1-r1:0/0::gentoo, installed) pulled in by
    dev-java/icedtea-web:0[icedtea7,nsplugin] required by (dev-java/icedtea-7.2.4.3:7/7::gentoo, installed)

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Tue May 31, 2016 4:18 am    Post subject: Reply with quote

Hm, der aktuell noch nicht auflösbare Konflikt liegt vermutlich hier:
uhai wrote:
Code:
dev-java/icedtea-web:0

  (dev-java/icedtea-web-1.6.1-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-java/icedtea-web-1.6.1:0 required by (dev-java/icedtea-bin-3.0.1:8/8::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                           

  (dev-java/icedtea-web-1.5.1-r1:0/0::gentoo, installed) pulled in by
    dev-java/icedtea-web:0[icedtea7,nsplugin] required by (dev-java/icedtea-7.2.4.3:7/7::gentoo, installed)
bei der installierten dev-java/icedtea-7.2.4.3:7/7 Version.
Vermutlich hast du in deiner package.accept_keywords nur exakt diese Version freigeschaltet? Beachte das es diese Version nicht mehr im Tree gibt.
Vorschlag: (Falls dem so ist): Nimm die Versionsangabe in deiner package.accept_keywords bei dev-java/icedtea raus, so das auf die aktuelle verfügbare Version aktualisiert werden kann.
Ich denke damit sollte der Konflikt dann (hoffentlich) gelöst sein :)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Tue May 31, 2016 5:23 am    Post subject: Reply with quote

Code:
Master_Tux ~ # grep -r icedtea /etc/portage/package.accept_keywords/*
Master_Tux ~ #


Habe ich gar nicht in package.accept_keywords.... oder ist mein grep falsch??

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Tue May 31, 2016 7:21 am    Post subject: Reply with quote

Puh nee, keine Ahnung.
Soweit ich das im icedtea-7.2.4.3 Log sehe war die Version aber nie stable - sprich normal musst du dafür mal ein Eintrag in der package.accept_keywords gemacht haben.
Aber ok, wie dem auch sei, wenn du dev-java/icedtea brauchst, dann schalte dir bitte die aktuelle Version frei (es gibt da zZt nur eine im Slot 7).
Code:
eix -e dev-java/icedtea
* dev-java/icedtea
     Available versions: 
     (8)    (~)3.0.1
     (7)    (~)7.2.6.6^t
[...]
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Wed Jun 01, 2016 3:39 am    Post subject: Reply with quote

icedtea hat geklappt, Block ist weg, aber ein

emerge --ask --changed-use --newrepo --deep world

bleibt weider hängen:

Code:
PyQt 4.11.4 is being used.
Qt 4.8.7 is being used.
sip 4.16.9 is being used.
The sip executable is /usr/bin/sip.
The QScintilla module is being built with 'protected' redefined as 'public'.
The QScintilla API file will be installed in /usr/share/qt4/qsci/api/python.
Generating the C++ source for the Qsci module...
 * ERROR: dev-python/qscintilla-python-2.8.4::gentoo failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  133:  Called src_configure
 *   environment, line 3267:  Called python_foreach_impl 'run_in_build_dir' 'configuration'
 *   environment, line 2751:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1929:  Called _multibuild_run '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1927:  Called _python_multibuild_wrapper 'run_in_build_dir' 'configuration'
 *   environment, line  454:  Called run_in_build_dir 'configuration'
 *   environment, line 3249:  Called configuration
 *   environment, line 3264:  Called die
 * The specific snippet of code:
 *           "${myconf[@]}" || die;
 *
 * If you need support, post the output of `emerge --info '=dev-python/qscintilla-python-2.8.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/qscintilla-python-2.8.4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python2_7'
 * S: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python'

>>> Failed to emerge dev-python/qscintilla-python-2.8.4, Log file:

>>>  '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'


emerge --resume --skipfirst:

Code:
/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/headless/fontconfig_database.cpp:275:1: error: static assertion failed: sizeof(specialLanguages) / sizeof(const char *) == QChar::ScriptCount
 Q_STATIC_ASSERT(sizeof(specialLanguages) / sizeof(const char *) == QChar::ScriptCount);
 ^
Makefile:509: recipe for target 'fontconfig_database.o' failed
make: *** [fontconfig_database.o] Error 1
make: *** Waiting for unfinished jobs....
Error while executing: make -j4

Traceback (most recent call last):
  File "setup.py", line 99, in <module>
    sys.exit(main())
  File "setup.py", line 85, in main
    command.run_all(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 181, in run_all
    self.run_cmd(self, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 175, in run_cmd
    self.run_cmd(scmd, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 178, in run_cmd
    cmd.run(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 434, in run
    self.build_headless()
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 570, in build_headless
    self.check_call([make] + ['-j%d'%(cpu_count or 1)])
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 506, in check_call
    subprocess.check_call(*args, **kwargs)
  File "/usr/lib64/python2.7/subprocess.py", line 540, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['make', '-j4']' returned non-zero exit status 2
 * ERROR: app-text/calibre-2.47.0::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line 133:  Called src_install
 *   environment, line 3163:  Called die
 * The specific snippet of code:
 *       PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} "${PYTHON}" setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="${ED}usr" --staging-libdir="${ED}usr/${libdir}" || die;
 *
 * If you need support, post the output of `emerge --info '=app-text/calibre-2.47.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-text/calibre-2.47.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'
 * S: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'

>>> Failed to emerge app-text/calibre-2.47.0, Log file:

>>>  '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Wed Jun 01, 2016 10:11 am    Post subject: Reply with quote

Puh.. :)
Versuche mal bitte ein rebuild:
Code:
emerge -av1 =sip-4.16.9 =x11-libs/qscintilla-2.8.4-r1 =dev-python/PyQt4-4.11.1 =dev-python/qscintilla-python-2.8.4

Wenn eines der Pakete abbrechen sollte, dann poste bitte mal deren komplette Fehlermeldung (build.log, und sofern schon das configure scheitert bitte auch das config.log).
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Wed Jun 01, 2016 6:21 pm    Post subject: Reply with quote

So geht gar nichts...:

Code:
 emerge -av1 =dev-python/sip-4.16.9 =x11-libs/qscintilla-2.8.4-r1 =dev-python/PyQt4-4.11.1 =dev-python/qscintilla-python-2.8.4
zsh: dev-python/sip-4.16.9 not found


Der Fehler kommt analog für alle anderen Pakete auch so.

eix findet die Pakete aber.... ??

Mit "emerge -auDNtv --verbose-conflicts --backtrack=300 world" bekomme ich das:


Code:

 Running pre-merge checks for sys-apps/systemd-230-r1
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     4.1.15-gentoo-r1y
 * Checking for suitable kernel configuration options...
 *   CONFIG_IDE:         should not be set. But it is.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.


Was ist CONFIG_IDE und wo wird das gesetzt? Ist das vielleicht die Quelle allen Übels?
uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Wed Jun 01, 2016 8:38 pm    Post subject: Reply with quote

Das emerge Kommando sollte so funktionieren - teste es mal mit ner normalen Bash Shell.
Und ja, CONFIG_IDE (das sind die uralten IDE-Treiber) solltest du im Kernel deaktivieren.
Im "make menuconfig" unter Device Drivers --->
< > ATA/ATAPI/MFM/RLL support (DEPRECATED)
^ Den deaktivieren.
Falls du tatsächlich noch IDE-Treiber benötigst, dann nutze die libata Treiber unter
<*> Serial ATA and Parallel ATA drivers (libata) --->
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Thu Jun 02, 2016 4:51 am    Post subject: Reply with quote

das habe ich wohl beim Kernel-Update mit make oldconfig übersehen...

ist geändert.

zsh ist meine login-shell. Bash ist wohl noch installiert, lässt sich aber mit ALT-F2 nicht starten. Da muss ich nochmal sehen, woran das liegt...

emerge -auDNtv --verbose-conflicts --backtrack=300 world führt zu


Code:
....
[blocks B      ] <kde-frameworks/kactivities-5.20.0 ("<kde-frameworks/kactivities-5.20.0" is blocking kde-plasma/kactivitymanagerd-5.5.0, kde-plasma/kactivities-workspace-5.5.0)

Total: 121 packages (92 upgrades, 2 downgrades, 7 new, 8 in new slots, 12 reinstalls, 5 uninstalls), Size of downloads: 405.045 KiB
Conflict: 8 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-57.1:0/57::gentoo, installed) pulled in by
    dev-libs/icu:0/57= required by (mail-mta/postfix-3.0.3-r1:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    dev-libs/icu:0/57= required by (net-nds/openldap-2.4.38-r2:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    dev-libs/icu:0/57= required by (media-libs/libvisio-0.1.5:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    dev-libs/icu:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-db/sqlite-3.12.0:3/3::gentoo, installed)
                ^^^^^^                                                                                                                           
    dev-libs/icu:0/57= required by (app-text/libmspub-0.1.2:0/0::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtcore-4.8.7-r2:4/4::gentoo, installed)
                ^^^^^^                                                                                                                             
    >=dev-libs/icu-3.8.1-r1:0/57= required by (net-libs/webkit-gtk-2.4.10-r200:2/2::gentoo, installed)
                           ^^^^^^                                                                                                         
    dev-libs/icu:0/57= required by (dev-qt/qtcore-5.6.0:5/5.6::gentoo, installed)
                ^^^^^^                                                                                               
    >=dev-libs/icu-50:0/57= required by (app-text/texlive-core-2014-r4:0/0::gentoo, installed)
                     ^^^^^^                                                                                                       
    >=dev-libs/icu-3.8.1-r1:0/57= required by (net-libs/webkit-gtk-2.10.9:4/37::gentoo, installed)
                           ^^^^^^                                                                                                     
    dev-libs/icu:0/57= required by (dev-qt/qtwebkit-5.6.0:5/5.6::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/57= required by (app-text/libebook-0.1.2-r1:0/0::gentoo, installed)
                ^^^^^^                                                                                                   
    dev-libs/icu:0/57= required by (media-libs/raptor-2.0.9:2/2::gentoo, installed)
                ^^^^^^                                                                                                 
    dev-libs/icu:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtwebkit-4.8.7:4/4::gentoo, installed)
                ^^^^^^                                                                                                                           
    >=dev-libs/icu-4.4:0/57= required by (dev-tex/bibtexu-3.71_p20140525:0/0::gentoo, installed)
                      ^^^^^^                                                                                                       
    >=dev-libs/icu-51.2-r1:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/libxml2-2.9.3:2/2::gentoo, installed)
                          ^^^^^^                                                                                                                             
    >=dev-libs/icu-3.6:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed)
                      ^^^^^^                                                                                                                                   
    >=dev-libs/icu-51.2-r1:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/harfbuzz-1.1.3:0/0.9.18::gentoo, installed)
                          ^^^^^^                                                                                                                                     
    dev-libs/icu:0/57= required by (gnome-extra/evolution-data-server-3.18.5:0/54::gentoo, installed)
                ^^^^^^                                                                                                                   
    >=dev-libs/icu-3.8.1-r1:0/57= required by (net-libs/webkit-gtk-2.4.10:3/25::gentoo, installed)
                           ^^^^^^                                                                                                     
    dev-libs/icu:0/57= required by (media-libs/libcdr-0.1.1:0/0::gentoo, installed)
                ^^^^^^                                                                                                 
    >=dev-libs/icu-4.8.1.1:0/57= required by (app-office/libreoffice-5.1.2.2:0/0::gentoo, installed)
                          ^^^^^^                                                                                                       

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/icu-4.4:0/55= required by (app-text/calibre-2.47.0:0/0::gentoo, installed)
                      ^^^^^^                                                                                                 

kde-frameworks/kactivities:5

  (kde-frameworks/kactivities-5.18.0-r1:5/5.18::gentoo, installed) pulled in by
    <kde-frameworks/kactivities-5.20.0:5 required by (kde-base/kactivities-4.13.3-r2:4/4.13::gentoo, installed)
    ^                           ^^^^^^^^                                                                                                                                                 

  (kde-frameworks/kactivities-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kactivities-5.21.0:5 required by (kde-plasma/kactivities-workspace-5.5.0:5/5::gentoo, ebuild scheduled for merge)
    ^^                           ^^^^^^^^                                                                                                                                                                       
    >=kde-frameworks/kactivities-5.21.0:5 required by (kde-plasma/plasma-workspace-5.5.5-r2:5/5::gentoo, installed)
    ^^                           ^^^^^^^^                                                                                                                                                   
    >=kde-frameworks/kactivities-5.21.0:5 required by (kde-plasma/kwin-5.5.5:5/5::gentoo, installed)
    ^^                           ^^^^^^^^                                                                                                                                     
    >=kde-frameworks/kactivities-5.21:5 required by (kde-frameworks/plasma-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    ^^                           ^^^^^^                                                                                           


Sieht nach einem fehlgeschlagenem Plasma-Update aus, oder?
uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Thu Jun 02, 2016 5:29 am    Post subject: Reply with quote

uhai wrote:
zsh ist meine login-shell. Bash ist wohl noch installiert, lässt sich aber mit ALT-F2 nicht starten. Da muss ich nochmal sehen, woran das liegt...

"bash" lässt sich garantiert mit krunner starten. Nur siehst du nix, weil es eben nur ne shell ist und kein terminal. Mach mal dein terminal (konsole, xterm, urxvt) auf und tippe da "bash" ein. Oder führe mit Alt+F2 "bash -c dolphin" aus ;)

Quote:
emerge -auDNtv --verbose-conflicts --backtrack=300 world führt zu


Code:
....
[blocks B      ] <kde-frameworks/kactivities-5.20.0 ("<kde-frameworks/kactivities-5.20.0" is blocking kde-plasma/kactivitymanagerd-5.5.0, kde-plasma/kactivities-workspace-5.5.0)
...
kde-frameworks/kactivities:5

  (kde-frameworks/kactivities-5.18.0-r1:5/5.18::gentoo, installed) pulled in by
    <kde-frameworks/kactivities-5.20.0:5 required by (kde-base/kactivities-4.13.3-r2:4/4.13::gentoo, installed)
    ^                           ^^^^^^^^                                                                                                                                                 

  (kde-frameworks/kactivities-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kactivities-5.21.0:5 required by (kde-plasma/kactivities-workspace-5.5.0:5/5::gentoo, ebuild scheduled for merge)
    ^^                           ^^^^^^^^                                                                                                                                                                       
    >=kde-frameworks/kactivities-5.21.0:5 required by (kde-plasma/plasma-workspace-5.5.5-r2:5/5::gentoo, installed)
    ^^                           ^^^^^^^^                                                                                                                                                   
    >=kde-frameworks/kactivities-5.21.0:5 required by (kde-plasma/kwin-5.5.5:5/5::gentoo, installed)
    ^^                           ^^^^^^^^                                                                                                                                     
    >=kde-frameworks/kactivities-5.21:5 required by (kde-frameworks/plasma-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    ^^                           ^^^^^^                                                                                           


Sieht nach einem fehlgeschlagenem Plasma-Update aus, oder?
uhai

Aus kde-base/kactivities-4.13.3-r2:
Code:
   || ( $(add_kdebase_dep kactivitymanagerd) <kde-frameworks/kactivities-5.20.0:5 kde-plasma/kactivitymanagerd:5 )

kde-base/kactivitymanagerd oder kde-plasma/kactivitymanagerd installieren könnte hier helfen, kann aber auch ein portage-bug sein, wenn es den Block noch immer anzeigt.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Thu Jun 02, 2016 8:30 pm    Post subject: Reply with quote

kde-plasma/kactivitymanagerd habe ich installiert, der BLock ist weg, das hier bleibt:

Code:
>>> Emerging (18 of 108) dev-python/qscintilla-python-2.8.4::gentoo
 * QScintilla-gpl-2.8.4.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                         [ ok ]
>>> Unpacking source...
>>> Unpacking QScintilla-gpl-2.8.4.tar.gz to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work
>>> Source unpacked in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work
>>> Preparing source in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python ...
 * Will copy sources from /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python
 * python2_7: copying to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python2_7
 * python3_4: copying to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python3_4
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python ...
 * python2_7: running run_in_build_dir configuration
/usr/bin/python2.7 configure.py --destdir=/usr/lib64/python2.7/site-packages/PyQt4 --sip-incdir=/usr/include/python2.7 --pyqt-sipdir=/usr/share/sip --qsci-sipdir=/usr/share/sip --pyqt=PyQt4 --no-timestamp
Error: Unable to create the C++ code.
Configuring QScintilla 2.8.4...
QScintilla 2.8.4 is being used.
The QScintilla .sip files will be installed in /usr/share/sip.
The QScintilla module will be installed in
/usr/lib64/python2.7/site-packages/PyQt4.
PyQt 4.11.4 is being used.
Qt 4.8.7 is being used.
sip 4.16.9 is being used.
The sip executable is /usr/bin/sip.
The QScintilla module is being built with 'protected' redefined as 'public'.
The QScintilla API file will be installed in /usr/share/qt4/qsci/api/python.
Generating the C++ source for the Qsci module...
 * ERROR: dev-python/qscintilla-python-2.8.4::gentoo failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  133:  Called src_configure
 *   environment, line 3267:  Called python_foreach_impl 'run_in_build_dir' 'configuration'
 *   environment, line 2751:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1929:  Called _multibuild_run '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1927:  Called _python_multibuild_wrapper 'run_in_build_dir' 'configuration'
 *   environment, line  454:  Called run_in_build_dir 'configuration'
 *   environment, line 3249:  Called configuration
 *   environment, line 3264:  Called die
 * The specific snippet of code:
 *           "${myconf[@]}" || die;
 *
 * If you need support, post the output of `emerge --info '=dev-python/qscintilla-python-2.8.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/qscintilla-python-2.8.4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python2_7'
 * S: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python'

>>> Failed to emerge dev-python/qscintilla-python-2.8.4, Log file:

>>>  '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'


Nach emerge --resume --skipfirst

Code:
Makefile:513: recipe for target 'fontconfig_database.o' failed
make: *** [fontconfig_database.o] Error 1
Error while executing: make -j4

Traceback (most recent call last):
  File "setup.py", line 99, in <module>
    sys.exit(main())
  File "setup.py", line 85, in main
    command.run_all(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 181, in run_all
    self.run_cmd(self, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 175, in run_cmd
    self.run_cmd(scmd, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 178, in run_cmd
    cmd.run(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 434, in run
    self.build_headless()
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 570, in build_headless
    self.check_call([make] + ['-j%d'%(cpu_count or 1)])
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 506, in check_call
    subprocess.check_call(*args, **kwargs)
  File "/usr/lib64/python2.7/subprocess.py", line 540, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['make', '-j4']' returned non-zero exit status 2
 * ERROR: app-text/calibre-2.47.0::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line 133:  Called src_install
 *   environment, line 3163:  Called die
 * The specific snippet of code:
 *       PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} "${PYTHON}" setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="${ED}usr" --staging-libdir="${ED}usr/${libdir}" || die;
 *
 * If you need support, post the output of `emerge --info '=app-text/calibre-2.47.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-text/calibre-2.47.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'
 * S: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'

>>> Failed to emerge app-text/calibre-2.47.0, Log file:

>>>  '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'

und zum Schluß:
Code:
!!! existing preserved libs:
>>> package: media-gfx/imagemagick-6.9.4.1
 *  - /usr/lib64/libMagickWand-6.Q64HDRI.so.2
 *  - /usr/lib64/libMagickWand-6.Q64HDRI.so.2.0.0
 *      used by /usr/lib64/calibre/calibre/plugins/magick.so (app-text/calibre-2.47.0)
 *  - /usr/lib64/libMagickCore-6.Q64HDRI.so.2
 *  - /usr/lib64/libMagickCore-6.Q64HDRI.so.2.0.0
>>> package: x11-libs/qscintilla-2.8.4-r1
 *  - /usr/lib64/qt4/libqscintilla2.so.12
 *  - /usr/lib64/qt4/libqscintilla2.so.12.0.0
 *      used by /usr/lib64/python2.7/site-packages/PyQt4/Qsci.so (dev-python/qscintilla-python-2.9)
 *      used by /usr/lib64/python3.4/site-packages/PyQt4/Qsci.so (dev-python/qscintilla-python-2.9)
>>> package: dev-libs/icu-57.1
 *  - /usr/lib64/libicuuc.so.55
 *  - /usr/lib64/libicuuc.so.55.1
 *      used by /usr/lib64/calibre/calibre/plugins/icu.so (app-text/calibre-2.47.0)
 *      used by /usr/lib64/calibre/calibre/plugins/matcher.so (app-text/calibre-2.47.0)
 *  - /usr/lib64/libicui18n.so.55
 *  - /usr/lib64/libicui18n.so.55.1
 *      used by /usr/lib64/calibre/calibre/plugins/icu.so (app-text/calibre-2.47.0)
 *      used by /usr/lib64/calibre/calibre/plugins/matcher.so (app-text/calibre-2.47.0)
 *  - /usr/lib64/libicudata.so.55
 *  - /usr/lib64/libicudata.so.55.1
Use emerge @preserved-rebuild to rebuild packages using these libraries

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Fri Jun 03, 2016 5:02 am    Post subject: Reply with quote

Jetzt in bash:

Code:
/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/headless/fontconfig_database.cpp:275:1: error: static assertion failed: sizeof(specialLanguages) / sizeof(const char *) == QChar::ScriptCount
 Q_STATIC_ASSERT(sizeof(specialLanguages) / sizeof(const char *) == QChar::ScriptCount);
 ^
Makefile:513: recipe for target 'fontconfig_database.o' failed
make: *** [fontconfig_database.o] Error 1
Error while executing: make -j4

Traceback (most recent call last):
  File "setup.py", line 99, in <module>
    sys.exit(main())
  File "setup.py", line 85, in main
    command.run_all(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 181, in run_all
    self.run_cmd(self, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 175, in run_cmd
    self.run_cmd(scmd, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 178, in run_cmd
    cmd.run(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 434, in run
    self.build_headless()
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 570, in build_headless
    self.check_call([make] + ['-j%d'%(cpu_count or 1)])
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 506, in check_call
    subprocess.check_call(*args, **kwargs)
  File "/usr/lib64/python2.7/subprocess.py", line 540, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['make', '-j4']' returned non-zero exit status 2
 * ERROR: app-text/calibre-2.47.0::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line 133:  Called src_install
 *   environment, line 3163:  Called die
 * The specific snippet of code:
 *       PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} "${PYTHON}" setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="${ED}usr" --staging-libdir="${ED}usr/${libdir}" || die;
 *
 * If you need support, post the output of `emerge --info '=app-text/calibre-2.47.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-text/calibre-2.47.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'
 * S: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'

>>> Failed to emerge app-text/calibre-2.47.0, Log file:

>>>  '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'


und nach emerge --resume --skipfirst:

Code:
>>> Emerging (1 of 1) dev-python/qscintilla-python-2.8.4::gentoo
 * QScintilla-gpl-2.8.4.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                         [ ok ]
>>> Unpacking source...
>>> Unpacking QScintilla-gpl-2.8.4.tar.gz to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work
>>> Source unpacked in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work
>>> Preparing source in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python ...
 * Will copy sources from /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python
 * python2_7: copying to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python2_7
 * python3_4: copying to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python3_4
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python ...
 * python2_7: running run_in_build_dir configuration
/usr/bin/python2.7 configure.py --destdir=/usr/lib64/python2.7/site-packages/PyQt4 --sip-incdir=/usr/include/python2.7 --pyqt-sipdir=/usr/share/sip --qsci-sipdir=/usr/share/sip --pyqt=PyQt4 --no-timestamp
Error: Unable to create the C++ code.
Configuring QScintilla 2.8.4...
QScintilla 2.8.4 is being used.
The QScintilla .sip files will be installed in /usr/share/sip.
The QScintilla module will be installed in
/usr/lib64/python2.7/site-packages/PyQt4.
PyQt 4.11.4 is being used.
Qt 4.8.7 is being used.
sip 4.16.9 is being used.
The sip executable is /usr/bin/sip.
The QScintilla module is being built with 'protected' redefined as 'public'.
The QScintilla API file will be installed in /usr/share/qt4/qsci/api/python.
Generating the C++ source for the Qsci module...
 * ERROR: dev-python/qscintilla-python-2.8.4::gentoo failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  133:  Called src_configure
 *   environment, line 3267:  Called python_foreach_impl 'run_in_build_dir' 'configuration'
 *   environment, line 2751:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1929:  Called _multibuild_run '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1927:  Called _python_multibuild_wrapper 'run_in_build_dir' 'configuration'
 *   environment, line  454:  Called run_in_build_dir 'configuration'
 *   environment, line 3249:  Called configuration
 *   environment, line 3264:  Called die
 * The specific snippet of code:
 *           "${myconf[@]}" || die;
 *
 * If you need support, post the output of `emerge --info '=dev-python/qscintilla-python-2.8.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/qscintilla-python-2.8.4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python2_7'
 * S: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python'

>>> Failed to emerge dev-python/qscintilla-python-2.8.4, Log file:

>>>  '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'


Das liegt doch an Python irgendwie, oder?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Fri Jun 03, 2016 5:00 pm    Post subject: Reply with quote

Puh.., hast du den Vorschlag aus https://forums.gentoo.org/viewtopic-p-7926192.html#7926192 mal versucht?
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Fri Jun 03, 2016 6:59 pm    Post subject: Reply with quote

Hab ich aus den Augen verloren - jetzt aber - hier ist das Ergebnis:

Code:
Makefile:513: recipe for target 'fontconfig_database.o' failed
make: *** [fontconfig_database.o] Error 1
Error while executing: make -j4

Traceback (most recent call last):
  File "setup.py", line 99, in <module>
    sys.exit(main())
  File "setup.py", line 85, in main
    command.run_all(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 181, in run_all
    self.run_cmd(self, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 175, in run_cmd
    self.run_cmd(scmd, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 178, in run_cmd
    cmd.run(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 434, in run
    self.build_headless()
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 570, in build_headless
    self.check_call([make] + ['-j%d'%(cpu_count or 1)])
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 506, in check_call
    subprocess.check_call(*args, **kwargs)
  File "/usr/lib64/python2.7/subprocess.py", line 540, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['make', '-j4']' returned non-zero exit status 2
 * ERROR: app-text/calibre-2.47.0::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line 133:  Called src_install
 *   environment, line 3163:  Called die
 * The specific snippet of code:
 *       PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} "${PYTHON}" setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="${ED}usr" --staging-libdir="${ED}usr/${libdir}" || die;
 *
 * If you need support, post the output of `emerge --info '=app-text/calibre-2.47.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-text/calibre-2.47.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'
 * S: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'

>>> Failed to emerge app-text/calibre-2.47.0, Log file:

>>>  '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Fri Jun 03, 2016 8:17 pm    Post subject: Reply with quote

Hm nein, das app-text/calibre-2.47 Ergebnis kann nicht von dem vorgeschlagenen
Code:
emerge -av1 =sip-4.16.9 =x11-libs/qscintilla-2.8.4-r1 =dev-python/PyQt4-4.11.1 =dev-python/qscintilla-python-2.8.4
rebuild kommen.

calibre-2.47 ist ne andere Geschichte, das basiert auf Qt 5 und dev-python/PyQt5
qscintilla-python-2.8.4 basiert auf Qt 4 und dev-python/PyQt4
sprich diese beiden Sachen sollte man ein wenig getrennt voneinander betrachten.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sat Jun 04, 2016 4:15 am    Post subject: Reply with quote

Sorry,

das war das nachfolgende emerge @preserved-rebuild


Der shutdown läuft immer noch nicht :-(

Code:
systemctl
Failed to list units: Die Wartezeit für die Verbindung ist abgelaufen


Code:

init 0
init: timeout opening/writing control channel /dev/initctl


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Fri Jun 10, 2016 5:16 pm    Post subject: Reply with quote

Das ist der Rest, der immer abbricht:

Code:
Calculating dependencies... done!
[ebuild  rR   ~] app-text/calibre-2.47.0::gentoo  USE="udisks" PYTHON_TARGETS="python2_7" 0 KiB
[nomerge       ] virtual/dev-manager-0::gentoo
[ebuild  N     ]  sys-fs/static-dev-0.1::gentoo  0 KiB
[ebuild  N     ]   sys-apps/makedev-3.23.1::gentoo  USE="-build (-selinux)" 0 KiB

Total: 3 packages (2 new, 1 reinstall), Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-drivers/nvidia-drivers:0

  (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, ebuild scheduled for merge) conflicts with
    ~x11-drivers/nvidia-drivers-340.93 required by (media-video/nvidia-settings-340.58:0/0::gentoo, installed)
    ^                           ^^^^^^

sys-apps/systemd:0

  (sys-apps/systemd-230-r1:0/2::gentoo, ebuild scheduled for merge) conflicts with
    <sys-apps/systemd-230 required by (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed)


Kann da der Grund für den fehlenden shutdown liegen?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Fri Jun 10, 2016 9:28 pm    Post subject: Reply with quote

Ah, dann hat sich die
* ERROR: dev-python/qscintilla-python-2.8.4::gentoo failed (configure phase)
Geschichte erledigt? (prima das du das nebenbei auch mal nicht mit erwähnst...)

uhai wrote:
Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-drivers/nvidia-drivers:0

  (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, ebuild scheduled for merge) conflicts with
    ~x11-drivers/nvidia-drivers-340.93 required by (media-video/nvidia-settings-340.58:0/0::gentoo, installed)
Das sollte sich erledigen indem du =media-video/nvidia-settings-340.58-r1 in den keywords freischaltest.

uhai wrote:
Code:
[nomerge       ] virtual/dev-manager-0::gentoo
[ebuild  N     ]  sys-fs/static-dev-0.1::gentoo  0 KiB
[ebuild  N     ]   sys-apps/makedev-3.23.1::gentoo  USE="-build (-selinux)" 0 KiB
Code:
sys-apps/systemd:0

  (sys-apps/systemd-230-r1:0/2::gentoo, ebuild scheduled for merge) conflicts with
    <sys-apps/systemd-230 required by (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed)
Das sollte sich erledigen indem du nicht die, zu deinem stable xorg-server-1.17 inkompatible höchste testing >=sys-apps/systemd-230 Version freischaltest.
Schalte hier am besten nur die vom x11-base/xorg-server-1.17.4[systemd] Ebuild kompatible <sys-apps/systemd-230 Version frei, und keine höhere.

uhai wrote:
Kann da der Grund für den fehlenden shutdown liegen?
Wahrscheinlich eher nicht.
Aber ist damit gemeint das /sbin/shutdown nicht vorhanden ist? Falls ja, dann poste bitte mal mit welchen Useflags sys-apps/systemd gebaut wurde (emerge -pv sys-apps/systemd).
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sat Jun 11, 2016 11:16 am    Post subject: Reply with quote

Josef.95 wrote:
Ah, dann hat sich die
* ERROR: dev-python/qscintilla-python-2.8.4::gentoo failed (configure phase)
Geschichte erledigt? (prima das du das nebenbei auch mal nicht mit erwähnst...)


Ob's erledigt weiss ich nicht. emerge -auDNtv --verbose-conflicts --backtrack=300 world löst es nur nicht aus. Bisher konnte ich es jedenfalls nicht ohne Abbruch "emergen".

Josef.95 wrote:

uhai wrote:
Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-drivers/nvidia-drivers:0

  (x11-drivers/nvidia-drivers-340.96:0/340::gentoo, ebuild scheduled for merge) conflicts with
    ~x11-drivers/nvidia-drivers-340.93 required by (media-video/nvidia-settings-340.58:0/0::gentoo, installed)
Das sollte sich erledigen indem du =media-video/nvidia-settings-340.58-r1 in den keywords freischaltest.


ok, das habe ich....

[quote="Josef.95"]
uhai wrote:
Code:
[nomerge       ] virtual/dev-manager-0::gentoo
[ebuild  N     ]  sys-fs/static-dev-0.1::gentoo  0 KiB
[ebuild  N     ]   sys-apps/makedev-3.23.1::gentoo  USE="-build (-selinux)" 0 KiB
Code:
sys-apps/systemd:0

  (sys-apps/systemd-230-r1:0/2::gentoo, ebuild scheduled for merge) conflicts with
    <sys-apps/systemd-230 required by (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed)
Das sollte sich erledigen indem du nicht die, zu deinem stable xorg-server-1.17 inkompatible höchste testing >=sys-apps/systemd-230 Version freischaltest.
Schalte hier am besten nur die vom x11-base/xorg-server-1.17.4[systemd] Ebuild kompatible <sys-apps/systemd-230 Version frei, und keine höhere.

HM, das habe ich hier gefunden: http://gentoo-en.vfose.ru/wiki/Systemd#Installation - ist vielleicht nicht mehr nötig? Hab mal wieder kein Datum in den Kommentarzeilen hinterlassen. Ich kommentiere die Einträge mal aus.

Josef.95 wrote:

uhai wrote:
Kann da der Grund für den fehlenden shutdown liegen?
Wahrscheinlich eher nicht.
Aber ist damit gemeint das /sbin/shutdown nicht vorhanden ist? Falls ja, dann poste bitte mal mit welchen Useflags sys-apps/systemd gebaut wurde (emerge -pv sys-apps/systemd).


Nein, damit ist gemeint, dass jeder Versuch shutdown scheitert:
Code:
systemctl poweroff
Failed to power off system via logind: Failed to activate service 'org.freedesktop.systemd1': timed out
Failed to start poweroff.target: Failed to activate service 'org.freedesktop.systemd1': timed out
See system logs and 'systemctl status poweroff.target' for details.


Code:
systemctl status poweroff.target
Failed to get properties: Die Wartezeit für die Verbindung ist abgelaufen


Also timeout?

Code:
 ls /sbin/s*
/sbin/service  /sbin/sfdisk    /sbin/slattach  /sbin/smtp  /sbin/start-stop-daemon  /sbin/sulogin    /sbin/swapoff  /sbin/switch_root
/sbin/setcap   /sbin/shutdown  /sbin/sln       /sbin/ss    /sbin/startproc          /sbin/swaplabel  /sbin/swapon


shutdown ist da. systemd habe ich auch schon mal neu installiert, ohne Verbesserung. Aber vielleicht hilft das downgrade von systemd.

journald hat haufenweise solche Einträge im log:

Code:
....
[3090364.304004] systemd-journald[110]: Failed to send WATCHDOG=1 notification message: Transport endpoint is not connected
[3090452.012377] systemd-journald[110]: Failed to send WATCHDOG=1 notification message: Transport endpoint is not connected
[3090542.610922] systemd-journald[110]: Failed to send WATCHDOG=1 notification message: Transport endpoint is not connected


Welches log sollte ich noch prüfen? Grep systemd hat nur vier Einträge von 2016 in portage/elog gefunden:

Code:
var/log/portage/elog/kde-plasma:ksshaskpass-5.5.5:20160414-040520.log:lines in /etc/plasma/shutdown/10-agent-shutdown.sh to
/var/log/portage/elog/kde-base:kdebase-startkde-4.11.22:20160306-162231.log:/etc/kde/shutdown/agent-shutdown.sh
/var/log/portage/elog/sys-power:apcupsd-3.14.13:20160609-203615.log:add apcupsd.powerfail to your shutdown runlevel:
/var/log/portage/elog/sys-power:apcupsd-3.14.13:20160609-203615.log:  rc-update add apcupsd.powerfail shutdown


Sorry, wenn Du verärgerst wegen dev-python/qscintilla-python-2.8.4 bist, ich habe nur den Output mienes Update-emerge gepostet weil ich mich gefreut habe, dass die lange Liste so eingeschrumpft ist.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sat Jun 11, 2016 2:00 pm    Post subject: Reply with quote

Wieder ein Abbruch bei calibre:

Code:
####### Building headless QPA plugin #######
Project MESSAGE: This project is using private headers and will therefore be tied to this specific Qt module build version.
Project MESSAGE: Running this project against other versions of the Qt modules may crash at any arbitrary point.
Project MESSAGE: This is not a bug, but a result of using Qt internals. You have been warned!
g++ -c -pipe -O2 -std=c++1y -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_PLUGIN -DQT_PLATFORMSUPPORT_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I. -isystem /usr/include/freetype2 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtPlatformSupport -isystem /usr/include/qt5/QtPlatformSupport/5.6.0 -isystem /usr/include/qt5/QtPlatformSupport/5.6.0/QtPlatformSupport -isystem /usr/include/qt5/QtGui/5.6.0 -isystem /usr/include/qt5/QtGui/5.6.0/QtGui -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtCore/5.6.0 -isystem /usr/include/qt5/QtCore/5.6.0/QtCore -isystem /usr/include/qt5/QtCore -I. -I/usr/lib64/qt5/mkspecs/linux-g++ -o headless_integration.o /var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/headless/headless_integration.cpp
g++ -c -pipe -O2 -std=c++1y -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_PLUGIN -DQT_PLATFORMSUPPORT_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I. -isystem /usr/include/freetype2 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtPlatformSupport -isystem /usr/include/qt5/QtPlatformSupport/5.6.0 -isystem /usr/include/qt5/QtPlatformSupport/5.6.0/QtPlatformSupport -isystem /usr/include/qt5/QtGui/5.6.0 -isystem /usr/include/qt5/QtGui/5.6.0/QtGui -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtCore/5.6.0 -isystem /usr/include/qt5/QtCore/5.6.0/QtCore -isystem /usr/include/qt5/QtCore -I. -I/usr/lib64/qt5/mkspecs/linux-g++ -o headless_backingstore.o /var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/headless/headless_backingstore.cpp
/usr/lib64/qt5/bin/moc -DQT_NO_DEBUG -DQT_PLUGIN -DQT_PLATFORMSUPPORT_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib64/qt5/mkspecs/linux-g++ -I/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/build/headless -I/usr/include/freetype2 -I/usr/include/qt5 -I/usr/include/qt5/QtPlatformSupport -I/usr/include/qt5/QtPlatformSupport/5.6.0 -I/usr/include/qt5/QtPlatformSupport/5.6.0/QtPlatformSupport -I/usr/include/qt5/QtGui/5.6.0 -I/usr/include/qt5/QtGui/5.6.0/QtGui -I/usr/include/qt5/QtGui -I/usr/include/qt5/QtCore/5.6.0 -I/usr/include/qt5/QtCore/5.6.0/QtCore -I/usr/include/qt5/QtCore -I/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4 -I/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/x86_64-pc-linux-gnu -I/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/backward -I/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include -I/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include-fixed -I/usr/include /var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/headless/main.cpp -o main.moc
g++ -c -pipe -O2 -std=c++1y -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_PLUGIN -DQT_PLATFORMSUPPORT_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I. -isystem /usr/include/freetype2 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtPlatformSupport -isystem /usr/include/qt5/QtPlatformSupport/5.6.0 -isystem /usr/include/qt5/QtPlatformSupport/5.6.0/QtPlatformSupport -isystem /usr/include/qt5/QtGui/5.6.0 -isystem /usr/include/qt5/QtGui/5.6.0/QtGui -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtCore/5.6.0 -isystem /usr/include/qt5/QtCore/5.6.0/QtCore -isystem /usr/include/qt5/QtCore -I. -I/usr/lib64/qt5/mkspecs/linux-g++ -o fontconfig_database.o /var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/headless/fontconfig_database.cpp
g++ -c -pipe -O2 -std=c++1y -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_PLUGIN -DQT_PLATFORMSUPPORT_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I. -isystem /usr/include/freetype2 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtPlatformSupport -isystem /usr/include/qt5/QtPlatformSupport/5.6.0 -isystem /usr/include/qt5/QtPlatformSupport/5.6.0/QtPlatformSupport -isystem /usr/include/qt5/QtGui/5.6.0 -isystem /usr/include/qt5/QtGui/5.6.0/QtGui -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtCore/5.6.0 -isystem /usr/include/qt5/QtCore/5.6.0/QtCore -isystem /usr/include/qt5/QtCore -I. -I/usr/lib64/qt5/mkspecs/linux-g++ -o main.o /var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/headless/main.cpp
/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/headless/fontconfig_database.cpp:275:1: error: static assertion failed: sizeof(specialLanguages) / sizeof(const char *) == QChar::ScriptCount
 Q_STATIC_ASSERT(sizeof(specialLanguages) / sizeof(const char *) == QChar::ScriptCount);
 ^
Makefile:513: recipe for target 'fontconfig_database.o' failed
make: *** [fontconfig_database.o] Error 1
Error while executing: make -j4

Traceback (most recent call last):
  File "setup.py", line 99, in <module>
    sys.exit(main())
  File "setup.py", line 85, in main
    command.run_all(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 181, in run_all
    self.run_cmd(self, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 175, in run_cmd
    self.run_cmd(scmd, opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/__init__.py", line 178, in run_cmd
    cmd.run(opts)
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 434, in run
    self.build_headless()
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 570, in build_headless
    self.check_call([make] + ['-j%d'%(cpu_count or 1)])
  File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/setup/extensions.py", line 506, in check_call
    subprocess.check_call(*args, **kwargs)
  File "/usr/lib64/python2.7/subprocess.py", line 540, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['make', '-j4']' returned non-zero exit status 2
 * ERROR: app-text/calibre-2.47.0::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line 133:  Called src_install
 *   environment, line 3168:  Called die
 * The specific snippet of code:
 *       PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} "${PYTHON}" setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="${ED}usr" --staging-libdir="${ED}usr/${libdir}" || die;
 *
 * If you need support, post the output of `emerge --info '=app-text/calibre-2.47.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-text/calibre-2.47.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/calibre-2.47.0/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'
 * S: '/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0'

>>> Failed to emerge app-text/calibre-2.47.0, Log file:

>>>  '/var/tmp/portage/app-text/calibre-2.47.0/temp/build.log'


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Mon Jun 13, 2016 6:19 pm    Post subject: Reply with quote

calibre-2.47 hatte ich in den keywords. Leider klappt es ohne mit calibre-1.20 auch nicht:

Code:
Calculating dependencies... done!
[ebuild     UD ] app-text/calibre-1.20::gentoo [2.47.0::gentoo] USE="udisks" PYTHON_TARGETS="(-python2_7%*)" 0 KiB

Total: 1 package (1 downgrade), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) app-text/calibre-1.20::gentoo
 * calibre-1.20.0.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                               [ ok ]
>>> Unpacking source...
>>> Unpacking calibre-1.20.0.tar.xz to /var/tmp/portage/app-text/calibre-1.20/work
>>> Source unpacked in /var/tmp/portage/app-text/calibre-1.20/work
>>> Preparing source in /var/tmp/portage/app-text/calibre-1.20/work/calibre ...
 * Applying calibre-1.20-no_updates_dialog.patch ...                                                                                                                                                        [ ok ]
 * Applying calibre-disable_plugins.patch ...                                                                                                                                                               [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-text/calibre-1.20/work/calibre ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-text/calibre-1.20/work/calibre ...
>>> Source compiled.
>>> Test phase [not enabled]: app-text/calibre-1.20

>>> Install calibre-1.20 into /var/tmp/portage/app-text/calibre-1.20/image/ category app-text
Traceback (most recent call last):
  File "setup.py", line 13, in <module>
    import setup.commands as commands
  File "/var/tmp/portage/app-text/calibre-1.20/work/calibre/setup/commands.py", line 34, in <module>
    from setup.extensions import Build
  File "/var/tmp/portage/app-text/calibre-1.20/work/calibre/setup/extensions.py", line 13, in <module>
    from PyQt4.pyqtconfig import QtGuiModuleMakefile
ImportError: No module named pyqtconfig
 * ERROR: app-text/calibre-1.20::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line 133:  Called src_install
 *   environment, line 2149:  Called die
 * The specific snippet of code:
 *       PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} "${EPREFIX}"/usr/bin/python2.7 setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="${ED}usr" --staging-libdir="${ED}usr/${libdir}" || die;
 *
 * If you need support, post the output of `emerge --info '=app-text/calibre-1.20::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-text/calibre-1.20::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-text/calibre-1.20/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/calibre-1.20/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/calibre-1.20/work/calibre'
 * S: '/var/tmp/portage/app-text/calibre-1.20/work/calibre'

>>> Failed to emerge app-text/calibre-1.20, Log file:

>>>  '/var/tmp/portage/app-text/calibre-1.20/temp/build.log'


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
LuxJux
Guru
Guru


Joined: 01 Mar 2016
Posts: 300

PostPosted: Mon Jun 13, 2016 9:04 pm    Post subject: Reply with quote

LuxJux wrote:
Reboot ging doch noch nie. Runterfahren oder Taste drücken war die einzige Möglichkeit.

Da hatte ich was falsch geschrieben. Reboot ging immer.
Ausschalten
in console oder auch WM
Code:
 shutdown now 10

ging nie. DANKE, daß sich jemand diesen Bug mal näher unter die Lupe nimmt
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Tue Jun 14, 2016 6:12 am    Post subject: Reply with quote

uhai wrote:
calibre-2.47 hatte ich in den keywords. Leider klappt es ohne mit calibre-1.20 auch nicht: [...]

Vorschlag: Mache mal bitte ein rebuild von dev-python/PyQt5 (welche Version nutzt du da eigentlich?),
und teste es dann mit der aktuellen =app-text/calibre-2.55.0 Version.

------------------------------------------------------------------------
Bezüglich des eigentlichen (systemd) Thread-Themas:
Nur ein vager Schuß ins Blaue: Da ja scheinbar alle systemd bzw. systemctl Aufrufe fehlschlagen,
bist du dir sicher dass dein System tatsächlich noch mit systemd gestartet wird? (oder es zZt eher mit OpenRC läuft)?
Schau mal bitte was
Code:
cat /proc/1/comm
und
cat /proc/cmdline
dazu ausgibt.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Fri Jun 17, 2016 5:41 am    Post subject: Reply with quote

Ist noch systemd:

Code:
Master_Tux uhai # cat /proc/1/comm
systemd
Master_Tux uhai # cat /proc/cmdline
root=/dev/sda3 rootfstype=ext4 init=/usr/lib/systemd/systemd


PyQt5 habe ich das hier:
Code:

eix dev-python/PyQt5
[I] dev-python/PyQt5
     Verfügbare Versionen:   5.5 ~5.5.1 5.5.1[1] ~5.6.1_pre1604271126[1] {dbus debug declarative designer doc examples gles2 gui help multimedia network opengl positioning printsupport sensors serialport sql svg testlib webchannel webkit websockets widgets x11extras xmlpatterns PYTHON_TARGETS="python2_7 python3_3 python3_4 python3_5"}
     Installierte Versionen: 5.5.1(23:03:32 09.06.2016)(dbus declarative gui network opengl printsupport sql svg webkit widgets -debug -designer -doc -examples -gles2 -help -multimedia -positioning -sensors -serialport -testlib -webchannel -websockets -x11extras -xmlpatterns PYTHON_TARGETS="python2_7 python3_4 -python3_3 -python3_5")
     Startseite:             http://www.riverbankcomputing.com/software/pyqt/intro https://pypi.python.org/pypi/PyQt5
     Beschreibung:           Python bindings for the Qt framework


rebuild läuft.... und hat geklappt.

calibre-2.55.0 musste ich keyworden, ist aber auch gelaufen.

Müssten von systemd nicht irgendwelche Prozesse laufen? Wie starte ich die denn neu, falls die fehlen oder abgeschmiert sind?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum