Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Skiped modules due to missing programs [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Thu May 12, 2016 9:16 am    Post subject: Skiped modules due to missing programs [SOLVED] Reply with quote

Hello,
I noticed that there is a lof of skiped modules when OpenRC is rising network interface:
Code:
 * Bringing up interface enp0s3
 *   Skipping module adsl due to missing program: /usr/sbin/adsl-start /usr/sbin/pppoe-start
 *   Skipping module br2684ctl due to missing program: br2684ctl
 *   Skipping module clip due to missing program: /usr/sbin/atmsigd
 *   Skipping module ethtool due to missing program: ethtool
 *   Skipping module netplugd due to missing program: /sbin/netplugd
 *   Skipping module ifplugd due to missing program: /usr/sbin/ifplugd
 *   Skipping module ipppd due to missing program: /usr/sbin/ipppd
 *   Skipping module iwconfig due to missing program: /sbin/iwconfig
 *   Skipping module firewalld due to missing program: firewall-cmd
 *   Skipping module pppd due to missing program: /usr/sbin/pppd
 *   Skipping module dhclient due to missing program: /sbin/dhclient
 *   Skipping module pump due to missing program: /sbin/pump

I tried to either find those modules in kernel configuration and turn them off or install appriopriate packages to load those modules. Another strange think for me is I don't have those modules in my /etc/conf.d/modules
Code:
# You can define a list modules for a specific kernel version,
# a released kernel version, a main kernel version or just a list.
# The most specific versioned variable will take precedence.
#modules_2_6_23_gentoo_r5="ieee1394 ohci1394"
#modules_2_6_23="tun ieee1394"
#modules_2_6="tun"
#modules_2="ipv6"
modules="echainiv nf_nat_masquerade_ipv4 iptable_nat nf_log_ipv4 ipt_MASQUERADE nf_nat_ipv4 nf_log_arp nf_nat_sip xt_mark xt_nat nf_log_common nf_nat nf_nat_irc xt_LOG xt_addrtype nf_nat_ftp nf_log_ipv6"

# You can give modules a different name when they load - the new name
# will also be used to pick arguments below.
#modules="dummy:dummy1"

# Give the modules some arguments if needed, per version if necessary.
# Again, the most specific versioned variable will take precedence.
#module_ieee1394_args="debug"
#module_ieee1394_args_2_6_23_gentoo_r5="debug2"
#module_ieee1394_args_2_6_23="debug3"
#module_ieee1394_args_2_6="debug4"
#module_ieee1394_args_2="debug5"

# You should consult your kernel documentation and configuration
# for a list of modules and their options.

I can't find all these skiped modules in kernel configuration and I have problem to find all appriopriate programs to load modules, so my question is how to clean that mess with modules? :)


Last edited by truthSEeker71 on Thu May 19, 2016 9:18 am; edited 1 time in total
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 814

PostPosted: Thu May 12, 2016 9:28 am    Post subject: Reply with quote

this does not refer to kernel modules, but to modules used for modular network-configuration:
https://wiki.gentoo.org/wiki/Handbook:AMD64/Full/Networking#Network_modules
these are usually configured via /etc/conf.d/net.

GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Thu May 12, 2016 9:38 am    Post subject: Reply with quote

Ow wow, your're right. I completly missed that.
Thak you for your help. :)
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu May 12, 2016 9:39 am    Post subject: Re: Skiped modules due to missing programs Reply with quote

truthSEeker71 wrote:
I tried to either find those modules in kernel configuration and turn them off or install appriopriate packages to load those modules. Another strange think for me is I don't have those modules in my /etc/conf.d/modules

truthSEeker71 ... they are openrc "modules", and have nothing to do with kernel modules.

truthSEeker71 wrote:
I can't find all these skiped modules in kernel configuration and I have problem to find all appriopriate programs to load modules, so my question is how to clean that mess with modules? :)

If you define (or negate) modules via 'modules_${IFACE}' openrc shouldn't then attempt to guess what module the interface is configured by ... something like the following:

/etc/conf.d/net:
modules_eth0="!plug !wireless dhcpcd"

Note "!" negates the module, and 'plug' is related to ifplugd and netplugd, and 'wireless' to iwconfig, wpa_supplicant, etc.

I don't think I've seen such an output so I suspect its being provided on stdout is a new thing, but then I'm using an old openrc. The mechanism I describe should be the same however.

best ... khay
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Thu May 12, 2016 11:10 am    Post subject: Reply with quote

Stragne things are happening. I thought I disabled some modules but after reboot (actually after a few reboots) OpenRC is still skipping modules. It's like changed that I made to /etc/conf.d/net are completely not affecting OpenRC. I tried syntax like this:
    /etc/conf.d/net:
    Code:
    modules="!adsl !br2684ctl !pump !dhclient !ipppd !pppd !firewalld !wireless"

and like this:
    Code:
    modules_enp0s3="!adsl !br2684ctl !pump !dhclient !ipppd !pppd !firewalld !wireless"

with the same result: OpenRC still attempts to load negated modules.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu May 12, 2016 11:24 am    Post subject: Reply with quote

truthSEeker71 wrote:
Code:
modules_enp0s3="!adsl !br2684ctl !pump !dhclient !ipppd !pppd !firewalld !wireless"

truthSEeker71 ... you're not proving what it should use ... so, say, providing 'dhcpcd' would then settle the issue of what you intend netifrc to use for dhcp.

Code:
modules_enp0s3="!plug !wireless dhcpcd"

HTH & best ... khay
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Thu May 12, 2016 11:48 am    Post subject: Reply with quote

I'm not sure how to apply your advice to my situation... So should I first configure which modules OpenRC loads and then negate rest?
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu May 12, 2016 1:03 pm    Post subject: Reply with quote

truthSEeker71 wrote:
I'm not sure how to apply your advice to my situation... So should I first configure which modules OpenRC loads and then negate rest?

truthSEeker71 ... assuming you are using dhcpcd on enp0s3 then as I provided it above should sufice.

best ... khay
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Fri May 13, 2016 5:54 am    Post subject: Reply with quote

Okey, I think that I understand. I configured modules just like you wrote this but communicates from OpenRC about dhcp client are still same.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri May 13, 2016 6:11 am    Post subject: Reply with quote

truthSEeker71 wrote:
Okey, I think that I understand. I configured modules just like you wrote this but communicates from OpenRC about dhcp client are still same.

truthSEeker71 ... can you show me the config, I think you probably don't have 'config_$IFACE=' defined. It should look like:

/etc/conf.d/net:
config_enp0s3="dhcp"
modules_enp0s3="!plug !wireless dhcpcd"

best ... khay
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Fri May 13, 2016 6:48 am    Post subject: Reply with quote

It's not much in this file but maybe somethink is wrong:
    /etc/conf.d/net:
Code:

# Use DHCP to connect to the network
config_enp0s3="dhcp"

# Add EPK gateway in order to ignore proxy (proxy is rejecting rsync protocol)
routes_enp0s3="default via 172.16.1.50"
# Do not load some unneeded modules
modules_enp0s3="!pump !dhclient !plug !wireless dhcpcd"
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri May 13, 2016 7:26 am    Post subject: Reply with quote

truthSEeker71 ...

That looks fine (though you shouldn' need to negate pump, etc, as dhcpcd is defined), which version of netifrc are you using?

best ... khay
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Fri May 13, 2016 8:19 am    Post subject: Reply with quote

Yes you're right about pump but my OpenRC at this point tries to load pump and dhclient though my current net configuration. My netifrc version is 0.2.2:
Code:
# eix -I netifrc
[I] net-misc/netifrc
     Available versions:  0.2.2 ~0.2.3 ~0.2.4 ~0.3.0 ~0.3.1 **9999
     Installed versions:  0.2.2(07:26:11 05.05.2016)
     Homepage:            https://www.gentoo.org/proj/en/base/openrc/
     Description:         Gentoo Network Interface Management Scripts
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri May 13, 2016 8:41 pm    Post subject: Reply with quote

truthSEeker71 ...

I'm not exactly sure why you are getting that output, and from your conf.d/net I can only assume its the fact you are also defining a route (something with generally dhcpcd does). Can you try the following:

/etc/conf.d/net:
config_enp0s3="dhcp"
modules_enp0s3="!plug !wireless dhcpcd"
dhcpcd_enp0s3="--quiet --ipv4only -S routers=172.16.1.50"
enable_ipv6_enp0s3="false"

Though probably not the source of the above it might also be good to see what you have defined in rc.conf ...

Code:
# egrep -v '^(#|$)' /etc/rc.conf

best ... khay
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Mon May 16, 2016 7:04 am    Post subject: Reply with quote

Sorry for that 2 days break but I'm using Gentoo at work.
I was mixing static routing with dhcp in order to bypass work proxy and I didn't know that I could define route with dhcpcd.
I configured enp0s3 and dhcpcd like you wrote but output from OpenRC is still the same.
This is my rc.conf:
Back to top
View user's profile Send private message
truthSEeker71
n00b
n00b


Joined: 15 Jun 2015
Posts: 32

PostPosted: Thu May 19, 2016 9:18 am    Post subject: Reply with quote

I think that I coped with that modules.
I realized that I don't have to worry about this modules and I don't have to install additional programs that I don't need.
Another thing is when I disabled verbose output from OpenRC:
Code:
# If you want verbose output for OpenRC, set this to yes. If you want
# verbose output for service foo only, set it to yes in /etc/conf.d/foo.
rc_verbose=yes

OpenRC stopped complaining about these modules. So I for my preferences I will keep verbose output but for me problem is solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum