Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Haswell ULT HD Audio, no sound
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1364
Location: Fayetteville, NC, USA

PostPosted: Thu May 12, 2016 2:51 pm    Post subject: Haswell ULT HD Audio, no sound Reply with quote

Now that the video is working here, I cannot seem to get the audio up. I have the Realtek codec built into the kernel for the HDA Intel stuff, and it appears to be loaded, but I cannot record using arecord and in KDE I only have "Default" listed under playback devices.
Code:

00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)
        Subsystem: Dell 8 Series HD Audio Controller [1028:05de]
        Kernel driver in use: snd_hda_intel
~ # arecord -vv fdat test.wav
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.0.29/work/alsa-lib-1.0.29/src/pcm/pcm_dsnoop.c:614:(snd_pcm_dsnoop_open) unable to open slave
arecord: main:722: audio open error: No such file or directory
~ # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC3226 Analog [ALC3226 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

So what is going on? I can see the HDMI and the PCH cards in KMix and I have the PCH set as default, but in Settings->Multimedia it only has default. How can I get my sound up?
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Fri May 13, 2016 6:44 am    Post subject: Reply with quote

well, why not arecord --list-devices if you are trying to "record"?

and unlike what you think this:
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]

mean the default is set on HDMI and not the PCH one.

i know nothing about kmix, but for alsa, default card is hdmi.
look at https://wiki.gentoo.org/wiki/ALSA#HTML5_does_not_play_in_the_Firefox_browser and also the laptops with hmdi audio section


Quote:
I have the Realtek codec built into the kernel for the HDA Intel stuff, and it appears to be loaded

if your card is not using realtek, that won't prevent snd_intel_hda from loading ; and it's not because many users have a realtek codec that your card is using it too.
Code:
cat /proc/asound/card*/codec* | grep Codec
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1364
Location: Fayetteville, NC, USA

PostPosted: Fri May 13, 2016 2:47 pm    Post subject: Reply with quote

I believe I have it sorted. It IS a Realtek codec, ALC3239 IIRC. I created /etc/modprobe.d/snd-hda-intel.conf and added the following lines to switch defaults.
Code:

options snd-hda-intel index=0 model=auto vid=8086 pid=9c20
options snd-hda-intel index=1 model=auto vid=8086 pid=0a0c

The PIDs came from 'lspci -nn | grep audio'. Simple! Just need to reboot to make it take effect. The issue is that I have a Windows 7 Pro VM running in VirtualBox doing updates. You know how it goes!

1) Check for updates
2) Wait 16hrs, 43min
3) Select updates, click install
4) Now wait at 0kb, 0% for God only knows how many hours for it to actually download and install them!

Once it finishes I can shut down the VM and reboot. Have I mentioned that I hate Windows and love Gentoo lately? Anybody?
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum