Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]black screen after resume from hibernation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ronnem
n00b
n00b


Joined: 17 Apr 2016
Posts: 12

PostPosted: Wed May 11, 2016 5:54 pm    Post subject: [SOLVED]black screen after resume from hibernation Reply with quote

Hi. After resume from hibernation on my laptop, I have black screen. I can't switch between virtual ttty's, but I can log-in my laptop from another computer from ssh. I can manipulate with laptop brightness via /sys/class/backlight/radeon_bl0/brightness.
My laptop has only vga and hdmi, but in the end of dmesg after resume I can see this:
Code:
[  373.893125] [drm:radeon_dp_link_train] *ERROR* displayport link status failed
[  373.893130] [drm:radeon_dp_link_train] *ERROR* clock recovery failed
[  374.801733] [drm:radeon_dp_link_train] *ERROR* displayport link status failed
[  374.801738] [drm:radeon_dp_link_train] *ERROR* clock recovery failed

Does that mean that something is wrong with video driver?

#cat /etc/X11/xorg.conf.d/10-monitor.conf
Code:
Section "Monitor"
   Identifier "Monitor0"
EndSection

Section "Device"
   Identifier "Radeon HD 8330"
   Driver "radeon"
   Option "AccelMethod" "Glamor"
   Option "DRI3" "on"
EndSection

Section "Screen"
   Identifier "LaptopDisplay"
   Device "Radeon HD 8330"
   Monitor "Monitor0"
   DefaultDepth 24
   SubSection "Display"
      Depth 24
      Modes "1366x768_60.00"
   EndSubSection
EndSection

#cat /usr/src/linux/.config
https://bpaste.net/show/1ee3067c8786

#lspci|grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8330]

#dmesg
https://bpaste.net/show/ed5040b4762a

#cat /var/log/pm-suspend.log
https://bpaste.net/show/83330f7f0d37

#cat /var/log/pm-powersave.log
https://bpaste.net/show/8183f6ebcb48

#eix-installed repo|egrep "power|-ati|kernel|llvm|mesa|xorg"
Code:
app-eselect/eselect-mesa-0.0.10
media-libs/mesa-11.2.2
sys-devel/llvm-3.7.1-r1
sys-kernel/genkernel-3.4.52.3
sys-kernel/gentoo-sources-4.5.3
sys-kernel/linux-firmware-20160331
sys-kernel/linux-headers-4.5
sys-power/acpid-2.0.23
sys-power/iasl-20140828
sys-power/pm-quirks-20100619
sys-power/pm-utils-1.4.1-r6
sys-power/upower-0.99.4
x11-base/xorg-drivers-1.18-r1
x11-base/xorg-server-1.18.3
x11-base/xorg-x11-7.4-r2
x11-drivers/xf86-video-ati-7.7.0
xfce-extra/xfce4-power-manager-1.5.2


Last edited by ronnem on Wed May 18, 2016 6:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
ronnem
n00b
n00b


Joined: 17 Apr 2016
Posts: 12

PostPosted: Wed May 18, 2016 6:27 pm    Post subject: Reply with quote

fixed by changing two kernel options:
CONFIG_DRM_TTM=y
CONFIG_DRM_RADEON=y
to
CONFIG_DRM_TTM=m
CONFIG_DRM_RADEON=m

Now there is no errors. Hibernation is working, but suspend isn't.
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Fri May 20, 2016 10:52 am    Post subject: Reply with quote

Moved from Installing Gentoo to Kernel & Hardware.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum