Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] nvidia-drivers-340.96-r5 fails under kernel 4.6.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 557
Location: USA

PostPosted: Thu May 19, 2016 8:26 pm    Post subject: [SOLVED] nvidia-drivers-340.96-r5 fails under kernel 4.6.0 Reply with quote

Here is emerge --info '=x11-drivers/nvidia-drivers-340.96-r5::gentoo', the complete build log, and
Code:
$ emerge -pqv '=x11-drivers/nvidia-drivers-340.96-r5::gentoo'
[ebuild   R   ] x11-drivers/nvidia-drivers-340.96-r5  USE="X acpi multilib tools uvm -pax_kernel -static-libs"

Any debugging hints and/or patches for this version of nvidia-drivers under kernel 4.6.0 will be gratefully received.

[SOLVED] Using both patches from this forum post it emerged without error. [/SOLVED]


Last edited by cfgauss on Thu May 26, 2016 9:20 pm; edited 2 times in total
Back to top
View user's profile Send private message
djdunn
l33t
l33t


Joined: 26 Dec 2004
Posts: 780
Location: Arrakis

PostPosted: Thu May 26, 2016 7:44 am    Post subject: Reply with quote

You have to use newer drivers version 3.67.18, if that driver does not work then you have 3 choices

1) use nouveau
2) find a 4.6 patch and patch it yourself
3) wait for nvidia to release new drivers
_________________
A process cannot be understood by stopping it. Understanding must move with the flow of the process, must join it and flow with it.

-The First Law of Mentat
Back to top
View user's profile Send private message
fhede
n00b
n00b


Joined: 15 Mar 2016
Posts: 43

PostPosted: Thu May 26, 2016 12:23 pm    Post subject: Reply with quote

If you go for latest nvidia-drivers 367.18 you dont need any patches. Build fine here without.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum