Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HPLIP suddenly stopped working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Thu May 19, 2016 10:05 pm    Post subject: HPLIP suddenly stopped working Reply with quote

I'm using net-print/hplip with a HP LaserJet Pro MFP M125nw. This has worked reasonably well in the past, until it suddenly stopped working.

After a world emerge or two, the device stopped accepting jobs. I eventually unmerged hplip and then emerged it again. When adding this printer, the utility (hplip) needs to install a proprietary driver. It offers to do this by downloading it. This seemed to proceed fine, however, it resulted in some weird error I forgot to note down in the final stage of adding the device.

I retried, unmerge and emerge. This time, it did NOT offer me to download the proprietary driver, but demanded I manually install a PPD to provide it. As it happens, hplip has a USE flag "static-ppds", which installs some additional PPDs, and my printer is among those.

I tried both:

hp-laserjet_pro_mfp_m125nw-hpijs.ppd.gz
hp-laserjet_pro_mfp_m125nw.ppd.gz

However, both fail with the obscure error:

Code:

Printer queue setup failed.
Error : successful-ok-ignored-or-substituted-attributes


And the printer does not get added.

There is also this package: net-print/hplip-plugin, I tried to emerge this as well, even though it has not been required before. The result was the same.

This is with version 3.16.3 of HPLIP.

I have another computer, which also has version 3.16.3 of HPLIP, and this computer can use the printer with no issues. I manually compared the USE flags and couldn't find any differences. The static-ppds flag is not required on the other computer. Both run Gentoo stable.

What could the reason for this be? Why does not the utility offer to download and install the driver more than once? How can I get it to ask for that again? Or in short, how can I resolve this issue?
Back to top
View user's profile Send private message
derk
Guru
Guru


Joined: 10 Mar 2003
Posts: 347
Location: St Thomas Ontario

PostPosted: Thu May 19, 2016 11:00 pm    Post subject: Reply with quote

you'll have to examine your emerge history for some clues .. qlop -ul or genlop -ul will help there ..

also have you recently changed gcc versions .. maybe due to a library mismatch .. recent gcc's are not always binary/abi compatible particularly c++ based programs ..

just a few clues to assist your digging

also check any log files available


you might also wish to look at the cups and hplip config files in /etc and see what is there that is different between your machines
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum