Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fetch failed for 'sys-kernel/gentoo-sources-4.5.0' - 404 Err
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
DangerLifter
n00b
n00b


Joined: 20 May 2016
Posts: 5

PostPosted: Fri May 20, 2016 3:16 am    Post subject: Fetch failed for 'sys-kernel/gentoo-sources-4.5.0' - 404 Err Reply with quote

Hi. I am new in gentoo. Such happened I need replace CentoOS with gentoo, based on very shallow instructions from previous dev. Now I have below issue. All advices would be great.

Code:
 
 emerge --sync
>>> Syncing repository 'gentoo' into '/usr/portage'...
>>> Starting rsync with rsync://62.210.250.216/gentoo-portage...
receiving incremental file list
timestamp.chk

Number of files: 1 (reg: 1)
Number of created files: 0
Number of deleted files: 0
Number of regular files transferred: 1
Total file size: 32 bytes
Total transferred file size: 32 bytes
Literal data: 32 bytes
Matched data: 0 bytes
File list size: 41
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 104
Total bytes received: 127

sent 104 bytes  received 127 bytes  462.00 bytes/sec
total size is 32  speedup is 0.14
receiving incremental file list
metadata/timestamp.chk

Number of files: 208,279 (reg: 181,068, dir: 27,211)
Number of created files: 1 (reg: 1)
Number of deleted files: 0
Number of regular files transferred: 1
Total file size: 410.33M bytes
Total transferred file size: 32 bytes
Literal data: 32 bytes
Matched data: 0 bytes
File list size: 2.92M
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 28.96K
Total bytes received: 5.28M

sent 28.96K bytes  received 5.28M bytes  624.29K bytes/sec
total size is 410.33M  speedup is 77.33
=== Sync completed for gentoo

 * IMPORTANT: 17 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

emerge -av gentoo-sources

 * IMPORTANT: 17 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

 * Last emerge --sync was 63d 16h 28m 11s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-kernel/gentoo-sources-4.5.0:4.5.0::gentoo  USE="-build -experimental -kdbus -symlink" 19 KiB

Total: 1 package (1 new), Size of downloads: 19 KiB

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-kernel/gentoo-sources-4.5.0::gentoo
 * linux-4.5.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                                                                [ ok ]
>>> Downloading 'http://distfiles.gentoo.org/distfiles/genpatches-4.5-1.base.tar.xz'
--2016-05-20 03:08:38--  http://distfiles.gentoo.org/distfiles/genpatches-4.5-1.base.tar.xz
Resolving distfiles.gentoo.org... 64.50.236.52, 64.50.233.100, 137.226.34.46, ...
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-05-20 03:08:39 ERROR 404: Not Found.

>>> Downloading 'http://gentoo.ussg.indiana.edu/distfiles/genpatches-4.5-1.base.tar.xz'
--2016-05-20 03:08:39--  http://gentoo.ussg.indiana.edu/distfiles/genpatches-4.5-1.base.tar.xz
Resolving gentoo.ussg.indiana.edu... 156.56.247.195
Connecting to gentoo.ussg.indiana.edu|156.56.247.195|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-05-20 03:08:39 ERROR 404: Not Found.

>>> Downloading 'http://gentoo-distfiles.mirrors.tds.net/distfiles/genpatches-4.5-1.base.tar.xz'
--2016-05-20 03:08:39--  http://gentoo-distfiles.mirrors.tds.net/distfiles/genpatches-4.5-1.base.tar.xz
Resolving gentoo-distfiles.mirrors.tds.net... 216.165.129.135
Connecting to gentoo-distfiles.mirrors.tds.net|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-05-20 03:08:39 ERROR 404: Not Found.

>>> Downloading 'http://gentoo.osuosl.org/distfiles/genpatches-4.5-1.base.tar.xz'
--2016-05-20 03:08:39--  http://gentoo.osuosl.org/distfiles/genpatches-4.5-1.base.tar.xz
Resolving gentoo.osuosl.org... 64.50.233.100, 64.50.236.52
Connecting to gentoo.osuosl.org|64.50.233.100|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-05-20 03:08:40 ERROR 404: Not Found.

>>> Downloading 'http://ftp.halifax.rwth-aachen.de/gentoo/distfiles/genpatches-4.5-1.base.tar.xz'
--2016-05-20 03:08:40--  http://ftp.halifax.rwth-aachen.de/gentoo/distfiles/genpatches-4.5-1.base.tar.xz
Resolving ftp.halifax.rwth-aachen.de... 137.226.34.46, 2a00:8a60:e012:a00::21
Connecting to ftp.halifax.rwth-aachen.de|137.226.34.46|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-05-20 03:08:40 ERROR 404: Not Found.

!!! Couldn't download 'genpatches-4.5-1.base.tar.xz'. Aborting.
 * Fetch failed for 'sys-kernel/gentoo-sources-4.5.0', Log file:
 *  '/var/tmp/portage/sys-kernel/gentoo-sources-4.5.0/temp/build.log'

>>> Failed to emerge sys-kernel/gentoo-sources-4.5.0, Log file:

>>>  '/var/tmp/portage/sys-kernel/gentoo-sources-4.5.0/temp/build.log'

 * Messages for package sys-kernel/gentoo-sources-4.5.0:

 * Fetch failed for 'sys-kernel/gentoo-sources-4.5.0', Log file:
 *  '/var/tmp/portage/sys-kernel/gentoo-sources-4.5.0/temp/build.log'
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Fri May 20, 2016 7:45 am    Post subject: Reply with quote

Code:
 * Last emerge --sync was 63d 16h 28m 11s ago.

Something is wrong here. I'd try syncing with some other server, gentoo-sources-4.5.0 is not in portage any more.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2614

PostPosted: Fri May 20, 2016 10:07 am    Post subject: Reply with quote

Buffoon wrote:
Code:
 * Last emerge --sync was 63d 16h 28m 11s ago.

Something is wrong here. I'd try syncing with some other server, gentoo-sources-4.5.0 is not in portage any more.
See https://gitweb.gentoo.org/repo/gentoo.git/commit/sys-kernel/gentoo-sources?id=63a6f4f363dbf816f66bd3ddd7900befb6898731 and use 4.5.0-r1 instead.
Back to top
View user's profile Send private message
DangerLifter
n00b
n00b


Joined: 20 May 2016
Posts: 5

PostPosted: Fri May 20, 2016 5:49 pm    Post subject: Reply with quote

Ok. I just started from scratch.
used http://distfiles.gentoo.org/releases/amd64/autobuilds/20160519/hardened/stage3-amd64-hardened-20160519.tar.bz2
and http://distfiles.gentoo.org/snapshots/portage-latest.tar.bz2
And now I have stable issue. It happens not for all packages but for some

Code:

emerge app-misc/screen

 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) app-misc/screen-4.3.1-r1::gentoo
>>> Downloading 'http://distfiles.gentoo.org/distfiles/screen-4.3.1.tar.gz'
--2016-05-20 17:41:27--  http://distfiles.gentoo.org/distfiles/screen-4.3.1.tar.gz
Resolving distfiles.gentoo.org... 140.211.166.134, 156.56.247.195, 137.226.34.46, ...
Connecting to distfiles.gentoo.org|140.211.166.134|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 845958 (826K) [application/x-gzip]
Saving to: ‘/usr/portage/distfiles/screen-4.3.1.tar.gz’

/usr/portage/distfi 100%[=====================>] 826.13K  1.04MB/s   in 0.8s   

2016-05-20 17:41:28 (1.04 MB/s) - ‘/usr/portage/distfiles/screen-4.3.1.tar.gz’ saved [845958/845958]

 * screen-4.3.1.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                                                             [ ok ]
>>> Unpacking source...
>>> Unpacking screen-4.3.1.tar.gz to /var/tmp/portage/app-misc/screen-4.3.1-r1/work
>>> Source unpacked in /var/tmp/portage/app-misc/screen-4.3.1-r1/work
>>> Preparing source in /var/tmp/portage/app-misc/screen-4.3.1-r1/work/screen-4.3.1 ...
 * Applying screen-4.3.0-no-utempter.patch ...                                                                                                                                                                                                                          [ ok ]
 * Applying screen-4.3.1-ansi.c.patch ...                                                                                                                                                                                                                               [ ok ]
 * Running eautoreconf in '/var/tmp/portage/app-misc/screen-4.3.1-r1/work/screen-4.3.1' ...
 * Running aclocal ...                                                                                                                                                                                                                                                  [ !! ]

 * Failed Running aclocal !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/app-misc/screen-4.3.1-r1/temp/aclocal.out

 * ERROR: app-misc/screen-4.3.1-r1::gentoo failed (prepare phase):
 *   Failed Running aclocal !
 *
 * Call stack:
 *     ebuild.sh, line  133:  Called src_prepare
 *   environment, line 3550:  Called eautoreconf
 *   environment, line 1034:  Called eaclocal
 *   environment, line  929:  Called autotools_run_tool '--at-m4flags' 'aclocal'
 *   environment, line  759:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of `emerge --info '=app-misc/screen-4.3.1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-misc/screen-4.3.1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-misc/screen-4.3.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-misc/screen-4.3.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/app-misc/screen-4.3.1-r1/work/screen-4.3.1'
 * S: '/var/tmp/portage/app-misc/screen-4.3.1-r1/work/screen-4.3.1'

>>> Failed to emerge app-misc/screen-4.3.1-r1, Log file:

>>>  '/var/tmp/portage/app-misc/screen-4.3.1-r1/temp/build.log'

 * Messages for package app-misc/screen-4.3.1-r1:

 * Failed Running aclocal !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/app-misc/screen-4.3.1-r1/temp/aclocal.out
 * ERROR: app-misc/screen-4.3.1-r1::gentoo failed (prepare phase):
 *   Failed Running aclocal !
 *
 * Call stack:
 *     ebuild.sh, line  133:  Called src_prepare
 *   environment, line 3550:  Called eautoreconf
 *   environment, line 1034:  Called eaclocal
 *   environment, line  929:  Called autotools_run_tool '--at-m4flags' 'aclocal'
 *   environment, line  759:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of `emerge --info '=app-misc/screen-4.3.1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-misc/screen-4.3.1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-misc/screen-4.3.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-misc/screen-4.3.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/app-misc/screen-4.3.1-r1/work/screen-4.3.1'
 * S: '/var/tmp/portage/app-misc/screen-4.3.1-r1/work/screen-4.3.1'
localhost ~ # cat /var/tmp/portage/app-misc/screen-4.3.1-r1/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/app-misc/screen-4.3.1-r1/work/screen-4.3.1
***** aclocal

/usr/lib/portage/python2.7/ebuild.sh: line 535:  7624 Segmentation fault      /usr/bin/aclocal "$@"


Code:

cat /var/tmp/portage/app-misc/screen-4.3.1-r1/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/app-misc/screen-4.3.1-r1/work/screen-4.3.1
***** aclocal

/usr/lib/portage/python2.7/ebuild.sh: line 535:  7624 Segmentation fault      /usr/bin/aclocal "$@"


Code:

emerge --info '=app-misc/screen-4.3.1-r1::gentoo'
Portage 2.2.28 (python 2.7.10-final-0, hardened/linux/amd64, gcc-4.9.3-vanilla, glibc-2.22-r4, 3.10.0-327.18.2.el7.x86_64 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.10.0-327.18.2.el7.x86_64-x86_64-Intel-R-_Atom-TM-_CPU_C2750_@_2.40GHz-with-centos-7.2.1511-Core
KiB Mem:     7997472 total,   6184552 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of repository gentoo: Fri, 20 May 2016 17:30:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bindist bzip2 cli cracklib crypt cxx dri gdbm hardened iconv ipv6 justify mmx mmxext modules multilib ncurses nls nptl openmp pam pax_kernel pcre pie readline seccomp session sse sse2 ssl ssp tcpd unicode urandom xattr xtpax zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


PS: I have been fighting with gentoo installation for 2 days already. It feels like a hell. Different issues and errors again and again. Do I ask too much from gentoo - just simple working system?!


To be clear. I do install gentoo over the centos 7.2. Here it is exact steps that lead me to final error above:
Code:


mkdir /root/old
cp -R  /etc /root/old/etc
cp -R  /var /root/old/var
cp -R  /usr /root/old/usr
cp -R  /lib /root/old/lib

mv /sbin/modprobe /sbin/.modprobe
find / -print0 | xargs -0 touch -d "1970-01-01 00:00 +0000" -m
mv /sbin/.modprobe /sbin/modprobe

cd /root

wget http://distfiles.gentoo.org/releases/amd64/autobuilds/20160519/hardened/stage3-amd64-hardened-20160519.tar.bz2
tar xfvjp stage* -C /

mv /lib /lib_ && ln -s /lib64 /lib
mv /usr/lib /usr/lib_ && ln -s /usr/lib64 /usr/lib

cp /root/old/etc/fstab /etc/fstab

passwd

wget http://distfiles.gentoo.org/snapshots/portage-latest.tar.bz2
tar xfvjp portage* -C /usr/

emerge --sync
emerge sys-apps/baselayout

source /etc/profile
export LANG=C

ln -s /etc/init.d/net.lo /etc/init.d/net.eno1
ln -s /etc/init.d/net.lo /etc/init.d/net.eno2
rc-update add net.eno1 boot
rc-update add net.eno2 boot

ln -s /etc/init.d/net.lo /etc/init.d/net.eth0
ln -s /etc/init.d/net.lo /etc/init.d/net.eth1
rc-update add net.eth0 boot
rc-update add net.eth1 boot

emerge dhcpcd

echo "domain XXXXXXXX
nameserver XXXXXXXX
nameserver 8.8.8.8
" > /etc/resolv.conf


nano /etc/ssh/sshd_config
#To enable root login, fix in /etc/ssh/sshd_config
#PermitRootLogin yes
#PasswordAuthentication yes

#find  /etc/ssh/ -name 'ssh_host_*' -print0 | xargs -0 chmod 600  - doest not work properly. fix it.
chmod 600 /etc/ssh/ssh_host_rsa_key
chown root:root /etc/ssh/ssh_host_rsa_key
chmod 600 /etc/ssh/ssh_host_ecdsa_key
chown root:root /etc/ssh/ssh_host_ecdsa_key
chmod 600 /etc/ssh/ssh_host_ed25519_key
chown root:root /etc/ssh/ssh_host_ed25519_key
chmod 644 /etc/ssh/sshd_config

rc-update add sshd boot

cp /root/old/etc/hosts /etc/hosts

nano /etc/hosts
# add into /etc/hosts 127.0.0.1 XXXXX XXXXXXX

ln -s /dev/null /etc/udev/rules.d/80-net-name-slot.rules

# reboot andcheck that everything works if ok than delete old
rm -rf /lib_ /usr/lib_
find /bin /sbin /etc /lib /usr /var -newermt "1970-01-01" ! -newermt "1970-01-02" -print0 | xargs -0 rm -rf

emerge-webrsync
emerge --sync
emerge gentoo-sources
emerge app-misc/screen


Everything is based on few articles though Internet. I will be much appreciated any help. Thank you.
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Fri May 20, 2016 7:19 pm    Post subject: Reply with quote

DangerLifter wrote:
To be clear. I do install gentoo over the centos 7.2. Here it is exact steps that lead me to final error above:


Are you installing Gentoo from a CentOS LiveCD or are you doing it over a current CentOS install in your machine?
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Fri May 20, 2016 7:25 pm    Post subject: Reply with quote

aclocal is part of sys-devel/automake. You may want to try re-emerging it.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5761

PostPosted: Fri May 20, 2016 7:36 pm    Post subject: Reply with quote

...why are you adding two udev-named network interfaces and two kernel-named ones to the boot runlevel, and then directly going out of your way to ensure at least half of them will never exist?
Back to top
View user's profile Send private message
DangerLifter
n00b
n00b


Joined: 20 May 2016
Posts: 5

PostPosted: Sat May 21, 2016 1:55 am    Post subject: Reply with quote

Quote:
why are you adding two udev-named network interfaces and two kernel-named ones to the boot runlevel, and then directly going out of your way to ensure at least half of them will never exist?

As I wrote I am new at this .On practice with this approach at least I get stable working network interfaces after overwrite centos and reboot. Have a plan to play with it more and clear but asap as I fix more important issues and will see light at the end of tunnel.

Yep. I do installation over current CentOS.
Code:

emerge sys-devel/automake

 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-devel/automake-1.15::gentoo
>>> Downloading 'http://distfiles.gentoo.org/distfiles/automake-1.15.tar.xz'
--2016-05-21 01:49:49--  http://distfiles.gentoo.org/distfiles/automake-1.15.tar.xz
Resolving distfiles.gentoo.org... 216.165.129.135, 64.50.233.100, 64.50.236.52, ...
Connecting to distfiles.gentoo.org|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1496708 (1.4M) [application/x-tar]
Saving to: ‘/usr/portage/distfiles/automake-1.15.tar.xz’

/usr/portage/distfi 100%[=====================>]   1.43M   652KB/s   in 2.2s   

2016-05-21 01:49:52 (652 KB/s) - ‘/usr/portage/distfiles/automake-1.15.tar.xz’ saved [1496708/1496708]

 * automake-1.15.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                                                            [ ok ]
>>> Unpacking source...
>>> Unpacking automake-1.15.tar.xz to /var/tmp/portage/sys-devel/automake-1.15/work
>>> Source unpacked in /var/tmp/portage/sys-devel/automake-1.15/work
>>> Preparing source in /var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15 ...
 * econf: updating automake-1.15/lib/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating automake-1.15/lib/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-silent-rules --libdir=/usr/lib64 --docdir=$(datarootdir)/doc/automake-1.15
checking whether make supports nested variables... yes
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking for a BSD-compatible install... /usr/lib/portage/python2.7/ebuild-helpers/xattr/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether ln -s works... yes
checking for perl... /usr/bin/perl
checking for tex... no
checking for yacc... yacc
checking for lex... lex
checking whether autoconf is installed... yes
checking whether autoconf works... no
configure: error: The installed version of autoconf does not work.
    Please check config.log for error messages before this one.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15/config.log
 * ERROR: sys-devel/automake-1.15::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  133:  Called src_configure
 *             environment, line 2060:  Called econf '--docdir=$(datarootdir)/doc/automake-1.15'
 *        phase-helpers.sh, line  662:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=sys-devel/automake-1.15::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/automake-1.15::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-devel/automake-1.15/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/automake-1.15/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15'
 * S: '/var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15'

>>> Failed to emerge sys-devel/automake-1.15, Log file:

>>>  '/var/tmp/portage/sys-devel/automake-1.15/temp/build.log'

 * Messages for package sys-devel/automake-1.15:

 * ERROR: sys-devel/automake-1.15::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  133:  Called src_configure
 *             environment, line 2060:  Called econf '--docdir=$(datarootdir)/doc/automake-1.15'
 *        phase-helpers.sh, line  662:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=sys-devel/automake-1.15::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/automake-1.15::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-devel/automake-1.15/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/automake-1.15/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15'
 * S: '/var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15'


Code:
cat /var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15/config.log
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by GNU Automake configure 1.15, which was
generated by GNU Autoconf 2.69.  Invocation command line was

  $ ./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-silent-rules --libdir=/usr/lib64 --docdir=$(datarootdir)/doc/automake-1.15

## --------- ##
## Platform. ##
## --------- ##

hostname = localhost
uname -m = x86_64
uname -r = 3.10.0-327.18.2.el7.x86_64
uname -s = Linux
uname -v = #1 SMP Thu May 12 11:03:55 UTC 2016

/usr/bin/uname -p = Intel(R) Atom(TM) CPU C2750 @ 2.40GHz
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/lib/portage/python2.7/ebuild-helpers/xattr
PATH: /usr/lib/portage/python2.7/ebuild-helpers
PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /opt/bin
PATH: /usr/x86_64-pc-linux-gnu/gcc-bin/4.9.3


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2031: checking whether make supports nested variables
configure:2048: result: yes
configure:2064: checking build system type
configure:2078: result: x86_64-pc-linux-gnu
configure:2098: checking host system type
configure:2111: result: x86_64-pc-linux-gnu
configure:2164: checking for a BSD-compatible install
configure:2232: result: /usr/lib/portage/python2.7/ebuild-helpers/xattr/install -c
configure:2243: checking whether build environment is sane
configure:2298: result: yes
configure:2449: checking for a thread-safe mkdir -p
configure:2488: result: /usr/bin/mkdir -p
configure:2495: checking for gawk
configure:2511: found /usr/bin/gawk
configure:2522: result: gawk
configure:2533: checking whether make sets $(MAKE)
configure:2555: result: yes
configure:2713: checking whether ln -s works
configure:2717: result: yes
configure:2727: checking for perl
configure:2745: found /usr/bin/perl
configure:2757: result: /usr/bin/perl
configure:2769: /usr/bin/perl --version

This is perl 5, version 20, subversion 2 (v5.20.2) built for x86_64-linux
(with 27 registered patches, see perl -V for more detail)

Copyright 1987-2015, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.

configure:2772: $? = 0
configure:2784: checking for tex
configure:2814: result: no
configure:2822:  --version </dev/null
./configure: line 2823: --version: command not found
configure:2825: $? = 127
configure:2843: checking for yacc
configure:2859: found /usr/bin/yacc
configure:2870: result: yacc
configure:2886: checking for lex
configure:2902: found /usr/bin/lex
configure:2913: result: lex
configure:2934: checking whether autoconf is installed
configure:2939: autoconf --version
autoconf (GNU Autoconf) 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+/Autoconf: GNU GPL version 3 or later
<http://gnu.org/licenses/gpl.html>, <http://gnu.org/licenses/exceptions.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by David J. MacKenzie and Akim Demaille.
configure:2942: $? = 0
configure:2950: result: yes
configure:2957: checking whether autoconf works
configure:2964: cd conftest && autoconf -o /dev/null conftest.ac
./configure: line 2975: 11341 Segmentation fault      $am_AUTOCONF -o /dev/null conftest.ac
configure:2967: $? = 139
configure:2976: result: no
configure:2979: error: The installed version of autoconf does not work.
    Please check config.log for error messages before this one.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=x86_64-pc-linux-gnu
ac_cv_env_AM_TEST_RUNNER_SHELL_set=
ac_cv_env_AM_TEST_RUNNER_SHELL_value=
ac_cv_env_CCC_set=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-O2 -pipe'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CXXFLAGS_set=set
ac_cv_env_CXXFLAGS_value='-O2 -pipe'
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_F77_set=
ac_cv_env_F77_value=
ac_cv_env_FCFLAGS_set=set
ac_cv_env_FCFLAGS_value='-O2 -pipe'
ac_cv_env_FC_set=
ac_cv_env_FC_value=
ac_cv_env_FFLAGS_set=set
ac_cv_env_FFLAGS_value='-O2 -pipe'
ac_cv_env_GNU_CC_set=
ac_cv_env_GNU_CC_value=
ac_cv_env_GNU_CFLAGS_set=
ac_cv_env_GNU_CFLAGS_value=
ac_cv_env_GNU_CXXFLAGS_set=
ac_cv_env_GNU_CXXFLAGS_value=
ac_cv_env_GNU_CXX_set=
ac_cv_env_GNU_CXX_value=
ac_cv_env_GNU_F77_set=
ac_cv_env_GNU_F77_value=
ac_cv_env_GNU_FCFLAGS_set=
ac_cv_env_GNU_FCFLAGS_value=
ac_cv_env_GNU_FC_set=
ac_cv_env_GNU_FC_value=
ac_cv_env_GNU_FFLAGS_set=
ac_cv_env_GNU_FFLAGS_value=
ac_cv_env_GNU_GCJFLAGS_set=
ac_cv_env_GNU_GCJFLAGS_value=
ac_cv_env_GNU_GCJ_set=
ac_cv_env_GNU_GCJ_value=
ac_cv_env_LDFLAGS_set=set
ac_cv_env_LDFLAGS_value='-Wl,-O1 -Wl,--as-needed'
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=set
ac_cv_env_build_alias_value=x86_64-pc-linux-gnu
ac_cv_env_host_alias_set=set
ac_cv_env_host_alias_value=x86_64-pc-linux-gnu
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=x86_64-pc-linux-gnu
ac_cv_path_PERL=/usr/bin/perl
ac_cv_path_install='/usr/lib/portage/python2.7/ebuild-helpers/xattr/install -c'
ac_cv_path_mkdir=/usr/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_LEX=lex
ac_cv_prog_YACC=yacc
ac_cv_prog_make_make_set=yes
am_cv_autoconf_installed=yes
am_cv_autoconf_works=no
am_cv_make_support_nested_variables=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='"/var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15/t/wrap/aclocal-1.15"'
AMTAR='$${TAR-tar}'
AM_BACKSLASH='\'
AM_DEFAULT_V='$(AM_DEFAULT_VERBOSITY)'
AM_DEFAULT_VERBOSITY='1'
AM_TEST_RUNNER_SHELL=''
AM_V='$(V)'
APIVERSION='1.15'
AUTOCONF='${SHELL} /var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15/lib/missing autoconf'
AUTOHEADER='${SHELL} /var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15/lib/missing autoheader'
AUTOMAKE='"/var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15/t/wrap/automake-1.15"'
AWK='gawk'
CC=''
CFLAGS='-O2 -pipe'
CPPFLAGS=''
CXX=''
CXXFLAGS='-O2 -pipe'
CYGPATH_W='echo'
DEFS=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
F77=''
FC=''
FCFLAGS='-O2 -pipe'
FFLAGS='-O2 -pipe'
FGREP=''
GNU_CC=''
GNU_CFLAGS=''
GNU_CXX=''
GNU_CXXFLAGS=''
GNU_F77=''
GNU_FC=''
GNU_FCFLAGS=''
GNU_FFLAGS=''
GNU_GCJ=''
GNU_GCJFLAGS=''
GREP=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
LDFLAGS='-Wl,-O1 -Wl,--as-needed'
LEX='lex'
LIBOBJS=''
LIBS=''
LN=''
LN_S='ln -s'
LTLIBOBJS=''
MAKEINFO='${SHELL} /var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15/lib/missing makeinfo'
MKDIR_P='/usr/bin/mkdir -p'
MODIFICATION_DELAY=''
OBJEXT=''
PACKAGE='automake'
PACKAGE_BUGREPORT='bug-automake@gnu.org'
PACKAGE_NAME='GNU Automake'
PACKAGE_STRING='GNU Automake 1.15'
PACKAGE_TARNAME='automake'
PACKAGE_URL='http://www.gnu.org/software/automake/'
PACKAGE_VERSION='1.15'
PATH_SEPARATOR=':'
PERL='/usr/bin/perl'
RELEASE_YEAR='2014'
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
TEX=''
VERSION='1.15'
YACC='yacc'
ac_ct_CC=''
ac_ct_CXX=''
ac_ct_F77=''
ac_ct_FC=''
ac_ct_GNU_CC=''
ac_ct_GNU_CXX=''
ac_ct_GNU_F77=''
ac_ct_GNU_FC=''
ac_ct_GNU_GCJ=''
am_AUTOCONF='autoconf'
am_AUTOHEADER='autoheader'
am_AUTOM4TE='autom4te'
am_AUTORECONF='autoreconf'
am_AUTOUPDATE='autoupdate'
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE=''
am__isrc=''
am__leading_dot='.'
am__tar='$${TAR-tar} chof - "$$tardir"'
am__untar='$${TAR-tar} xf -'
am_candidate_sh=''
amdir='${pkgvdatadir}/am'
automake_acdir='${datadir}/aclocal-1.15'
bindir='${exec_prefix}/bin'
build='x86_64-pc-linux-gnu'
build_alias='x86_64-pc-linux-gnu'
build_cpu='x86_64'
build_os='linux-gnu'
build_vendor='pc'
datadir='/usr/share'
datarootdir='${prefix}/share'
docdir='$(datarootdir)/doc/automake-1.15'
dvidir='${docdir}'
exec_prefix='NONE'
host='x86_64-pc-linux-gnu'
host_alias='x86_64-pc-linux-gnu'
host_cpu='x86_64'
host_os='linux-gnu'
host_vendor='pc'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='/usr/share/info'
install_sh='${SHELL} /var/tmp/portage/sys-devel/automake-1.15/work/automake-1.15/lib/install-sh'
libdir='/usr/lib64'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='/var/lib'
mandir='/usr/share/man'
mkdir_p='$(MKDIR_P)'
oldincludedir='/usr/include'
pdfdir='${docdir}'
pkgvdatadir='${datadir}/automake-1.15'
prefix='/usr'
program_transform_name='s,x,x,'
psdir='${docdir}'
required_autoconf_version='2.65'
sbindir='${exec_prefix}/sbin'
scriptdir='${pkgvdatadir}'
sharedstatedir='${prefix}/com'
sysconfdir='/etc'
system_acdir='${datadir}/aclocal'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME "GNU Automake"
#define PACKAGE_TARNAME "automake"
#define PACKAGE_VERSION "1.15"
#define PACKAGE_STRING "GNU Automake 1.15"
#define PACKAGE_BUGREPORT "bug-automake@gnu.org"
#define PACKAGE_URL "http://www.gnu.org/software/automake/"

configure: exit 1
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Sat May 21, 2016 12:19 pm    Post subject: Reply with quote

I would not recommend installing over a current install of another distribution (or even Gentoo!). Download a live cd or usb of Gentoo or another distribution, boot on it, then format your former CentOS partition and start from scratch following the handbook.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
DangerLifter
n00b
n00b


Joined: 20 May 2016
Posts: 5

PostPosted: Sat May 21, 2016 12:40 pm    Post subject: Reply with quote

I understand that it is not best way. But there is no possibility to use gentoo ISO for now.
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Sun May 22, 2016 12:51 pm    Post subject: Reply with quote

DangerLifter wrote:
I understand that it is not best way. But there is no possibility to use gentoo ISO for now.


Any not-so-ancient Linux live should do as long as it is the same 32/64 bits that you will install and that provides chroot.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
DangerLifter
n00b
n00b


Joined: 20 May 2016
Posts: 5

PostPosted: Sun May 22, 2016 9:44 pm    Post subject: Reply with quote

[quote="pilla"]
DangerLifter wrote:
I understand that it is not best way. But there is no possibility to use gentoo ISO for now.


Any not-so-ancient Linux live should do as long as it is the same 32/64 bits that you will install and that provides chroot.[/quote

Oh. I see what you mean. I should think about this yearly. Will try this way and hope will get success.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum