Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
CPU frequency doesn't auto-change
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
petan
n00b
n00b


Joined: 18 Jan 2016
Posts: 55

PostPosted: Tue May 31, 2016 10:13 am    Post subject: CPU frequency doesn't auto-change Reply with quote

Hi,

I have a serious issue with CPU on DELL E5550

Whenever I boot up the system while not plugged in, the kernel switches the frequency to 500MHZ:

Code:
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 61
Model name:            Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz
Stepping:              4
CPU MHz:               500.000
CPU max MHz:           2601.0000
CPU min MHz:           500.0000
BogoMIPS:              5188.38
Virtualization:        VT-x
NUMA node0 CPU(s):     0-3


When I boot up while plugged to wall socket, the frequency is 2600MHZ

Changing power while system is running has no effect and there seem to be no way to manually override this. That means always when I detect that laptop is in "power saving" mode, I have reboot while plugged in, otherwise it's terribly slow. Is there a way to make this work automatically? Or adjust the frequency by hand? Or basically, just disable power saving so that it's always max? I would rather have battery that doesn't last very long, than perma-slow laptop.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue May 31, 2016 10:48 am    Post subject: Re: CPU frequency doesn't auto-change Reply with quote

petan wrote:
Changing power while system is running has no effect and there seem to be no way to manually override this. That means always when I detect that laptop is in "power saving" mode, I have reboot while plugged in, otherwise it's terribly slow. Is there a way to make this work automatically? Or adjust the frequency by hand? Or basically, just disable power saving so that it's always max? I would rather have battery that doesn't last very long, than perma-slow laptop.

petan ... you perhaps have CPU_FREQ_GOV_POWERSAVE as the DEFAULT_GOV ... 'grep CPU_FREQ /usr/src/linux/.config' will give some idea.

The method of setting/changing cpu_freq is via sys-power/cpupower, so for example to set the governer to 'performance' (assuming its enabled in the kernel).

Code:
# cpupower -c all frequency-set -g performance

... or you can define the governer and parameters via /etc/conf.d/cpupower, or tie this in with acpid (so setting based on 'ac_adapter')

Also note that if you set 'ondemand' as the default govener the cpu will scale up/down dependent on the activity. This might providing the powersaving but still adjust cpu speed when needed.

best ... khay
Back to top
View user's profile Send private message
petan
n00b
n00b


Joined: 18 Jan 2016
Posts: 55

PostPosted: Wed Jun 01, 2016 12:21 pm    Post subject: Re: CPU frequency doesn't auto-change Reply with quote

khayyam wrote:
petan wrote:
Changing power while system is running has no effect and there seem to be no way to manually override this. That means always when I detect that laptop is in "power saving" mode, I have reboot while plugged in, otherwise it's terribly slow. Is there a way to make this work automatically? Or adjust the frequency by hand? Or basically, just disable power saving so that it's always max? I would rather have battery that doesn't last very long, than perma-slow laptop.

petan ... you perhaps have CPU_FREQ_GOV_POWERSAVE as the DEFAULT_GOV ... 'grep CPU_FREQ /usr/src/linux/.config' will give some idea.

The method of setting/changing cpu_freq is via sys-power/cpupower, so for example to set the governer to 'performance' (assuming its enabled in the kernel).

Code:
# cpupower -c all frequency-set -g performance

... or you can define the governer and parameters via /etc/conf.d/cpupower, or tie this in with acpid (so setting based on 'ac_adapter')

Also note that if you set 'ondemand' as the default govener the cpu will scale up/down dependent on the activity. This might providing the powersaving but still adjust cpu speed when needed.

best ... khay


Seems it's "performance" that I have by default

Code:
petanb@localhost ~ $ grep CPU_FREQ /usr/src/linux/.config
CONFIG_ACPI_CPU_FREQ_PSS=y
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_GOV_COMMON=y
# CONFIG_CPU_FREQ_STAT is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Wed Jun 01, 2016 8:36 pm    Post subject: Re: CPU frequency doesn't auto-change Reply with quote

petan wrote:
Seems it's "performance" that I have by default

petan ... in which case I can't explain why it is scaled to 500Mhz, do you perhaps have laptop-mode-tools installed/enabled?

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum