Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
one of my raid 1 arrays does sporadically not mount at boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
chrisk2305
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2007
Posts: 88

PostPosted: Sun Jun 05, 2016 2:55 pm    Post subject: one of my raid 1 arrays does sporadically not mount at boot Reply with quote

Hi Guys,

I have this strange isse that one of my raid 1 arrays does sporadically not mount at startup or sometimes it mounts and gets unmounted automatically (due to error according to systemd - but it does not state what kind of error.

All three array reside on the same two SSDs.

Code:

cat /proc/mdstat
Personalities : [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md126 : active raid1 sdk1[1] sdj1[0]
      131008 blocks [2/2] [UU]

md125 : active raid1 sdk3[1] sdj3[0]
      56386368 blocks [2/2] [UU]

md0 : active raid1 sdj4[1] sdk4[0]
      117144576 blocks super 1.2 [2/2] [UU]
      bitmap: 1/1 pages [4KB], 65536KB chunk

unused devices: <none>


md0 is the problematic one. the other two are boot and /root and they work fine though.

Some output of journalctl:

Code:

journalctl -b | grep md0
Journal file /var/log/journal/0aa988faa84d5db4360967a600004444/user-65534@00052ed148bf3e18-b9fced704e58c89f.journal~ is truncated, ignoring file.
Jun 05 16:47:55 fileserver kernel: md/raid1:md0: active with 2 out of 2 mirrors
Jun 05 16:47:55 fileserver kernel: created bitmap (1 pages) for device md0
Jun 05 16:47:55 fileserver kernel: md0: bitmap initialized from disk: read 1 pages, set 0 of 1788 bits
Jun 05 16:47:55 fileserver kernel: md0: detected capacity change from 0 to 119956045824
Jun 05 16:47:56 fileserver kernel: EXT4-fs (md0): mounted filesystem with ordered data mode. Opts: commit=120
Jun 05 16:47:55 fileserver systemd[1]: Found device /dev/md0.
Jun 05 16:49:31 fileserver kernel: EXT4-fs (md0): mounted filesystem with ordered data mode. Opts: commit=120
Jun 05 16:49:31 fileserver systemd[1]: Stopped (with error) /dev/md0.


I even stopped the md0 array, zeroed superblock and recreated everything from scratch but the error persists.

Please help :) Thanks
Christian

EDIT: some more journalctl -b grepping:

Code:

Jun 05 16:47:55 fileserver systemd[1]: Mounting /mnt/VM...
Jun 05 16:47:55 fileserver systemd[1]: Mounted /mnt/VM.
Jun 05 16:48:41 fileserver systemd[1]: Unmounting /mnt/VM...
Jun 05 16:48:41 fileserver systemd[1]: Unmounted /mnt/VM.


I see no reason why the array gets unmounted after ~50 seconds.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum