Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ glsa 201606-10 ] php
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Sun Jun 19, 2016 2:26 am    Post subject: [ glsa 201606-10 ] php Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Multiple vulnerabilities (GLSA 201606-10)
Severity: normal
Exploitable: remote
Date: June 19, 2016
Bug(s): #537586, #541098, #544186, #544330, #546872, #549538, #552408, #555576, #555830, #556952, #559612, #562882, #571254, #573892, #577376
ID: 201606-10

Synopsis

Multiple vulnerabilities have been found in PHP, the worst of which
could lead to arbitrary code execution, or cause a Denial of Service
condition.


Background

PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.


Affected Packages

Package: dev-lang/php
Vulnerable: < 5.6.19
Unaffected: >= 5.6.19
Unaffected: >= 5.5.33 < 5.5.34
Unaffected: >= 5.5.34 < 5.5.35
Unaffected: >= 5.5.35 < 5.5.36
Unaffected: >= 5.5.36 < 5.5.37
Unaffected: >= 5.5.37 < 5.5.38
Unaffected: >= 5.5.38 < 5.5.39
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers referenced below for details.


Impact

An attacker can possibly execute arbitrary code or create a Denial of
Service condition.


Workaround

There is no known workaround at this time.

Resolution

All PHP 5.4 users should upgrade to the latest 5.5 stable branch, as PHP
5.4 is now masked in Portage:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev=lang/php-5.5.33"
   
All PHP 5.5 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev=lang/php-5.5.33"
   
All PHP 5.6 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev=lang/php-5.6.19"
   


References

CVE-2013-6501
CVE-2014-9705
CVE-2014-9709
CVE-2015-0231
CVE-2015-0273
CVE-2015-1351
CVE-2015-1352
CVE-2015-2301
CVE-2015-2348
CVE-2015-2783
CVE-2015-2787
CVE-2015-3329
CVE-2015-3330
CVE-2015-4021
CVE-2015-4022
CVE-2015-4025
CVE-2015-4026
CVE-2015-4147
CVE-2015-4148
CVE-2015-4642
CVE-2015-4643
CVE-2015-4644
CVE-2015-6831
CVE-2015-6832
CVE-2015-6833
CVE-2015-6834
CVE-2015-6835
CVE-2015-6836
CVE-2015-6837
CVE-2015-6838
CVE-2015-7803
CVE-2015-7804


Last edited by GLSA on Mon Jun 20, 2016 4:17 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum