Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ACPI Error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1583
Location: /mnt/Gentoo/Europe

PostPosted: Mon Jun 20, 2016 1:56 pm    Post subject: ACPI Error Reply with quote

Hi,

During the start, and later on on text console I could see such message (this is part dmesg):
Code:
[   10.095870] ACPI Error: [^^^PEG0.PEGP.DGON] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[   10.095876] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC.ADJP] (Node ffff8802270a5988), AE_NOT_FOUND (20150930/psparse-542)
[   10.095882] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC._Q1C] (Node ffff8802270a55c8), AE_NOT_FOUND (20150930/psparse-542)
or

Code:
[    6.966026] ACPI Error: [^^^PEG0.PEGP.DGON] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    6.966032] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC.ADJP] (Node ffff8802270a5988), AE_NOT_FOUND (20150930/psparse
-542)
[    6.966038] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC._Q1C] (Node ffff8802270a55c8), AE_NOT_FOUND (20150930/psparse
-542)
[    7.000703] input: Primax USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1c.1/0000:04:00.0/usb3/3-1/3-1:1.0/0003:0461:4DE3.0001/inpu
t/input18
[    7.000826] hid-generic 0003:0461:4DE3.0001: input,hidraw0: USB HID v1.11 Mouse [Primax USB OPTICAL MOUSE] on usb-0000:04:00.0-1/input
0
[    7.246142] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsa
rguments-95)
[    7.246197] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsa
rguments-95)
[    7.246231] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsa
rguments-95)
[    7.246262] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsarguments-95)
[    7.246293] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsarguments-95)
[    7.246335] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsarguments-95)
[    7.246366] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsarguments-95)
[    7.287970] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsarguments-95)


What is wrong?

I have Intel: Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz

Maybe this? I As I have ACPI Processor P-States driver instead of Intel P state. How do I know is my prcessor Sandy Brigde+?
Quote:
Do not forget to enable the CPU frequency scaling driver for the CPU. For Intel core processors, userspace, ondemand and conservative governors are unnecessary, performance should be selected as the default, and Intel P state control should be selected instead of ACPI Processor P-States driver. [1]

https://wiki.gentoo.org/wiki/Power_management/Guide

Quote:
Intel P-State driver
--------------------

This driver provides an interface to control the P-State selection for the
SandyBridge+ Intel processors.
Back to top
View user's profile Send private message
dr_wulsen
n00b
n00b


Joined: 21 Aug 2013
Posts: 71
Location: Beautiful Austria, Lake area in Upper Austria

PostPosted: Sun Jun 26, 2016 7:00 pm    Post subject: Your CPU is a SandyBridge Reply with quote

Hi there,

your CPU is a sandy bridge.

Easiest thing to get this info:
Code:
cat /proc/cpuinfo | grep -i name

It will give you the cpu model name as output, in your case it should spit out a 2450M somewhere.

Put this model name to the search at http://ark.intel.com/ and you will get the details about your CPU: http://ark.intel.com/products/53452/Intel-Core-i5-2450M-Processor-3M-Cache-up-to-3_10-GHz?q=2450M
Your CPU is also listed on the page titled "Products formerly Sandy Bridge" - so I can confrim at least it's a Sandy bridge.


The error you are describing...I don't know if it comes from the power management being ACPI, but in case of question, you can disable both of them in the kernel config and see if your machine works then.
By the way - does it boot, or does it hang at those messages?

You could in doubt try to update your mainboard BIOS and see if it resolves the issue.
_________________
There's no stupid questions, only stupid answers.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum