Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I willing broke my Gentoo with cpanm, any help fixing[solved
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
clytle374
Apprentice
Apprentice


Joined: 01 Aug 2006
Posts: 193

PostPosted: Wed Jun 22, 2016 12:44 am    Post subject: I willing broke my Gentoo with cpanm, any help fixing[solved Reply with quote

UPDATE: This turned out to be a really big coincidence. Both packages broke and threw a similar error on the same 'update day'. The KDE ebuild corrected itself and freecad broke do to a new dependency. Am I lucky or what?

It was an emergency to for a job I was doing, I knew there was a chance I'd break it and have to reinstall. Well, I think I broke it and thought someone might know of a fix before I start a reinstall. I know it's my fault, so any education on that subject is unhelpful.

I needed the dev version of slic3r and it wanted to be ran as root. Luckily it did work, but now I'm let with the following errors.

Code:
>>> Emerging (1 of 1) kde-frameworks/kdoctools-5.21.0::gentoo
 .......
-- Found Perl: /usr/bin/perl (found version "5.24.0")
-- Could NOT find PerlModules_URI::Escape (missing:  PerlModules_URI_Escape_FOUND)
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
  Could NOT find PerlModules (missing: PerlModules_all_modules_found
  URI::Escape)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
  cmake/FindPerlModules.cmake:77 (find_package_handle_standard_args)
  cmake/uriencode.cmake:34 (find_package)
  src/CMakeLists.txt:4 (kdoctools_encode_uri)


And building Freecad that worked the day before gives me.

Code:

-- Check for medfile (libmed and libmedc) ...
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
  Could NOT find MEDFile (missing: MEDFILE_INCLUDE_DIRS MEDFILE_LIBRARIES)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
  cMake/FindMEDFile.cmake:54 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:581 (find_package)


emerging cmake doesn't help like I had hoped from

Code:
equery b FindPackageHandleStandardArgs.cmake
 * Searching for FindPackageHandleStandardArgs.cmake ...
dev-util/cmake-3.3.1-r1 (/usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake)
media-libs/phonon-4.7.2 (/usr/share/phonon/buildsystem/FindPackageHandleStandardArgs.cmake)
media-libs/phonon-4.7.2 (/usr/share/phonon4qt5/buildsystem/FindPackageHandleStandardArgs.cmake)
sys-kernel/linux-firmware-20160331 (/lib/firmware/carl9170fw/extra/FindPackageHandleStandardArgs.cmake)


I tried using a overlay first, but it failed with the following.

Quote:
!!! All ebuilds that could satisfy "=media-gfx/Slic3r-9999" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-gfx/Slic3r-9999::axs (masked by: invalid: IUSE contains defaults, but EAPI doesn't allow them)


Here is the output from installing slic3r as root.

Code:
cory-laptop Slic3r # perl Build.PL --gui
App::cpanminus is up to date. (1.7042)
Class::Accessor is up to date. (0.34)
Growl::GNTP is up to date. (0.21)
LWP::UserAgent is up to date. (6.15)
Net::Bonjour is up to date. (0.96)
OpenGL is up to date. (0.6704)
Socket is up to date. (2.021)
Wx is up to date. (0.9928)
Wx::GLCanvas is up to date. (0.09)
cory-laptop Slic3r #


And if I try as a non root user to try and see what it did to my system, I get a lot of the following errors

Quote:
! Can't write to /usr/local/lib64/perl5/5.24.0 and /usr/local/bin: Installing modules to /home/cory/perl5
! To turn off this warning, you have to do one of the following:
! - run me as a root or with --sudo option (to install to /usr/local/lib64/perl5/5.24.0 and /usr/local/bin)
! - Configure local::lib in your existing shell to set PERL_MM_OPT etc.
! - Install local::lib by running the following commands
!
! cpanm --local-lib=~/perl5 local::lib && eval $(perl -I ~/perl5/lib/perl5/ -Mlocal::lib)
!
Wx::GLCanvas is up to date. (0.09)


I find
Code:
ls /usr/local/bin/     
.keep               enc2xs              instmodsh           use-devel-checklib  xsubpp             
cpanm               encguess            piconv              wxperl_overload   


Thinking about deleting everything in there.

And maybe everything in here too since it appears gentoo put perl stuff in /usr/lib64/perl5/5.24.0/
Code:
cory-laptop Slic3r # ls /usr/local/lib64/perl5/5.24.0
App  Devel  ExtUtils  Getopt  IO  Math  Method  Moo  Moo.pm  Sub  Test  Test2  Test2.pm  newgetopt.pl  ok.pm  oo.pm  perllocal.pod  x86_64-linux-thread-multi

_________________
NooB since RedHat 6.1


Last edited by clytle374 on Fri Aug 26, 2016 12:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 731
Location: S.O. France

PostPosted: Fri Jun 24, 2016 8:22 pm    Post subject: Reply with quote

Code:
 -- Could NOT find PerlModules_URI::Escape (missing:  PerlModules_URI_Escape_FOUND)

Any problem with your perl installation? Seems dev-perl/URI is missing.
Run perl-cleaner

Quote:
And building Freecad that worked the day before gives me.

What version?
Quote:
Check for medfile (libmed and libmedc) ...

Don't know which ebuild this file are depending sorry.

How do you install slic3r?
Have you done anything else because I don't understand how you can break perl installing slic3r?
Back to top
View user's profile Send private message
clytle374
Apprentice
Apprentice


Joined: 01 Aug 2006
Posts: 193

PostPosted: Sat Jun 25, 2016 11:54 pm    Post subject: Reply with quote

I've rebuilt dev-perl/URI a few times now, and perl-cleaner --reallyall a couple too.

Quote:
Gentoo package equivalents

Via overlay:

layman -a axs
emerge =media-gfx/Slic3r-9999
Building by Hand:

NOTE -- letting App-cpanminus do its thing on a Gentoo Linux system has a high chance of messing up your system image! Proceed with caution.

layman -a perl-experimental-snapshots
emerge App-cpanminus
emerge dev-perl/Moo
(You might still need to run sudo perl Build.PL and sudo perl Build.PL --gui after that one.)


This is from the a Slic3r page. Freecad is the current dev from git. I So is the Slic3r I think broke it. It was installed with

Quote:
perl Build.PL
perl Build.PL --gui

It built and installed without issue. I did a git pull that night of freecad and got the failure. No other changes and I got the failure with kde-frameworks/kdoctools-5.21.0::gentoo the next time I ran emerge -DuN world.

I believe that cpanm installed several perl packages. I have looked at the logs in hopes of trying to figure out what it did, I have had no luck and have no experience with it. Here is the beginning of a build after git pull

Code:
perl Build.PL
App::cpanminus is up to date. (1.7042)
Class::XSAccessor is up to date. (1.19)
Devel::CheckLib is up to date. (1.07)
Encode is up to date. (2.84)
Encode::Locale is up to date. (1.05)
ExtUtils::MakeMaker is up to date. (7.18)
ExtUtils::ParseXS is up to date. (3.30)
File::Basename is up to date. (2.85)
File::Spec is up to date. (3.63)
Getopt::Long is up to date. (2.49)
IO::Scalar is up to date. (2.111)
Math::PlanePath is up to date. (123)
Module::Build::WithXSpp is up to date. (0.14)
--> Working on Moo
Fetching http://www.cpan.org/authors/id/H/HA/HAARG/Moo-2.002003.tar.gz ... OK
Configuring Moo-2.002003 ... OK
Building and testing Moo-2.002003 ... OK
Successfully installed Moo-2.002003 (upgraded from 2.002002)
1 distribution installed
POSIX is up to date. (1.65)
Scalar::Util is up to date. (1.45)
Test::Harness is up to date. (3.36)
--> Working on Test::More
Fetching http://www.cpan.org/authors/id/E/EX/EXODIST/Test-Simple-1.302033.tar.gz ... OK
Configuring Test-Simple-1.302033 ... OK
Building and testing Test-Simple-1.302033 ... OK
Successfully installed Test-Simple-1.302033 (upgraded from 1.302031)
1 distribution installed
Thread::Semaphore is up to date. (2.12)
--> Working on Time::HiRes
Fetching http://www.cpan.org/authors/id/J/JH/JHI/Time-HiRes-1.9737.tar.gz ... OK
Configuring Time-HiRes-1.9737 ... OK
Building and testing Time-HiRes-1.9737 ... OK
Successfully installed Time-HiRes-1.9737 (upgraded from 1.9736)
1 distribution installed
Unicode::Normalize is up to date. (1.25)
XML::SAX::ExpatXS is up to date. (1.33)
threads is up to date. (2.09)
cpanm (App::cpanminus) 1.7042 on perl 5.024000 built for x86_64-linux-thread-multi
Work directory is /root/.cpanm/work/1466896678.6309
You have make /usr/bin/make
You have /usr/bin/wget
You have /bin/tar: tar (GNU tar) 1.28
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by John Gilmore and Jay Fenlason.
You have /usr/bin/unzip
--> Working on ./xs
Entering /home/cory/Slic3r/xs
Checking if you have ExtUtils::Install 1.46 ... Yes (2.04)
Checking if you have Module::Build 0.38 ... Yes (0.4216)
Running Build.PL
Configuring /home/cory/Slic3r/xs ... Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'Slic3r-XS' version '0.01'
OK
Checking dependencies from MYMETA.json ...
Checking if you have ExtUtils::Typemaps 1.00 ... Yes (3.30)
Checking if you have ExtUtils::XSpp 0.18 ... Yes (0.18)
Checking if you have ExtUtils::Typemaps::Basic 1.05 ... Yes (1.05)
Checking if you have Test::More 0 ... Yes (1.302033)
Checking if you have ExtUtils::Typemaps::Default 1.05 ... Yes (1.05)
Checking if you have ExtUtils::ParseXS 3.18 ... Yes (3.30)
Checking if you have Module::Build 0.3601 ... Yes (0.4216)
Building and testing Slic3r-XS-0.01 ... Building Slic3r-XS
Processing XS typemap files...
Generating main XS file...
x86_64-pc-linux-gnu-gcc -I/usr/l


Is there a way to install this in sandbox or something like that when I get a fresh install so I don't noke it again?

Thanks for looking at this
Cory
_________________
NooB since RedHat 6.1
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum