Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
program crash
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Tue Jun 28, 2016 5:41 am    Post subject: program crash Reply with quote

Hi,
I recently set up an pc with gentoo and I noticed, that programs which I ran over a long time crash. The message i get from "dmesg" is the following:

Code:

[ 2815.193839] kworker/dying (1283) used greatest stack depth: 12608 bytes left
[ 4324.982018] kworker/dying (11785) used greatest stack depth: 12544 bytes left
[ 9157.098076] kworker/dying (1453) used greatest stack depth: 12512 bytes left
[281177.357017] gerris3D[15504]: segfault at 30 ip 00007f4634165939 sp 00007ffd31ff6c90 error 4 in libopen-pal.so.0.0.0[7f4634156000+55000]
[281177.357062] gerris3D[15503]: segfault at 30 ip 00007f9ef7b69939 sp 00007ffcd1c31b10 error 4 in libopen-pal.so.0.0.0[7f9ef7b5a000+55000]
[281177.417795] gerris3D[15507]: segfault at 30 ip 00007fe7d3eef939 sp 00007fff3b1e8510 error 4 in libopen-pal.so.0.0.0[7fe7d3ee0000+55000]
[281217.113485] gerris3D[15511]: segfault at 30 ip 00007ff4f61ac939 sp 00007ffffce71390 error 4 in libopen-pal.so.0.0.0[7ff4f619d000+55000]
[281472.948802] gerris3D[7141]: segfault at 30 ip 00007f599c14a939 sp 00007ffd2d2ff890 error 4 in libopen-pal.so.0.0.0[7f599c13b000+55000]
[281472.951111] gerris3D[7142]: segfault at 30 ip 00007fb49cee3939 sp 00007ffcf2b93710 error 4 in libopen-pal.so.0.0.0[7fb49ced4000+55000]
[281473.004147] gerris3D[7145]: segfault at 30 ip 00007f8e7e772939 sp 00007ffc22461190 error 4 in libopen-pal.so.0.0.0[7f8e7e763000+55000]
[286018.753345] kworker/dying (3846) used greatest stack depth: 11824 bytes left
[511777.989490] dns[13575]: segfault at 7fff1465eff8 ip 00007f2ed03a5c56 sp 00007fff1465f000 error 6 in libvt-mpi.so.0.0.0[7f2ed0342000+89000]
[511777.989533] dns[13565]: segfault at 7ffdaff0bff8 ip 00007fc7f9a81c59 sp 00007ffdaff0c000 error 6 in libvt-mpi.so.0.0.0[7fc7f9a1e000+89000]
[511777.989572] dns[13570]: segfault at 7ffdc209fff8 ip 00007f34861dbd9d sp 00007ffdc20a0000 error 6 in libvt-mpi.so.0.0.0[7f3486178000+89000]
[511777.989623] dns[13568]: segfault at 7ffe3e02bff8 ip 00007f8880992d9d sp 00007ffe3e02c000 error 6 in libvt-mpi.so.0.0.0[7f888092f000+89000]
[511777.989737] dns[13559]: segfault at 7ffc82fcbff8 ip 00007f159ea15c56 sp 00007ffc82fcc000 error 6 in libvt-mpi.so.0.0.0[7f159e9b2000+89000]
[511777.989775] dns[13577]: segfault at 7ffe29983ff8 ip 00007faea9e86c59 sp 00007ffe29984000 error 6 in libvt-mpi.so.0.0.0[7faea9e23000+89000]
[511777.989817] dns[13569]: segfault at 7ffca7465ff8 ip 00007f2475da5d9d sp 00007ffca7466000 error 6 in libvt-mpi.so.0.0.0[7f2475d42000+89000]
[511777.989852] dns[13574]: segfault at 7ffd2c6a7ff8 ip 00007ff4250f2c52 sp 00007ffd2c6a8000 error 6 in libvt-mpi.so.0.0.0[7ff42508f000+89000]
[511777.990987] dns[13573]: segfault at 7ffe23399ff8 ip 00007f0124d46c56 sp 00007ffe2339a000 error 6 in libvt-mpi.so.0.0.0[7f0124ce3000+89000]
[511777.991006] dns[13562]: segfault at 7ffe0f2c5ff8 ip 00007f934c705c56 sp 00007ffe0f2c6000 error 6 in libvt-mpi.so.0.0.0[7f934c6a2000+89000]


Here gerris is a program which is also available in portage (we compiled it our self, due to performance issues) and "dns" is an self written code, both use OpenMPI for parallelisation, dough "gerris" used MPI compiled with Gnu compilers and "dns" used OpenMPI compiled with Intel fortran compiler. I am certain, that it is not an issue of the code, becuase I run it on other pc's aswell and there both, gerris and dns work fine!

Here is my "emerge --info":
Code:

Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0, gcc-4.9.3, glibc-2.22-r4, 4.4.6-gentoo x86_64)
=================================================================
System uname: Linux-4.4.6-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_X5690_@_3.47GHz-with-gentoo-2.2
KiB Mem:    98944172 total,  78169548 free
KiB Swap:   11534332 total,  11534332 free
Timestamp of repository gentoo: Mon, 20 Jun 2016 08:00:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.iso88591"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl amd64 berkdb bindist bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mmx mmxext modules mpi multilib ncurses nls nptl openmp pam pcre readline seccomp session sse sse2 ssl tcpd unicode xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="mga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Any idears on how to fix this?
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 400
Location: France

PostPosted: Tue Jun 28, 2016 8:09 am    Post subject: Reply with quote

Hello.

https://www.open-mpi.org/faq/?category=troubleshooting

See issue 7, maybe your problem is related.

++
Gi)
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Tue Jun 28, 2016 11:38 am    Post subject: Reply with quote

guitou wrote:
Hello.

https://www.open-mpi.org/faq/?category=troubleshooting

See issue 7, maybe your problem is related.

++
Gi)


My version of the intel compiler is much more recent and I also never noticed this issue while I ran both programs on debian!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum