Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
media-gfx/xnviewmp
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
gttg
n00b
n00b


Joined: 02 Oct 2015
Posts: 38

PostPosted: Fri Jul 01, 2016 8:32 am    Post subject: media-gfx/xnviewmp Reply with quote

Hi,

just installed from c2p-overlay, ebuild is xnviewmp-0.79-r1.
http://data.gpo.zugaina.org/c2p-overlay/media-gfx/xnviewmp/

It installed. But when I am clicking on icon, nothing happens.
How to check what is wrong with it?

Thank You
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Fri Jul 01, 2016 8:38 am    Post subject: Reply with quote

can you launch the application from the command line? maybe it will print some errors in the terminal
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
gttg
n00b
n00b


Joined: 02 Oct 2015
Posts: 38

PostPosted: Fri Jul 01, 2016 12:07 pm    Post subject: Reply with quote

yes, here is it

Code:


root # /opt/XnView/XnView
Qt: Session management error: None of the authentication protocols specified are supported
Fontconfig error: line 20351199: syntax error
Fontconfig error: Cannot load default config file
Segmentation fault



but all QT components for it are installed, yet I am using GTK+ environment - Cinnamon.
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Fri Jul 01, 2016 2:30 pm    Post subject: Reply with quote

two points to consider

- wich qt version do you use?
- try lo check fontconfig as https://wiki.gentoo.org/wiki/Fontconfig
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
gttg
n00b
n00b


Joined: 02 Oct 2015
Posts: 38

PostPosted: Fri Jul 01, 2016 4:29 pm    Post subject: Reply with quote

QT
there are both 4 and 5, but all qt5 versions marked in ebuild are present.

Code:


dev-qt/qtgui
     Available versions: 
     (4)    4.8.5-r4 4.8.6-r4 ~4.8.7
     (5)    5.4.2-r1^t
       {(+)accessibility aqua cups dbus debug egl eglfs evdev +exceptions +gif gles2 +glib gtkstyle +harfbuzz ibus jpeg mng nas nis pch +png qt3support test tiff trace +udev +xcb xinerama +xv ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  4.8.6-r4(4)(02:10:31 PM 10/04/2015)(accessibility cups exceptions glib mng qt3support tiff xv -aqua -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32") 5.5.1-r1(5)^t(01:55:41 PM 03/28/2016)(dbus gif jpeg png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -gtkstyle -ibus -libinput -test -tslib -tuio)


dev-qt/qtmultimedia
     Available versions: 
     (4)    4.8.5 4.8.6-r1 ~4.8.7
     (5)    5.4.2-r1^t
       {alsa aqua debug +exceptions +gstreamer openal opengl pch pulseaudio qml test widgets ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  5.5.1-r2(5)^t(03:25:31 PM 03/28/2016)(alsa pulseaudio widgets -debug -gles2 -gstreamer -gstreamer010 -openal -qml -test)


dev-qt/qtwidgets
     Available versions:  (5) 5.4.2^t
       {debug gles2 gtkstyle +png test +xcb}
     Installed versions:  5.5.1-r1(5)^t(01:58:37 PM 03/28/2016)(png xcb -debug -gles2 -gtkstyle -test)


dev-qt/qtnetwork
     Available versions:  (5) 5.4.2^t
       {bindist connman debug networkmanager +ssl test}
     Installed versions:  5.5.1(5)^t(02:29:52 PM 03/28/2016)(bindist networkmanager ssl -connman -debug -libproxy -test)


dev-qt/qtprintsupport
     Available versions:  (5) 5.4.2^t
       {cups debug gles2 test}
     Installed versions:  5.5.1(5)^t(01:59:37 PM 03/28/2016)(cups -debug -gles2 -test)


dev-qt/qtsvg
     Available versions: 
     (4)    4.8.5 4.8.6-r1 ~4.8.7
     (5)    5.4.2^t
       {+accessibility aqua debug +exceptions pch test ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  4.8.6-r1(4)(03:03:39 PM 10/04/2015)(accessibility exceptions -aqua -debug -pch ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32") 5.5.1-r1(5)^t(01:59:54 PM 03/28/2016)(-debug -test)


dev-qt/qtx11extras
     Available versions:  (5) 5.4.2^t
       {debug test}
     Installed versions:  5.5.1(5)^t(06:36:22 AM 04/24/2016)(-debug -test)


dev-qt/qtconcurrent
     Available versions:  (5) 5.4.2^t
       {debug test}
     Installed versions:  5.5.1(5)^t(02:04:12 PM 05/25/2016)(-debug -test)


dev-qt/qtxml
     Available versions:  (5) 5.4.2^t
       {debug test}
     Installed versions:  5.5.1(5)^t(01:39:52 PM 03/28/2016)(-debug -test)


dev-qt/qtxmlpatterns =\\\ this one is not present in ebuild
     Available versions: 
     (4)    4.8.5 4.8.6-r1 ~4.8.7
     (5)    5.4.2^t
       {aqua debug pch test ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  4.8.6-r1(4)(03:02:29 PM 10/04/2015)(-aqua -debug -pch ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")


dev-qt/qtopengl
     Available versions: 
     (4)    4.8.5 4.8.6-r1 ~4.8.7
     (5)    5.4.2^t
       {aqua debug egl +exceptions gles2 pch qt3support test ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  4.8.6-r1(4)(12:36:02 AM 06/19/2016)(exceptions qt3support -aqua -debug -egl -pch ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32") 5.5.1(5)^t(01:59:06 PM 03/28/2016)(-debug -gles2 -test)


ev-qt/qtsql
     Available versions: 
     (4)    4.8.5 4.8.6-r1 ~4.8.7
     (5)    5.4.2^t
       {aqua debug +exceptions firebird freetds mysql oci8 odbc pch postgres qt3support +sqlite test ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  4.8.6-r1(4)(02:01:43 PM 10/04/2015)(exceptions qt3support sqlite -aqua -debug -freetds -mysql -oci8 -odbc -pch -postgres ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32") 5.5.1(5)^t(01:39:30 PM 03/28/2016)(sqlite -debug -freetds -mysql -oci8 -odbc -postgres -test)


dev-qt/qtdbus
     Available versions: 
     (4)    4.8.5 4.8.6-r1 ~4.8.7
     (5)    5.4.2^t
       {aqua debug +exceptions pch test ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  4.8.6-r1(4)(03:11:08 PM 10/04/2015)(exceptions -aqua -debug -pch ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32") 5.5.1(5)^t(01:50:07 PM 03/28/2016)(-debug -test)


dev-qt/qtwebkit
     Available versions: 
     (4)    4.8.5 4.8.6-r1 ~4.8.7 [M]~4.10.4
     (5)    5.4.2^mt
       {aqua debug +exceptions (+)gstreamer gstreamer010 icu +jit multimedia opengl pch printsupport qml test udev webp ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  4.8.6-r1(4)(11:40:14 PM 05/08/2016)(exceptions gstreamer icu jit -aqua -debug -pch ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32") 5.5.1-r1(5)^mt(10:15:04 AM 05/09/2016)(jit opengl printsupport -debug -geolocation -gstreamer -gstreamer010 -multimedia -orientation -qml -test -webchannel -webp)


dev-qt/qtimageformats
     Available versions:  (5) ~5.4.2^t
       {debug test}
     Installed versions:  5.5.1-r1(5)^t(05:52:07 AM 07/01/2016)(-debug -test)


dev-libs/icu
     Available versions:  54.1-r1(0/54a) 55.1(0/55) {debug doc examples static-libs ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  57.1(0/57)(10:37:34 PM 05/08/2016)(-debug -doc -examples -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")


dev-libs/glib
     Available versions: 
     (1)    1.2.10-r5 1.2.10-r6
     (2)    2.40.2 2.42.2 2.44.1 ~2.44.1-r1
       {dbus debug fam hardened +mime selinux static-libs systemtap test utils xattr ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" KERNEL="linux" PYTHON_TARGETS="python2_7"}
     Installed versions:  2.46.2-r3(2)(12:10:14 PM 05/15/2016)(dbus mime xattr -debug -fam -selinux -static-libs -systemtap -test -utils ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" KERNEL="linux" PYTHON_TARGETS="python2_7")


x11-libs/libX11
     Available versions:  1.6.2 ~1.6.3 {doc ipv6 static-libs test ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  1.6.3(05:48:27 PM 12/06/2015)(ipv6 -doc -static-libs -test ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")


x11-libs/libXi
     Available versions:  1.7.2 1.7.4 ~1.7.5 {doc static-libs ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  1.7.5(05:50:12 PM 12/06/2015)(-doc -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")


x11-libs/libXt
     Available versions:  1.1.4 ~1.1.5 {static-libs ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  1.1.5(06:02:55 PM 12/06/2015)(-static-libs ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")










what font i should enable?

Code:

# eselect fontconfig list
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-scale-bitmap-fonts.conf *
  [4]   10-sub-pixel-bgr.conf
  [5]   10-sub-pixel-rgb.conf
  [6]   10-sub-pixel-vbgr.conf
  [7]   10-sub-pixel-vrgb.conf
  [8]   10-unhinted.conf
  [9]   11-lcdfilter-default.conf
  [10]  11-lcdfilter-legacy.conf
  [11]  11-lcdfilter-light.conf
  [12]  20-unhint-small-dejavu-sans.conf
  [13]  20-unhint-small-dejavu-sans-mono.conf
  [14]  20-unhint-small-dejavu-serif.conf
  [15]  20-unhint-small-vera.conf *
  [16]  25-unhint-nonlatin.conf
  [17]  30-metric-aliases.conf *
  [18]  30-urw-aliases.conf *
  [19]  40-nonlatin.conf *
  [20]  42-luxi-mono.conf *
  [21]  45-latin.conf *
  [22]  49-sansserif.conf *
  [23]  50-user.conf *
  [24]  51-local.conf *
  [25]  57-dejavu-sans.conf
  [26]  57-dejavu-sans-mono.conf
  [27]  57-dejavu-serif.conf
  [28]  60-latin.conf *
  [29]  60-liberation.conf
  [30]  65-fonts-persian.conf *
  [31]  65-khmer.conf
  [32]  65-nonlatin.conf *
  [33]  69-unifont.conf *
  [34]  70-no-bitmaps.conf
  [35]  70-yes-bitmaps.conf
  [36]  80-delicious.conf *
  [37]  90-synthetic.conf *
  [38]  99pdftoopvp.conf
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1109
Location: switzerland

PostPosted: Sat Jul 02, 2016 6:20 am    Post subject: Reply with quote

gttg ,

I suggest you to ask directly in the xnviewmo forum

http://newsgroup.xnview.com/viewforum.php?f=68


I tried to search in google to help you but there are a lot of causes for this error,...I think is a fontconfig related error and not qt

let me know please, and sorry for my english
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
gttg
n00b
n00b


Joined: 02 Oct 2015
Posts: 38

PostPosted: Sat Jul 02, 2016 12:09 pm    Post subject: Reply with quote

this thread solved issue
http://newsgroup.xnview.com/viewtopic.php?f=82&t=32321&p=128641&hilit=fontconfig&sid=96e6d503bf47bc09b64043906e3060df#p128641
I've placed this executable, yet 0.76 version. But it works.
Seems something is wrong with executables. there.
Thank You.
Will post there issue about 0.79 version, and once that works, will mark this as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum