Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't seem to use genkernel lately [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6315
Location: /usr/lib64/lv2

PostPosted: Fri Jun 10, 2016 7:14 pm    Post subject: Can't seem to use genkernel lately [SOLVED] Reply with quote

Anyone having trouble using genkernel lately? I've tried compiling hardened-sources and gentoo-sources, either chrooting from sysresccd or after I've booted into a base install. Tried again after setting up my system further, still fails. Last time, it failed on "drivers" and "net."
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.


Last edited by audiodef on Thu Jul 07, 2016 12:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3121
Location: Illinois, USA

PostPosted: Thu Jun 23, 2016 12:21 am    Post subject: Re: Can't seem to use genkernel lately Reply with quote

audiodef wrote:
Anyone having trouble using genkernel lately? I've tried compiling hardened-sources and gentoo-sources, either chrooting from sysresccd or after I've booted into a base install. Tried again after setting up my system further, still fails. Last time, it failed on "drivers" and "net."


I used genkernel (latest stable) on two existing installations in the last week with no problem. Can you pastebin your /etc/genkernel.conf ? Also, what complete command are you using to run genkernel. Is this the first time on this installation? How much RAM is available?
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6315
Location: /usr/lib64/lv2

PostPosted: Thu Jul 07, 2016 12:04 pm    Post subject: Reply with quote

There might be a bug somewhere. Genkernel runs reliably IFF I disable CONFIG_BUILD_DOCSRC in menuconfig. So I've made a self-note to do that from now on. I've experienced this with more than one kernel version and more than one kernel flavor on more than one machine.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3121
Location: Illinois, USA

PostPosted: Thu Jul 07, 2016 12:23 pm    Post subject: Reply with quote

audiodef wrote:
Genkernel runs reliably IFF I disable CONFIG_BUILD_DOCSRC in menuconfig.


Never used that one and it's hard to find. Rather vague description. What's it supposed to do?
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6315
Location: /usr/lib64/lv2

PostPosted: Sun Jul 10, 2016 12:57 am    Post subject: Reply with quote

Don't remember the exact description from menuconfig, but it builds documentation, which is not needed for most user purposes. Not sure why it seems to be enabled by default, but disabling it allows genkernel to proceed.

Possibly I have a habit of setting something somewhere that triggers this, but I can't think of what it might be offhand. I don't generally use the doc use flag.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum