Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
USB keyboard and mouse quit working.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1507
Location: San Jose, CA

PostPosted: Wed Jul 06, 2016 9:01 pm    Post subject: USB keyboard and mouse quit working. Reply with quote

There is a lot of old threads about this, but I'm starting a new one anyway.

I just updated to the latest unstable qt and plasma and I updated to gentoo-sources-4.6.3.

My Logitech keyboard and mouse stop working if I leave them alone for a few minutes. The easiest way to get them back is to plug in a USB device which wakes them up.

I have tried disabling power savings using laptop_mode's power settings:

/etc/laptop-mode/conf.d/runtime-pm.conf:
Code:
AUTOSUSPEND_RUNTIME_DEVID_BLACKLIST="046d:c52b"


That didn't work so:
Code:
CONTROL_RUNTIME_AUTOSUSPEND=0


That didn't work either.

Anyone been through this?

It's a bummer to have to wake up the keyboard and mouse by plugging in a USB device...
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1368
Location: Montréal

PostPosted: Thu Jul 07, 2016 10:44 am    Post subject: Reply with quote

The usbcore module have autosuspend parameter that you can set to 0 to disable it. I am not sure if this will resolv your problem because, Usb mouses and keyboards should not need external Usb device plug to wake up by default.

So, you can do
Code:
echo 'options usbcore autosuspend=0' > /etc/modprobe.d/usbcore.conf

If usbcore is in the kernel image you can pass the usbcore.autosuspend=0 parameter to the Linux kernel.
_________________
Paul
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1655
Location: United Kingdom

PostPosted: Thu Jul 07, 2016 12:56 pm    Post subject: Reply with quote

Does the problem still occur after you have removed Laptop Mode Tools from the default runlevel and rebooted?

Code:
rc-update delete laptop_mode default

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1507
Location: San Jose, CA

PostPosted: Thu Jul 07, 2016 3:52 pm    Post subject: Reply with quote

Thanks for the replies.

Update: even though I had restarted laptop_mode multiple times after changing the config file, the keyboard and mouse would still stop working.

However, after rebooting with laptop_mode enabled and usb power saving disabled in the laptop_mode config files, the problem has gone away.

Strange, but so far so good.
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum