Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]/dev/mapper/gentoo-usr is already mounted opertional
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
83657664
n00b
n00b


Joined: 16 Mar 2011
Posts: 50

PostPosted: Sat Jul 02, 2016 3:45 pm    Post subject: [SOLVED]/dev/mapper/gentoo-usr is already mounted opertional Reply with quote

when system boot,
everything seems ok,when it is mount partion.
only this device :
Code:
/dev/mapper/gentoo-usr is already mounted
e2fsck can not running,aborting.
error opertional .

i can't figure why this error happened.

df print

/dev/mapper/gentoo-usr is mounted
it can use mounted files
but can't be unmounted.
Code:
it's sys target is busy
isof(8) and fuser(1)..........
i can't remember.
anyone know why?


Last edited by 83657664 on Sat Jul 16, 2016 12:00 am; edited 2 times in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44038
Location: 56N 3W

PostPosted: Sat Jul 02, 2016 4:09 pm    Post subject: Reply with quote

83657664,

After your inappropriate large text, its tempting to just post 'yes' but that would be against the spirit of the Gentoo forum.

I guess that /dev/mapper/gentoo-usr ends up as /usr. The current wisdom is that to support a separate user, you need an initrd to mount it before udev starts.
Your initrd is therefore responsible for checking /dev/mapper/gentoo-usr before its mounted.

Its not an error to mount an already mounted filesystem but you can't check it.

My fstab has
Code:
# now on ssd
UUID=1c981da8-f0f6-4953-b485-8dbc9e7c6879  /var                    ext4  noatime,noauto,discard    1 0
UUID=24e36648-f410-40b8-931f-41ad46741a47  /usr                    ext4  noatime,noauto,discard    1 0
because my initrd mounts both /usr and /var and I don't need localmount to try to remount them.
My initrd also does the fsck when its required.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
83657664
n00b
n00b


Joined: 16 Mar 2011
Posts: 50

PostPosted: Sat Jul 02, 2016 5:22 pm    Post subject: Reply with quote

NeddySeagoon wrote:
83657664,

After your inappropriate large text, its tempting to just post 'yes' but that would be against the spirit of the Gentoo forum.

I guess that /dev/mapper/gentoo-usr ends up as /usr. The current wisdom is that to support a separate user, you need an initrd to mount it before udev starts.
Your initrd is therefore responsible for checking /dev/mapper/gentoo-usr before its mounted.

Its not an error to mount an already mounted filesystem but you can't check it.

My fstab has
Code:
# now on ssd
UUID=1c981da8-f0f6-4953-b485-8dbc9e7c6879  /var                    ext4  noatime,noauto,discard    1 0
UUID=24e36648-f410-40b8-931f-41ad46741a47  /usr                    ext4  noatime,noauto,discard    1 0
because my initrd mounts both /usr and /var and I don't need localmount to try to remount them.
My initrd also does the fsck when its required.


but how ?
i already had a initrd in /boot
just write a uuid and discard in my fstab,
will you tell me some steps to do?
thanks.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44038
Location: 56N 3W

PostPosted: Sat Jul 02, 2016 5:48 pm    Post subject: Reply with quote

83657664,

Thank you for fixing you first post.

You need the noauto option for /usr in /etc/fstab so that localmount does not try to mount the already mounted file system.
Do not be tempted to remove the /usr entry as the initrd may read it to find out where /usr is. Then booting will fail.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
83657664
n00b
n00b


Joined: 16 Mar 2011
Posts: 50

PostPosted: Sun Jul 03, 2016 5:57 am    Post subject: Reply with quote

NeddySeagoon wrote:
83657664,

Thank you for fixing you first post.

You need the noauto option for /usr in /etc/fstab so that localmount does not try to mount the already mounted file system.
Do not be tempted to remove the /usr entry as the initrd may read it to find out where /usr is. Then booting will fail.

add noauto,same error
before openrc start,i notice a msg:
Quote:
mount /dev/mapper/gentoo-usr as /usr, mount -etx4 ........

NeddySeagoon,
thank you for your help.
i think there is wrong with kernel config.
but where ?
which option can mount /usr before openrc start?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44038
Location: 56N 3W

PostPosted: Sun Jul 03, 2016 8:04 am    Post subject: Reply with quote

83657664,

Your kernel is OK. If there were a problem there, it would just not work.
The message you see is a warning.
Quote:
before openrc start,i notice a msg:

Quote:
mount /dev/mapper/gentoo-usr as /usr, mount -etx4 ........

That's expected. Its from the initrd mounting /usr before it hands over to the real root filesystem.
The warning is generated by the localmount openrc service trying to mount /usr again and attempting to check it in the process.

Please post your /etc/fstab. Either copy and paste it to a post or use wgetpaste to put it onto a pastebin.
We don't want any copy typing errors.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
83657664
n00b
n00b


Joined: 16 Mar 2011
Posts: 50

PostPosted: Mon Jul 04, 2016 1:34 am    Post subject: Reply with quote

NeddySeagoon,


here is my /etc/fstab:
Code:

/dev/sdb2                      /boot           ext4          defaults,noatime      1 2
/dev/mapper/gentoo-root        /               ext4          noatime         0 1
/dev/mapper/gentoo-usr         /usr            ext4          noatime         0 2
/dev/mapper/gentoo-opt         /opt            ext4          noatime         0 2
/dev/mapper/gentoo-var         /var            ext4          noatime         0 2
/dev/mapper/gentoo-home        /home           ext4          noatime         0 2
/dev/mapper/gentoo-swap        none            swap          sw              0 0

add noauto,same error
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44038
Location: 56N 3W

PostPosted: Mon Jul 04, 2016 5:37 pm    Post subject: Reply with quote

83657664,

You don't have noauto.
Code:
/dev/mapper/gentoo-usr         /usr            ext4          noatime,noauto         0 2


Your initrd init script may read the file to determine that /usr is /dev/mapper/gentoo-usr. It will not use the mount options.
When localmount runs, controlled by OpenRC, it will not try to mount /usr again as localmount will obey the noauto.
That's fine as /usr is already mounted.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
83657664
n00b
n00b


Joined: 16 Mar 2011
Posts: 50

PostPosted: Sat Jul 09, 2016 11:48 am    Post subject: Reply with quote

NeddySeagoon wrote:
83657664,

You don't have noauto.
Code:
/dev/mapper/gentoo-usr         /usr            ext4          noatime,noauto         0 2


Your initrd init script may read the file to determine that /usr is /dev/mapper/gentoo-usr. It will not use the mount options.
When localmount runs, controlled by OpenRC, it will not try to mount /usr again as localmount will obey the noauto.
That's fine as /usr is already mounted.


NeddySeagoon

it's no help even change to noauto
here is my rc.log:
Code:
rc shutdown logging started at Sat Jul  9 18:44:28 2016

 * Caching service dependencies ...
 [ ok ]
 * Stopping local ...
 [ ok ]
 * Saving random seed ...
 [ ok ]
 * Deactivating additional swap space ...
 [ ok ]
 * Stopping sshd ...
 [ ok ]
/lib64/rc/sh/rc-cgroup.sh: line 91: /sys/fs/cgroup/openrc/keymaps/tasks: No such file or directory
 * Stopping DHCP Client Daemon ...
 [ ok ]
 * Stopping cronie ...
 [ ok ]
 * Stopping syslog-ng ...
 [ ok ]
 * Unmounting loop devices
 * Unmounting filesystems
 *   Unmounting /tmp ...
 [ ok ]
 *   Unmounting /opt ...
 [ ok ]
 *   Unmounting /var ...
 [ ok ]
 *   Unmounting /home ...
 [ ok ]
 * Deactivating swap devices ...
 [ ok ]
 * Shutting down the Logical Volume Manager
 *   Shutting Down LVs & VGs ...
  Logical volume gentoo/root contains a filesystem in use.
  Logical volume gentoo/usr contains a filesystem in use.
 * Failed (possibly some LVs still needed for /usr or root)
 [ !! ]
 * Finished shutting down the Logical Volume Manager
 * Stopping lvmetad ...
 [ ok ]
 * Stopping udev ...
 [ ok ]
 * Setting hardware clock using the system clock [Local Time] ...
 [ ok ]

rc shutdown logging stopped at Sat Jul  9 18:44:30 2016


rc sysinit logging started at Sat Jul  9 18:46:21 2016


   OpenRC 0.19.1 is starting up Gentoo Linux (x86_64)

 * /proc is already mounted
 * Mounting /run ...
 * /run/openrc: creating directory
 * /run/lock: creating directory
 * /run/lock: correcting owner
 * Remounting devtmpfs on /dev ...
 [ ok ]
 * Mounting /dev/mqueue ...
 [ ok ]
 * Mounting /dev/shm ...
 [ ok ]
 * Restoring SELinux contexts in /dev ...
 [ ok ]
 * Creating list of required static device nodes for the current kernel ...
 [ ok ]
 * Mounting debug filesystem ...
 [ ok ]
 * Mounting fuse control filesystem ...
 [ ok ]
 * Mounting SELinux filesystem ...
 [ ok ]
 * Mounting cgroup filesystem ...
 [ ok ]
 * Restoring SELinux contexts in /sys ...
 [ ok ]
 * Setting up tmpfiles.d entries for /dev ...
 [ ok ]
 * Starting udev ...
starting version 225
 [ ok ]
 * Generating a rule to create a /dev/root symlink ...
 [ ok ]
 * Populating /dev with existing devices through uevents ...
 [ ok ]
 * Waiting for uevents to be processed ...
 [ ok ]

rc sysinit logging stopped at Sat Jul  9 18:46:21 2016


rc boot logging started at Sat Jul  9 18:46:21 2016

 * Setting system clock using the hardware clock [Local Time] ...
 [ ok ]
 * Autoloaded 0 module(s)
 [ ok ]
 * /run/lvm: creating directory
 * Starting lvmetad ...
 [ ok ]
 * Setting up the Logical Volume Manager ...
 [ ok ]
 * Checking local filesystems  ...
/dev/mapper/gentoo-root: clean, 3717/983040 files, 234046/3932160 blocks
/dev/mapper/gentoo-home: clean, 12/32768000 files, 2107224/131072000 blocks
/dev/mapper/gentoo-usr is mounted.
e2fsck: Cannot continue, aborting.


/dev/mapper/gentoo-var: clean, 17867/6553600 files, 526216/26214400 blocks
/dev/mapper/gentoo-opt: clean, 286/3276800 files, 274769/13107200 blocks
/dev/mapper/gentoo-tmp: clean, 13/814400 files, 91836/3253248 blocks
/dev/sdb2: clean, 359/24384 files, 28720/97280 blocks
 * Operational error
 [ !! ]
 * Remounting root filesystem read/write ...
 [ ok ]
 * Remounting filesystems ...
 [ ok ]
 * Updating /etc/mtab ...
 * Creating mtab symbolic link
 [ ok ]
/lib64/rc/sh/rc-cgroup.sh: line 91: /sys/fs/cgroup/openrc/swap/tasks: No such file or directory
 * Activating swap devices ...
 [ ok ]
 * Mounting local filesystems ...
 [ ok ]
 * Mounting misc binary format filesystem ...
 [ ok ]
 * Loading custom binary format handlers ...
 [ ok ]
/lib64/rc/sh/rc-cgroup.sh: line 91: /sys/fs/cgroup/openrc/sysctl/tasks: No such file or directory
 * Configuring kernel parameters ...
 [ ok ]
 * Creating user login records ...
 [ ok ]
 * Wiping /tmp directory ...
 [ ok ]
 * Setting hostname to claymore ...
 [ ok ]
 * Setting terminal encoding [UTF-8] ...
 [ ok ]
 * Setting keyboard mode [UTF-8] ...
 [ ok ]
 * Loading key mappings [us] ...
 [ ok ]
 * Bringing up network interface lo ...
 [ ok ]
 * Activating additional swap space ...
 [ ok ]
 * Setting up tmpfiles.d entries ...
 [ ok ]
 * Initializing random number generator ...
 [ ok ]

rc boot logging stopped at Sat Jul  9 18:46:26 2016


rc default logging started at Sat Jul  9 18:46:26 2016

 * Checking your configfile (/etc/syslog-ng/syslog-ng.conf) ...
 [ ok ]
 * Starting syslog-ng ...
 [ ok ]
/lib64/rc/sh/rc-cgroup.sh: line 91: /sys/fs/cgroup/openrc/cronie/tasks: No such file or directory
 * Starting cronie ...
 [ ok ]
 * Starting DHCP Client Daemon ...
 [ ok ]
/lib64/rc/sh/rc-cgroup.sh: line 91: /sys/fs/cgroup/openrc/net.eth0/tasks: No such file or directory
 * Bringing up interface eth0
 *   dhcp ...
 *     Running dhcpcd ...
sending commands to master dhcpcd process
 [ ok ]
 *     received address
 [ ok ]
 * Mounting network filesystems ...
 [ ok ]
 * Starting sshd ...
 [ ok ]
 * Starting local ...
 [ ok ]

rc default logging stopped at Sat Jul  9 18:46:28 2016

that's before rc start,
there is line :mout /dev/mapper/gentoo-usr as new /usr
it's pop up so quick,
i can't remember
Back to top
View user's profile Send private message
83657664
n00b
n00b


Joined: 16 Mar 2011
Posts: 50

PostPosted: Sat Jul 09, 2016 12:43 pm    Post subject: Reply with quote

i see one link :
https://forums.gentoo.org/viewtopic-p-7352894.html
solve my problem

NeddySeagoon,
thanks any way.
this topic is closed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum