Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Canon PIXMA MG5750 - "Filter failed"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
sliwowitz
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 197
Location: Europe/Prague

PostPosted: Sun Jul 17, 2016 2:27 pm    Post subject: Canon PIXMA MG5750 - "Filter failed" Reply with quote

I'm trying to install the Canon PIXMA MG5750 printer. It should be supported by the cnijfilter2 5.20 drivers. I got the ebuild from the overlay at https://github.com/MeisterP/poncho-overlay/tree/master/net-print/cnijfilter2 and changed it to download & install version 5.20. I can add the printer just fine, and it is automatically recognized as series 5700, but when I try to print anything, I only get a blank page, and a "Filter failed" error. I uploaded the CUPS debug log at http://pastebin.com/dn0M0KXh

Any tips?
_________________
The question of whether Machines Can Think... is about as relevant as the question of whether Submarines Can Swim.
-- Edsger Dijkstra
Back to top
View user's profile Send private message
sliwowitz
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 197
Location: Europe/Prague

PostPosted: Tue Jul 19, 2016 10:14 pm    Post subject: Reply with quote

There are also commercial 3rd party drivers "TurboPrint" http://zedonet.com/en_p_turboprint_driver.phtml?&mfg=Canon and they seem to work fine so far (you have to install through their 'toolbox' which somehow feels weird). I'd really prefer to run on the free drivers though. TurboPrint offers some 30 day trial, so I still hope I will find the solution for the official cnijfilter2 driver by then...
_________________
The question of whether Machines Can Think... is about as relevant as the question of whether Submarines Can Swim.
-- Edsger Dijkstra
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1647
Location: United Kingdom

PostPosted: Tue Jul 19, 2016 10:51 pm    Post subject: Reply with quote

Gutenprint has a FOSS driver for the Canon MG5750. Have you tried that?

http://gimp-print.sourceforge.net/p_Supported_Printers.php
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
sliwowitz
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 197
Location: Europe/Prague

PostPosted: Tue Jul 19, 2016 11:53 pm    Post subject: Reply with quote

Fitzcarraldo wrote:
Gutenprint has a FOSS driver for the Canon MG5750. Have you tried that?

http://gimp-print.sourceforge.net/p_Supported_Printers.php


Thanks for the tip, I didn't know about these. I had to install version 5.2.11 which is not in portage yet (the latest 5.2.10 didn't offer the mg5700 series driver). I copied the ebuild and patches to my local overlay, it emerged fine, and I got the gutenprint driver for mg5700, but now when I try to print anything, I just get a page fully covered with black ink. I'll investigate that later (I just restarted the cups service, but maybe I should try to rebuild cups and restart the whole computer in a couple days)

Also the scanner isn't recognized. I don't know whether there is a backend in the sane-backends git version (it does not seem to be listed on the supported scanners web page), as the media-gfx/sane-backends-9999 ebuild fails to apply one of the patches (sane-backends-1.0.25-disable-usb-tests.patch, will investigate later as well - no need to scan anything right now).

For future reference - a link to the other forum thread, where Fitzcarraldo contributed more information about Canon PXIMAs https://forums.gentoo.org/viewtopic-t-1024836-view-previous.html?sid=6a509ca67ee51f8a1b3414d5ce27ad71
_________________
The question of whether Machines Can Think... is about as relevant as the question of whether Submarines Can Swim.
-- Edsger Dijkstra
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1647
Location: United Kingdom

PostPosted: Wed Jul 20, 2016 8:52 am    Post subject: Reply with quote

I'm not sure about the black page issue. You might want to check which USE flags you have set for the various printer-related packages. Below is what I have got on my main laptop, which does print correctly to a Canon PIXMA MG6150 printer using a Gutenprint driver, although that does not mean much.

Code:
fitzcarraldo@clevow230ss ~ $ eix -I ghostscript
[I] app-text/ghostscript-gpl
     Available versions:  9.10-r2^d ~9.10-r4^d 9.15-r1^d [M]~9.18^d ~9.19^d {X cups dbus djvu gtk idn static-libs tiff L10N="de ja ko zh-CN zh-TW"}
     Installed versions:  9.15-r1(23:36:40 25/06/16)(X cups dbus gtk tiff -djvu -idn -static-libs L10N="-de -ja -ko -zh-CN -zh-TW")
     Homepage:            http://ghostscript.com/
     Description:         Ghostscript is an interpreter for the PostScript language and for PDF

fitzcarraldo@clevow230ss ~ $ eix -I gutenprint
[I] net-print/gutenprint
     Available versions:  5.2.9^t ~5.2.10^t {cups foomaticdb gimp gtk nls ppds readline static-libs}
     Installed versions:  5.2.9^t(22:27:57 18/04/15)(cups foomaticdb gimp gtk nls ppds readline -static-libs)
     Homepage:            http://gutenprint.sourceforge.net
     Description:         Ghostscript and cups printer drivers

fitzcarraldo@clevow230ss ~ $ eix -I foomatic
[I] net-print/foomatic-db
     Available versions:  4.0.20140105 ~4.0.20141025 ~4.0.20150819 ~4.0.20160504
     Installed versions:  4.0.20140105(22:10:20 18/04/15)
     Homepage:            http://www.linuxprinting.org/foomatic.html
     Description:         Printer information files for foomatic-db-engine to generate ppds

[I] net-print/foomatic-db-engine
     Available versions:  4.0.11 ~4.0.12
     Installed versions:  4.0.11(17:35:49 23/06/15)
     Homepage:            http://www.linuxprinting.org/foomatic.html
     Description:         Generates ppds out of xml foomatic printer description files

[I] net-print/foomatic-db-ppds
     Available versions:  4.0.20140105 ~4.0.20141025 ~4.0.20150819-r1 ~4.0.20160504
     Installed versions:  4.0.20140105(22:09:48 18/04/15)
     Homepage:            http://www.linuxprinting.org/foomatic.html
     Description:         linuxprinting.org PPD files for postscript printers

Found 3 matches
fitzcarraldo@clevow230ss ~ $ eix -I cups
[I] dev-python/pycups
     Available versions:  1.9.72 1.9.73 {doc examples PYTHON_TARGETS="pypy python2_7 python3_3 python3_4"}
     Installed versions:  1.9.73(23:00:24 11/07/16)(-doc -examples PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3")
     Homepage:            http://cyberelk.net/tim/data/pycups/
     Description:         Python bindings for the CUPS API

[I] net-print/cups
     Available versions:  2.0.3^t ~2.0.4^t 2.1.3-r1^t ~2.1.4^t **9999^t {X acl dbus debug java kerberos lprng-compat pam python selinux +ssl static-libs systemd +threads usb xinetd zeroconf ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" ELIBC="FreeBSD" LINGUAS="+ca +cs +de +es +fr +it +ja +ru" PYTHON_TARGETS="python2_7"}
     Installed versions:  2.1.3-r1^t(00:17:44 08/06/16)(X acl dbus pam ssl threads usb zeroconf -debug -java -kerberos -lprng-compat -python -selinux -static-libs -systemd -xinetd ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" ELIBC="-FreeBSD" LINGUAS="-ca -cs -de -es -fr -it -ja -ru" PYTHON_TARGETS="python2_7")
     Homepage:            http://www.cups.org/
     Description:         The Common Unix Printing System

[I] net-print/cups-bjnp
     Available versions:  ~1.1 ~1.2.1 (~)2.0
     Installed versions:  2.0(22:42:54 18/04/15)
     Homepage:            http://sourceforge.net/projects/cups-bjnp/
     Description:         CUPS backend for the canon printers using the proprietary USB over IP BJNP protocol

[I] net-print/cups-filters
     Available versions:  1.5.0 ~1.6.0 ~1.8.2-r1 ~1.8.3 **9999 {dbus +foomatic jpeg ldap perl png +postscript static-libs tiff zeroconf}
     Installed versions:  1.5.0(15:26:33 20/04/16)(dbus foomatic jpeg ldap png tiff zeroconf -perl -static-libs)
     Homepage:            http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat
     Description:         Cups PDF filters

[I] net-print/cups-pdf
     Available versions:  2.6.1 ~3.0_beta1 {+ppds}
     Installed versions:  2.6.1(22:52:34 19/04/15)
     Homepage:            http://www.cups-pdf.de/
     Description:         Provides a virtual printer for CUPS to produce PDF files

Found 5 matches

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum