Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Lots of issues after emerging testing R package:
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
nelsonwcf
Tux's lil' helper
Tux's lil' helper


Joined: 31 Oct 2012
Posts: 112

PostPosted: Thu Jul 21, 2016 1:54 am    Post subject: Lots of issues after emerging testing R package: Reply with quote

Hi guys,

Since I've tried to emerge the latest version of R package, my system go all messed up and I don't know how fix many of the conflicts that started to appear in portage. I returned the previous settings to packages.{keywords, accept_keywords, use} but even so I can't seem find a way to fix the conflicts.

Can someone help me fix my portage build?

Code:
Calculating dependencies  ..... done!
[ebuild   R    ] x11-libs/libX11-1.6.3  ABI_X86="32*"

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-proto/inputproto:0

  (x11-proto/inputproto-2.3.1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/inputproto-2.3[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, ebuild scheduled for merge)
                                                           

x11-libs/libXdmcp:0

  (x11-libs/libXdmcp-1.1.2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed)
                                                             

net-fs/samba:0

  (net-fs/samba-4.2.11:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=net-fs/samba-4.0.0_alpha1[client] required by (kde-apps/kio-extras-15.12.3:5/5::gentoo, installed)
                                ^^^^^^
    >=net-fs/samba-4.0.0_alpha1:0[client] required by (media-video/vlc-2.2.1-r1:0/5-8::gentoo, installed)
                                  ^^^^^^

x11-proto/xextproto:0

  (x11-proto/xextproto-7.3.0:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/xextproto-7.2.1-r1:0/0=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXext-1.3.3:0/0::gentoo, installed)
                                                                   
    >=x11-proto/xextproto-7.2.1-r1:=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXext-1.3.3:0/0::gentoo, installed)
                                                                 
    >=x11-proto/xextproto-7.2.1-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, ebuild scheduled for merge)
                                                               

x11-libs/libXext:0

  (x11-libs/libXext-1.3.3:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libXext-1.3.2[abi_x86_32] required by (x11-drivers/nvidia-drivers-361.28:0/361::gentoo, installed)
                             ^^^^^^^^^^

x11-proto/xproto:0

  (x11-proto/xproto-7.0.28:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/xproto-7.0.24[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXau-1.0.8:0/0::gentoo, installed)
                                                         
    >=x11-proto/xproto-7.0.24[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, ebuild scheduled for merge)
                                                         

x11-proto/kbproto:0

  (x11-proto/kbproto-1.0.7:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/kbproto-1.0.6-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, ebuild scheduled for merge)
                                                             

dev-libs/libpthread-stubs:0

  (dev-libs/libpthread-stubs-0.3-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/libpthread-stubs-0.3-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed)
                                                                   

x11-proto/xf86bigfontproto:0

  (x11-proto/xf86bigfontproto-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/xf86bigfontproto-1.2.0-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, ebuild scheduled for merge)
                                                                     

sys-libs/tevent:0

  (sys-libs/tevent-0.9.28:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=sys-libs/tevent-0.9.27[python(+),abi_x86_64(-)] required by (sys-libs/ldb-1.1.26:0/1.1.26::gentoo, installed)
                                                     

x11-proto/xcb-proto:0

  (x11-proto/xcb-proto-1.11:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/xcb-proto-1.11[abi_x86_32(-),abi_x86_64(-),python_targets_python3_4(-),python_single_target_python3_4(+)] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed)
                                                                                                                         

x11-libs/libxcb:0

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libxcb-1.9.3[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, ebuild scheduled for merge)
                                                       

x11-libs/libXau:0

  (x11-libs/libXau-1.0.8:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed)
                                                           


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by x11-libs/libXext-1.3.3::gentoo
# required by www-client/firefox-bin-45.2.0::gentoo
# required by @selected
# required by @world (argument)
>=x11-libs/libX11-1.6.3 abi_x86_32

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/libX11-1.6.2[abi_x86_32]".
!!! One of the following packages is required to complete your request:
- x11-libs/libX11-1.6.2::gentoo (Change USE: +abi_x86_32)
(dependency required by "x11-drivers/nvidia-drivers-361.28::gentoo[X,multilib]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Jul 21, 2016 1:18 pm    Post subject: Reply with quote

run eselect news read all
take action as recommended in items:
2015-03-28-true-multilib
2015-10-22-gcc-5-new-c++11-abi
2015-12-16-python-abiflags-rebuild-needed
then, if you haven't, emerge python-updater and perl-cleaner and run python-updater and perl-cleaner all
_________________
Defund the FCC.
Back to top
View user's profile Send private message
nelsonwcf
Tux's lil' helper
Tux's lil' helper


Joined: 31 Oct 2012
Posts: 112

PostPosted: Fri Jul 22, 2016 1:56 am    Post subject: Reply with quote

DONAHUE wrote:
run eselect news read all
take action as recommended in items:
2015-03-28-true-multilib
2015-10-22-gcc-5-new-c++11-abi
2015-12-16-python-abiflags-rebuild-needed
then, if you haven't, emerge python-updater and perl-cleaner and run python-updater and perl-cleaner all


my select news read all returned no messages (I think I purged all messages that I've read last year).
I ran python-updater and perl-cleaner all but nothing changed.

I believe I forgot to tell something: When installing R and R Studio, I've added the ~amd64 flag. During the emerge, one of the packages failed to compile. After that, I removed the ~amd64 flag and re-emerged. This issue started to appear after that.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Fri Jul 22, 2016 2:49 am    Post subject: Reply with quote

eselect news read all not select news read all
if you still get no news with eselect, browse to https://www.gentoo.org/support/news-items/
better to leave the global keyword alone and add the defective package to package.mask
_________________
Defund the FCC.
Back to top
View user's profile Send private message
nelsonwcf
Tux's lil' helper
Tux's lil' helper


Joined: 31 Oct 2012
Posts: 112

PostPosted: Fri Jul 22, 2016 11:03 pm    Post subject: Reply with quote

Hi,

Well, I followed the advice in the three news, then ran python-updater and perl-cleaner all. However, it didn't solve the problem.
How do I find the defective package? After I ran emerge --depclean once the package failed, it removed it (because the dependent software, R, was never installed) so it is not in the system anymore.

Any other ideas of what may be causing this issue?

Below more information about my system:

Code:
emerge --update --newuse --with-bdeps=y --deeo @world

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-proto/inputproto:0

  (x11-proto/inputproto-2.3.1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/inputproto-2.3[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, installed)
                                                           

x11-proto/xextproto:0

  (x11-proto/xextproto-7.3.0:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/xextproto-7.2.1-r1:=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXext-1.3.3:0/0::gentoo, installed)
                                                                 
    >=x11-proto/xextproto-7.2.1-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, installed)
                                                               
    >=x11-proto/xextproto-7.2.1-r1:0/0=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXext-1.3.3:0/0::gentoo, installed)
                                                                   

x11-proto/xproto:0

  (x11-proto/xproto-7.0.28:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/xproto-7.0.24[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, installed)
                                                         
    >=x11-proto/xproto-7.0.24[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXau-1.0.8:0/0::gentoo, installed)
                                                         

x11-libs/libXau:0

  (x11-libs/libXau-1.0.8:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed)
                                                           

x11-proto/kbproto:0

  (x11-proto/kbproto-1.0.7:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-proto/kbproto-1.0.6-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, installed)
                                                             

x11-libs/libxcb:0

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libxcb-1.9.3[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.3:0/0::gentoo, installed)
                                                       

x11-libs/libXdmcp:0

  (x11-libs/libXdmcp-1.1.2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed)
                                                             

dev-libs/libpthread-stubs:0

  (dev-libs/libpthread-stubs-0.3-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/libpthread-stubs-0.3-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed)
                                                                   

>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.


Below my make.conf:

Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j4"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="dbus bindist mmx sse sse2 alsa consolekit libinput"

INPUT_DEVICES="libinput"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
LINGUAS="en"

VIDEO_CARDS="nvidia"


package.accept_keywords:

Code:
sys-boot/refind ~amd64


package.keywords:

Code:
cross-armv7a-hardfloat-linux-gnueabi/binutils arm -amd64 -~amd64
cross-armv7a-hardfloat-linux-gnueabi/gcc arm -amd64 -~amd64
cross-armv7a-hardfloat-linux-gnueabi/linux-headers arm -amd64 -~amd64
cross-armv7a-hardfloat-linux-gnueabi/glibc arm -amd64 -~amd64
cross-armv7a-hardfloat-linux-gnueabi/gdb arm ~arm -amd64 -~amd64



package.use:

Code:
cross-armv7a-hardfloat-linux-gnueabi/binutils -selinux -multilib
cross-armv7a-hardfloat-linux-gnueabi/linux-headers -selinux -multilib
cross-armv7a-hardfloat-linux-gnueabi/glibc -selinux -multilib
cross-armv7a-hardfloat-linux-gnueabi/gcc -selinux -boundschecking -d -gcj -gtk -libffi -mudflap -objc -objc++ -objc-gc -multilib
net-misc/iputils -caps -filecaps
dev-python/pyudev pyqt4

sys-boot/refind ~amd64 ext4
# required by x11-drivers/nvidia-drivers-361.28::gentoo[X,multilib]
# required by x11-base/xorg-drivers-1.17::gentoo[video_cards_nvidia]
# required by @selected
# required by @world (argument)
>=x11-libs/libX11-1.6.3 abi_x86_32
# required by x11-drivers/nvidia-drivers-361.28::gentoo[X,multilib]
# required by x11-base/xorg-drivers-1.17::gentoo[video_cards_nvidia]
# required by @selected
# required by @world (argument)
>=x11-libs/libXext-1.3.3 abi_x86_32
# required by sys-libs/ldb-1.1.26::gentoo
# required by net-fs/samba-4.2.11::gentoo
# required by net-libs/libsoup-2.52.2::gentoo[samba]
# required by net-misc/networkmanager-1.0.12-r1::gentoo
# required by kde-frameworks/networkmanager-qt-5.21.0::gentoo
# required by kde-plasma/plasma-workspace-5.5.5-r2::gentoo[geolocation]
# required by kde-plasma/powerdevil-5.5.5::gentoo
# required by kde-plasma/plasma-meta-5.5.5::gentoo
# required by @selected
# required by @world (argument)
>=sys-libs/tevent-0.9.28 python
# required by media-video/vlc-2.2.1-r1::gentoo[samba]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# required by media-libs/phonon-4.7.2::gentoo[vlc]
# required by kde-frameworks/knotifyconfig-5.21.0::gentoo[phonon]
# required by kde-apps/kdenlive-15.12.3::gentoo
# required by kde-apps/kdemultimedia-meta-15.12.3::gentoo
# required by kde-apps/kde-apps-meta-15.12.3-r3::gentoo
# required by @selected
# required by @world (argument)
>=net-fs/samba-4.2.11 client
[/code]

There must be some way to fix this issue without having to reinstall everything.

Also, when I try to uninstall many libs, emerge says that the lib is being used and don't unmerge it. I really don't know how to deal with this problem and reading the portage guides didn't shed light on the subject.

Thank you,
Nelson
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Sat Jul 23, 2016 2:26 am    Post subject: Reply with quote

Code:
emerge wgetpaste
if needed, then
Run:
Code:
wgetpaste -t -s dpaste -c "emerge --info"
Code:
wgetpaste -t -s dpaste -c "emerge -pv dev-lang/R"
and/or
Code:
wgetpaste -t -s dpaste -c "emerge -pvuND world"
Post the url's returned
_________________
Defund the FCC.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Sat Jul 23, 2016 2:39 pm    Post subject: Reply with quote

try placing
Quote:
*/* abi_x86_32
in /etc/portage/package.use followed by emerge -avuND world. BTW, the troublemaker appears to be nvidia-drivers. I don't use nvidia-drivers; tried an emerge -pv nvidia-drivers and received a huge number of abi_x86 blockers. added */* abi_x86_32 to /etc/portage/package.use and the mess cleared.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 564
Location: France

PostPosted: Tue Jul 26, 2016 12:25 pm    Post subject: Reply with quote

nelsonwcf wrote:
There must be some way to fix this issue without having to reinstall everything.

Yes. Add this in your package.use file :
Code:
>=x11-proto/inputproto-2.3  abi_x86_32
>=x11-proto/xextproto-7.2.1-r1  abi_x86_32
>=x11-proto/xproto-7.0.24  abi_x86_32
>=x11-libs/libXau-1.0.7-r1  abi_x86_32
>=x11-proto/kbproto-1.0.6-r1  abi_x86_32
>=x11-libs/libxcb-1.9.3  abi_x86_32               
>=x11-libs/libXdmcp-1.1.1-r1  abi_x86_32
>=dev-libs/libpthread-stubs-0.3-r1  abi_x86_32
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 697

PostPosted: Tue Jul 26, 2016 6:36 pm    Post subject: Reply with quote

DONAHUE wrote:
try placing
Quote:
*/* abi_x86_32
in /etc/portage/package.use followed by emerge -avuND world. BTW, the troublemaker appears to be nvidia-drivers. I don't use nvidia-drivers; tried an emerge -pv nvidia-drivers and received a huge number of abi_x86 blockers. added */* abi_x86_32 to /etc/portage/package.use and the mess cleared.


can also run
Code:
# emerge dev-lang/R --autounmask-write || etc-update

(then type -5 to write config file)

and he can compile only packages with "abi_x86_32" flag needed
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum