Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Multiple package instance
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
chronical
n00b
n00b


Joined: 23 Jul 2016
Posts: 6

PostPosted: Sun Jul 24, 2016 11:33 am    Post subject: Multiple package instance Reply with quote

Hallo Zusammen,

nach einem emerge -eav system bekomme ich die Meldung

Code:


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:5

  (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.6.1[gles2=,gtkstyle=,png=,xcb?] required by (dev-qt/qtwidgets-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                 
    (and 6 more with the same problem)

  (dev-qt/qtgui-5.5.1-r1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.5.1 required by (dev-qt/qtquickcontrols-5.5.1-r1:5/5::gentoo, installed)
    ^             ^^^^^                                                                                                                           
    >=dev-qt/qtgui-5.5.1:5/5= required by (kde-frameworks/frameworkintegration-5.21.0:5/5.21::gentoo, installed)
                        ^^^^^                                                                                                                       
    (and 6 more with the same problems)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.6.1 required by (dev-qt/qtscript-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    (and 14 more with the same problem)

  (dev-qt/qtcore-5.5.1-r1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qtwidgets-5.5.1-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                                     
    (and 15 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.6.1 required by (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

  (dev-qt/qtdbus-5.5.1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.5.1 required by (dev-qt/qtgui-5.5.1-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 1 more with the same problem)

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.6.1-r1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.6.1[widgets] required by (dev-qt/designer-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                             
    (and 1 more with the same problem)

  (dev-qt/qtdeclarative-5.5.1-r1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtdeclarative-5.5.1 required by (dev-qt/qtgraphicaleffects-5.5.1-r1:5/5::gentoo, installed)
    ^                     ^^^^^                                                                                                                               
    (and 3 more with the same problem)

dev-qt/qttest:5

  (dev-qt/qttest-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.6.1 required by (dev-qt/qtdeclarative-5.6.1-r1:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                             

  (dev-qt/qttest-5.5.1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qttest-5.5.1 required by (dev-qt/qtdeclarative-5.5.1-r1:5/5::gentoo, installed)
    ^              ^^^^^                                                                                                                         

dev-qt/qtxmlpatterns:5

  (dev-qt/qtxmlpatterns-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.6.1 required by (dev-qt/qtdeclarative-5.6.1-r1:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                             

  (dev-qt/qtxmlpatterns-5.5.1-r1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-5.5.1 required by (dev-qt/qtdeclarative-5.5.1-r1:5/5::gentoo, installed)
    ^                     ^^^^^                                                                                                                         

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.6.1[gles2=] required by (dev-qt/qtdeclarative-5.6.1-r1:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                                     
    (and 4 more with the same problem)

  (dev-qt/qtwidgets-5.5.1-r1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.5.1 required by (dev-qt/qtmultimedia-5.5.1-r2:5/5::gentoo, installed)
    ^                 ^^^^^                                                                                                                         
    (and 4 more with the same problem)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.6.1 required by (dev-qt/qtxmlpatterns-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         
    (and 2 more with the same problem)

  (dev-qt/qtnetwork-5.5.1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtnetwork-5.5.1 required by (dev-qt/qtwebkit-5.5.1-r1:5/5::gentoo, installed)
    ^                 ^^^^^                                                                                                                     
    (and 3 more with the same problem)

dev-qt/qtxml:5

  (dev-qt/qtxml-5.6.1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxml-5.6.1 required by (dev-qt/linguist-tools-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           
    (and 1 more with the same problem)

  (dev-qt/qtxml-5.5.1:5/5::gentoo, installed) pulled in by
    ~dev-qt/qtxml-5.5.1 required by (dev-qt/qdbus-5.5.1-r1:5/5::gentoo, installed)


Ich habe versucht der Option oneshot zu benutzen, wie im Troubleshooting beschrieben, leider ohne Erfolg.
Da ich auch noch kein Profi um Umgang mit Portage bin, würde ich mich über einen kleinen Stupser freuen.

Vielen Dank
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2329
Location: Konradsreuth (Germany)

PostPosted: Sun Jul 24, 2016 2:55 pm    Post subject: Reply with quote

Ich habe die ganzen KDE-5-Blocks gelöst, indem ich die einzelnen Qt-Pakete in der richtigen Version per emerge -1 --nodeps installiert habe. Das ist natürlich ein mühsames Unterfangen, und muss auch in der richtigen Reihenfolge passieren. Dann wieder schauen, was immer noch Blocks verursacht (emerge -uavD @world), wieder mit -1 --nodeps mergen und so weiter. Irgendwann gibt es dann keine Blocks mehr. Nachmachen ohne Garantie, dass man das System nicht zerschießt ;-)

Ist eine blöde Situation, die wir derzeit mit den Qt-Paketen und KDE 5 haben …
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Sun Jul 24, 2016 4:22 pm    Post subject: Reply with quote

Das problem hier ist dass pakete die qt version 5.5.1 verlangen und andere pakete die qt version 5.6.1

Aus der geposteten ausgabe wird leider nicht klar welches paket genau jetzt ein qt paket in der version 5.5.1 benötigt. Obwohl 5.6.1 mittlerweile in portage stable ist.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Sun Jul 24, 2016 4:32 pm    Post subject: Reply with quote

l3u wrote:
Ist eine blöde Situation, die wir derzeit mit den Qt-Paketen und KDE 5 haben …

Die Blocks betreffen nur die Qt pakete. Da die einzelnen Qt pakete von upstream nicht designed sind mit unterschiedlichen Versionen ihrer Qt Abhängigkeiten klar zu kommen.
-> Alle Qt Pakete müssen in der selben version installiert sein.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
chronical
n00b
n00b


Joined: 23 Jul 2016
Posts: 6

PostPosted: Sun Jul 24, 2016 5:00 pm    Post subject: Reply with quote

Hallo,

vielen Dank für die Anmerkungen,
Wie finde ich denn die richtige Reihenfolge heraus ?

VG
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Sun Jul 24, 2016 5:26 pm    Post subject: Reply with quote

Hm, normal sollte ein Qt Update beim normalen @world Update problemlos mit durchgehen.

chronical,
du versuchst aktuell nur ein "emerge -eav system"
mit dem man ggf nicht alle installierten Qt Pakete (zb welche die nur eine Abhängigkeit von @world sind) mit erwischt,
und da die Qt Pakete nur alle zusammen, in gleicher Version installiert werden können, könnte eine Mischung aus verschiedenen Versionen eventuell die Konflikte hervorrufen.

Vorschlag: Da Qt 5.6.1 erst vor sehr wenigen Tagen auf amd64 und x86 stable markiert wurde, mache bitte noch mal einen frischen "emerge --sync" (um sicherzugehen das es keine Versionskonflikte aus stable und testing gibt).
Und versuche dann ein normales
Code:
emerge -avuDN @world
Update.
Wenn das nicht klappt, dann poste bitte mal die komplette emerge Ausgabe (am besten via einem Pastebin-Service).
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2329
Location: Konradsreuth (Germany)

PostPosted: Sun Jul 24, 2016 5:54 pm    Post subject: Reply with quote

Josef.95 wrote:
Hm, normal sollte ein Qt Update beim normalen @world Update problemlos mit durchgehen.

Auch wieder wahr, ich habe hier testing KDE 5 installiert, aber da hatte ich genau diese Blocks. Auf allen Rechnern ;-) Deswegen bin ich jetzt einfach mal davon ausgegangen, dass es da das selbe Problem ist.
Back to top
View user's profile Send private message
chronical
n00b
n00b


Joined: 23 Jul 2016
Posts: 6

PostPosted: Sun Jul 24, 2016 6:27 pm    Post subject: Reply with quote

Hallo,

Code:

emerge --sync
emerge -avUND world und system


hatte ich Gestern gemacht und die waren auch ohne Probleme durchgelaufen.
Ich werde das noch mal wiederholen und den kompletten emerge output via pastebin posten.[/code]
Back to top
View user's profile Send private message
chronical
n00b
n00b


Joined: 23 Jul 2016
Posts: 6

PostPosted: Sun Jul 24, 2016 6:45 pm    Post subject: Reply with quote

hier der pastebin

http://pastebin.com/Q2uV38Hu
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Sun Jul 24, 2016 9:01 pm    Post subject: Reply with quote

chronical wrote:
Hallo,

Code:

emerge --sync
emerge -avUND world und system


hatte ich Gestern gemacht und die waren auch ohne Probleme durchgelaufen.
Ich werde das noch mal wiederholen und den kompletten emerge output via pastebin posten.[/code]


Huh ja, bei deinem "emerge -avUND world und system" Befehl fehlt zum Updaten die --update (kurz -u) Option, das könnte erklären warum nicht alle Pakete mit aktualisiert werden.
(bitte nicht -U und -u verwechseln, siehe zu den Optionen auch im "man emerge")

Aus deinem Pastebin: In dem du wieder nur "sudo emerge -eav @system" verwendest, siehe zb
[ebuild U ] dev-qt/qtcore-5.6.1:5/5.6::gentoo [5.5.1-r1:5/5::gentoo] USE="icu -debug -systemd {-test}" 0 KiB
[ebuild U ] dev-qt/qtxml-5.6.1:5/5.6::gentoo [5.5.1:5/5::gentoo] USE="-debug {-test}" 0 KiB
usw
Ein Teil-Qt-Update wird so idR nicht funktionieren.

Versuche es bitte noch mal (wie bereits vorgeschlagen) mit einem
Code:
emerge -avuDN @world
mit (wie nach einem @world Update, von emerge vorgeschlagenen)
Code:
emerge -a --depclean

Wenn das durch ist, dann sollte auch dein "emerge -eav @system" funktionieren.
Back to top
View user's profile Send private message
Helmering
n00b
n00b


Joined: 13 Dec 2011
Posts: 57
Location: Italy

PostPosted: Mon Jul 25, 2016 11:36 am    Post subject: Reply with quote

Überprüfe auch mal dein "world file" (/var/lib/portage/world)
Da dürfen nur die von dir explezit gewünschten Pakete, nicht aber deren Abhängigkeiten drinstehen.

Der emerge Parameter -1 oder --oneshot vermeidet einen Eintrag im world file.

Gruss, Ralf
Back to top
View user's profile Send private message
chronical
n00b
n00b


Joined: 23 Jul 2016
Posts: 6

PostPosted: Mon Aug 01, 2016 7:07 pm    Post subject: Reply with quote

Hallo Zusammen,

das kleine u in emerge -avuND @world hat geholfen.
Vielen Dank für die Hilfe.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum