Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]schwerer Fehler meinerseits - zlib ist weg
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 197
Location: Wien

PostPosted: Wed Jul 27, 2016 11:48 am    Post subject: [gelöst]schwerer Fehler meinerseits - zlib ist weg Reply with quote

Hallo,
bitte fragt mich nicht wie sowas passieren konnte.
Hab jedenfalls in einem Anfall geistiger Schwäche
Code:
emerge --unmerge zlib
ausgeführt.
Das war ein schwerer Fehler, da emerge ohne zlib gar nicht funktioniert.
D.h. kann emerge nicht mehr nutzen um zlib wieder zu installieren.
Was könnte ich tun?
wär z.b. mit den bootbaren gentoo-live bzw. gentoo-minimal CD/DVDs sowas möglich?
bitte um Hilfe


Last edited by oliver2104 on Thu Jul 28, 2016 12:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1296
Location: Frankfurt, Germany

PostPosted: Wed Jul 27, 2016 11:44 pm    Post subject: Reply with quote

Ich würde einfach die zlib Bibliotheksdateien von einem hinreichend ähnlichen Server (u.a. gleiche Architektur, gleiche zlib Version, gleiche oder geringere CPU Flags) auf das System kopieren. Dann sollte emerge wieder funktionieren. Sicherheitshalber würde ich dann zlib erneut mit emerge compilieren und installieren lassen und schauen, dass alle kopierten Dateien mit einer neueren Version überschrieben wurden.

Die zu kopierenden Dateien kann man auf dem "ähnlichen" Server mit "qlist zlib" ermitteln. Doku braucht man nicht mitzukopieren.

Da ich auch gelegentlich wichtige Dateien lösche, habe ich dieses Verfahren schon ein paar Mal erfolgreich ausprobiert :-)
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 248

PostPosted: Thu Jul 28, 2016 7:06 am    Post subject: Reply with quote

Ich baue für solche Geschichten meine Pakete immer mit
Quote:

FEATURES="buildpkg"

Dann hat man zur Not immer ein Binärpaket zur Hand, was man schnell mal entpacken kann. Das geht zwar etwas auf Kosten des Speicherplatzes, erspart einem aber im Notfall viel Arbeit ;-).

Ansonsten kannst du natürlich auch einfach die Daten von einer möglichst aktuellen Gentoo Live CD nehmen, dort werden die Pakete ja immer sehr generisch gebaut. Am einfachsten geht es vermutlich mit
Code:

quickpkg sys-libs/zlib

Dann brauchst du nur das erstellte tbz2 Archiv kopieren und entpacken.
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 197
Location: Wien

PostPosted: Thu Jul 28, 2016 11:59 am    Post subject: Reply with quote

Super,
konnte eine geeignete vorkompilierte libz.so.1.2.8 im Internet finden.
hab die ins /usr/lib64 Verzeichnis kopiert.
und einen SymLink erzeugt.
Code:
ln -s /usr/lib64/libz.so.2.8 /usr/lib64/libz.so.1

emerge läuft jetzt wieder, natürlich habe ich sofort die zlib neu emerged.
Sieht soweit alles gut aus.
Vielen Dank für Eure Tipps
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum