Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
make modules_install error bss_file.c:175
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Mon Aug 08, 2016 5:58 am    Post subject: make modules_install error bss_file.c:175 Reply with quote

Hey!

I tried to ugrade my kernel from:
linux-4.1.12-gentoo --> linux-4.4.6-gentoo *

I followed this tutorial: https://wiki.gentoo.org/wiki/Kernel/Upgrade and 'merged' the configs with
Code:
 make silentconfig


the make command succeed while
Code:
 make modules_install
shows me the following error:

Code:

ronny-reiner-rambo linux # make modules_install
  INSTALL Documentation/connector/cn_test.ko
At main.c:222:
- SSL error:02001002:system library:fopen:No such file or directory: bss_file.c:175
- SSL error:2006D080:BIO routines:BIO_new_file:no such file: bss_file.c:178
sign-file: : No such file or directory
scripts/Makefile.modinst:35: recipe for target 'Documentation/connector/cn_test.ko' failed
make[1]: *** [Documentation/connector/cn_test.ko] Error 1
Makefile:1122: recipe for target '_modinst_' failed
make: *** [_modinst_] Error 2



my .config:

http://pastebin.com/9iZqrMpk
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Fri Aug 12, 2016 5:49 am    Post subject: Reply with quote

Nobody have a hint / same problem???
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 700

PostPosted: Sun Aug 14, 2016 2:48 pm    Post subject: Reply with quote

Looks like you've enabled module signing for Secure Boot purposes but you don't have the userspace tools installed.

I'm unfamiliar with make silentconfig, but I generally use make oldconfig when updating kernels. It looks like make silentconfig accidentally enabled a Secure-Boot-related option. My recommendation: either start over using make oldconfig, or manually disable anything Secure-Boot-/keysigning-/etc.-related in make menuconfig, or install the necessary userspace tools (no idea what they are, I don't use Secure Boot).
Back to top
View user's profile Send private message
royalts
n00b
n00b


Joined: 06 Jan 2015
Posts: 39

PostPosted: Tue Aug 16, 2016 7:35 am    Post subject: Reply with quote

I actually created a new config using
Quote:
make oldconfig
an it seem's to work . No Idea if I choose different options or if
Quote:
make silentconfig
did cause the issue. Thanks Aquous
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum