Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
USB problem related to Yubikey
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Punchcutter
Guru
Guru


Joined: 11 Feb 2007
Posts: 329

PostPosted: Wed Aug 10, 2016 1:44 am    Post subject: USB problem related to Yubikey Reply with quote

Hi.... the other day I had this problem that I think I've had before. I inserted my Yubikey to login to my email, and the little LED on it did not flash, indicating that it has been recognized as a device by the USB system. I took it out and tried several times, and different ports, but no go.

If this happens again, it'll be a very serious inconvenience, so I want to get a head-start on what I can do when this happens. Is there anything I can do to "reload" or "kick in the pants" my USB drivers to hopefully fix this problem? I found that I had a module "usbhid" in my kernel, so I tried what I thought was a smart way of rmmod'ing and then modprobe'ing it again (on a single shell command line, knowing that it would affect my keyboard), but that failed anyway, and then I had a major lockup, and had to reboot :oops:

I've looked in my kernel config, and it seems I have most of my USB driver stuff chosen as y (*) rather than module. This no doubt just a default position and probably not something chosen specifically by me back when I installed, ages ago.

Would it be better to have all of the USB items as modules?

Thanks for any hints you can give about this.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum