Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] slots vermeiden bei digikam-5.1.0???
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Wed Aug 10, 2016 8:07 pm    Post subject: [gelöst] slots vermeiden bei digikam-5.1.0??? Reply with quote

Hilfe, so sieht das aus:

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/opencv:0

  (media-libs/opencv-3.0.0:0/3.0::gentoo, installed) pulled in by
    >=media-libs/opencv-3:0/3.0=[contrib] required by (kde-apps/libkface-16.04.3:5/5::gentoo, installed)
    ^^                   ^^^^^^^                                                                                                                               

  (media-libs/opencv-2.4.12:0/2.4::gentoo, ebuild scheduled for merge) pulled in by
    <media-libs/opencv-3.0.0 required by (media-gfx/digikam-5.1.0:5/5::gentoo, ebuild scheduled for merge)


..und ich kann das wieder nicht deuten. Wie kann ich die slots vermeiden?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Sun Aug 14, 2016 11:10 am; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Thu Aug 11, 2016 12:01 am    Post subject: Reply with quote

Hm, es ist immer wieder schwierig zu helfen, wenn nicht bekannt ist aus was für ein emerge Kommando diese Teilauszüge stammen :-/

Aber, die Abhängigkeiten schauen etwa so aus: (ich versuche diese mal zu erklären)
libkface-16.04.3.ebuild:
media-libs/opencv:=[contrib(+)]
Heißt etwa, es wird media-libs/opencv mit USE=contrib gefordert, sofern die media-libs/opencv Version das contrib Useflag hat.
Die >=media-libs/opencv-3.0.0 Versionen haben das contrib Useflag (die <media-libs/opencv-3.0.0 Versionen haben es nicht).
Installiert ist bei dir media-libs/opencv-3.0.0
Ab >=media-libs/opencv-3.0.0 musst du also sicherstellen das diese mit USE=contrib gebaut/installiert werden.
Damit ist die geforderte Abhängigkeit von libkface-16.04.3 erfüllt.

Nun kommt aber digikam hinzu, das fordert laut
digikam-5.1.0.ebuild:
        media-libs/opencv:=[-qt4]
        || ( <media-libs/opencv-3.0.0 >=media-libs/opencv-3.1.0 )

Das passt mit deiner aktuell installierten =media-libs/opencv-3.0.0 Version nicht zusammen.

Benötigt wird entweder
<media-libs/opencv-3.0.0
oder
>=media-libs/opencv-3.1.0[contrib] (sprich wenn diese Version genutzt wird, dann muss diese mit USE=contrib gebaut werden).
Damit werden dann die Abhängigkeiten von libkface-16.04.3 und digikam-5.1.0 erfüllt, und portage sollte diese auflösen können.

Ich hoffe das war nun nicht zu kompliziert erklärt, und ist verständlich :)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Thu Aug 11, 2016 3:41 am    Post subject: Reply with quote

Sorry, ich mache meine updates immer mit emerge -auDNtv world.

Und ich dachte, ich hätte contrib drin und -qt4 auch:

Code:
 media-libs/opencv
     Verfügbare Versionen:   2.4.9(0/2.4) ~2.4.10(0/2.4) ~2.4.11(0/2.4) ~2.4.11(0/2.4)[1] 2.4.12(0/2.4)[1] ~2.4.12-r1(0/2.4)[1] (~)3.0.0(0/3.0) (~)3.0.0(0/3.0)[1] ~3.1.0-r1(0/3.1)[1] ~3.1.0-r3(0/3.1)[1] ~3.1.0-r4(0/3.1)[1] {contrib cuda doc +eigen examples ffmpeg gdal gphoto2 gstreamer gtk ieee1394 ipp java jpeg jpeg2k libav opencl openexr opengl openmp pch png +python qt4 qt5 testprograms threads tiff v4l vaapi vtk webp xine ELIBC="FreeBSD" PYTHON_SINGLE_TARGET="python2_7 python3_3 python3_4 python3_5" PYTHON_TARGETS="python2_7 python3_3 python3_4 python3_5"}
     Installierte Versionen: 3.0.0(09:20:35 16.04.2016)(contrib eigen gtk java jpeg jpeg2k opengl openmp png python qt5 threads tiff v4l xine -cuda -doc -examples -ffmpeg -gstreamer -ieee1394 -ipp -libav -opencl -openexr -pch -qt4 -testprograms -vtk ELIBC="-FreeBSD" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3")
     Startseite:             http://opencv.org
     Beschreibung:           A collection of algorithms and sample code for various computer vision problems


Also müsst es doch passen?

uhai

PS:

Hier ist die vollständige Ausgabe:

Code:
Calculating dependencies... done!
[ebuild     U ~] media-gfx/digikam-5.1.0:5::gentoo [5.0.0:5::gentoo] USE="X debug gphoto2 handbook%* kipi lensfun marble mysql scanner video (-addressbook) -semantic-desktop {-test}" 66.660 KiB
[ebuild   R    ] dev-util/eric-5.5.2:5::gentoo  L10N="de%* -cs% -en% -es% -fr% -it% -pt% -ru% -tr% -zh-CN%" LINGUAS="(-cs%) (-de%*) (-en%) (-es%) (-fr%) (-it%) (-pt%) (-ru%) (-tr%) (-zh_CN%)" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3" 0 KiB
[nomerge       ] media-gfx/digikam-5.1.0:5::gentoo [5.0.0:5::gentoo] USE="X debug gphoto2 handbook%* kipi lensfun marble mysql scanner video (-addressbook) -semantic-desktop {-test}"
[ebuild     U ~]  media-plugins/kipi-plugins-5.1.0:5::gentoo [5.0.0:5::gentoo] USE="flashexport handbook remotestorage%* -debug (-mediawiki) {-test} (-vkontakte)" 0 KiB
[ebuild     UD ]  media-libs/opencv-2.4.12:0/2.4::gentoo [3.0.0:0/3.0::gentoo] USE="eigen gtk java jpeg jpeg2k opengl openmp png python threads tiff v4l xine -cuda -doc -examples -ffmpeg -gstreamer -ieee1394 (-ipp) -libav -opencl -openexr -pch -qt4 -testprograms (-vtk) (-contrib%*) (-qt5%*)" PYTHON_SINGLE_TARGET="(-python2_7%*) (-python3_3%) (-python3_4%)" PYTHON_TARGETS="python2_7 (-python3_3%) (-python3_4%*)" 91.076 KiB

Total: 4 packages (2 upgrades, 1 downgrade, 1 reinstall), Size of downloads: 157.736 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/opencv:0

  (media-libs/opencv-3.0.0:0/3.0::gentoo, installed) pulled in by
    >=media-libs/opencv-3:0/3.0=[contrib] required by (kde-apps/libkface-16.04.3:5/5::gentoo, installed)
    ^^                   ^^^^^^^                                                                                                                               

  (media-libs/opencv-2.4.12:0/2.4::gentoo, ebuild scheduled for merge) pulled in by
    <media-libs/opencv-3.0.0 required by (media-gfx/digikam-5.1.0:5/5::gentoo, ebuild scheduled for merge)

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Thu Aug 11, 2016 5:44 am    Post subject: Reply with quote

Nö, passt nicht, denn du hast exakt nur 3.0.0 freigeschaltet, digikam will aber entweder <3.0.0 (also 2.4.12) oder >=3.1.0. Wegen libkface bleibt dir nichts anderes übrig, du musst die 3.1.0 freischalten (package.accept_keywords).
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Thu Aug 11, 2016 5:48 am    Post subject: Reply with quote

ooh... habe ich übersehen. Danke für den Zaunpfahl...

Aber jetzt müsste es gehen....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Thu Aug 11, 2016 9:07 am    Post subject: Reply with quote

<3.0.0 also zb die stable opencv-2.4.12 geht auch (libkface fordert keine bestimmte Version).
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sun Aug 14, 2016 10:24 am    Post subject: Reply with quote

uhai wrote:
Aber jetzt müsste es gehen....
Tut es das nun?
Oder woran scheitert es nun noch?
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Aug 14, 2016 11:09 am    Post subject: Reply with quote

sorry, das läuft. opencv habe ich ge"keyworded"...

bin am Testen, warum exiv2 die Wartungsfunktionen von digikam immer abstürzen lässt... da habe ich den thread hier aus den Augen verloren. Danke für Eure Hilfe :-)

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum