Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Remote Gentoo Install: SSH
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
hack.canada
n00b
n00b


Joined: 12 Aug 2016
Posts: 4
Location: Canada

PostPosted: Fri Aug 12, 2016 8:28 pm    Post subject: [solved] Remote Gentoo Install: SSH Reply with quote

Hi all,

As a disclaimer, I am new to Gentoo in particular, but so far I am loving it more and more with each use!

Back on topic: ...

SO! Please forgive me if it seems, at first glance, that I am beating a dead horse with the title of this topic, but I am having issues with logging in remotely as root in order to proceed with the Gentoo install.

I boot up gentoo from the install CD, setup networking, change my root password, and then start up the SSH server. All very straight forward. Now, when I attempt to login remotely via SSH I am greeted with the error (after entering the root password correctly at the remote ssh client prompt) "Permission denied (publickey, keyboard-interactive)"

Just to test that it wasn't a connection issue with the host, I proceeded to create a new user on my gentoo install and then login remotely via this user. That worked fine with 0 issues. I am only presented with the error when attempting to login as root.

It would seem to me that I am doing things correctly? But clearly I am missing something, as all of the search results I have found online have simply stated to do exactly what I did and in exactly the same order. The only problem is that these attempts were error-free :P

As I said, I am new to the distro specifically and maybe there is something basic that I am missing. If it is needed, I can provide additional details if my description is unclear.

Thanks a lot in advance :)


Last edited by hack.canada on Fri Aug 12, 2016 9:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43213
Location: 56N 3W

PostPosted: Fri Aug 12, 2016 8:53 pm    Post subject: Reply with quote

hack.canada,

Welcome to Gentoo.

Look at the content of /etc/ssh/sshd_config.
Find the section
Code:
# Authentication:

#LoginGraceTime 2m
#PermitRootLogin prohibit-password
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

That its commented ou shows its the default setting.

If you have
Code:
#PermitRootLogin prohibit-password
then root is not permitted to authenticate over ssh using a password.
Set
Code:
PermitRootLogin yes
and restart sshd.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
hack.canada
n00b
n00b


Joined: 12 Aug 2016
Posts: 4
Location: Canada

PostPosted: Fri Aug 12, 2016 9:04 pm    Post subject: Reply with quote

*Smacks head off of desk*

Thanks a lot for your help :) as you probably guessed, everything is working fine and my issue has been solved.

Just as an aside (I could be completely off as I am going off of memory) in the introductory text of the gentoo CLI install environment, it mentions the basic way of starting sshd as well as remembering to reset your passwd root to a known value in order to enable remote login... you'd think that if the instructions were that verbose, that they would have mentioned the configure option?

P.S. please forgive the accuracy of my prior statement; I have been compiling and installing for hours .....well days lol. I may not be as accurate in my recollection as I would have hoped to be.

It's great to be an actively posting member of this community and I look forward to contributing what I can / when I can.
Cheers all :)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43213
Location: 56N 3W

PostPosted: Fri Aug 12, 2016 9:29 pm    Post subject: Reply with quote

hack.canada,

That behaviour is a newish default in sshd.
The old setting was
Code:
#PermitRootLogin yes
and everything just worked as in the Wiki.

Gentoo is considering fixing the liveCD, so it justworks again.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
hack.canada
n00b
n00b


Joined: 12 Aug 2016
Posts: 4
Location: Canada

PostPosted: Fri Aug 12, 2016 9:35 pm    Post subject: Reply with quote

Ahhhhhh.... makes sense. Thanks so much for being patient and helpful. I have noticed at times that there were (honest, trivial, and/or unavoidable) things like that that would crop up in the install guide from time-to-time, which I'm sure is incredibly difficult to maintain in a guide of that scope.

If I have any more questions I will feel more than comfortable addressing them on these forums.

Now back to my install... uptime=man.are.you.seriously.still.compiling? =)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum