Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Tux showing while boot?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ayleid96
n00b
n00b


Joined: 25 Apr 2016
Posts: 51
Location: /home/noodles

PostPosted: Sun Aug 14, 2016 8:22 pm    Post subject: Tux showing while boot? Reply with quote

Hi,

i compiled latest kernel 4.7 from kernel.org with olddefconfig... but on gentoo and vanilla kernel tux is not showing up at boot? how can i achieve this? :D thanks in advance...
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7130
Location: almost Mile High in the USA

PostPosted: Mon Aug 15, 2016 12:20 am    Post subject: Reply with quote

You mean the penguin pictures per CPU thread during boot?
You need either FBCON or KMS enabled in your kernel config for your video card. I think this should be virtually automatic if you use an OSS kernel driver for X11.

Device Drivers -> graphics support -> bootup logo

If you're using ATI fglrx or NVIDIA closed source drivers, this will conflict and you may have problems. It looks like you aren't so perhaps you just need to enable the icons in the fbcon setup. (FGLRX/NVIDIA drivers want you to disable all kernel drivers that take over the console.)

Hmm... I guess this is post 5000 for me, means nothing!
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
ayleid96
n00b
n00b


Joined: 25 Apr 2016
Posts: 51
Location: /home/noodles

PostPosted: Fri Aug 19, 2016 9:46 am    Post subject: Reply with quote

eccerr0r wrote:
You mean the penguin pictures per CPU thread during boot?
You need either FBCON or KMS enabled in your kernel config for your video card. I think this should be virtually automatic if you use an OSS kernel driver for X11.

Device Drivers -> graphics support -> bootup logo

If you're using ATI fglrx or NVIDIA closed source drivers, this will conflict and you may have problems. It looks like you aren't so perhaps you just need to enable the icons in the fbcon setup. (FGLRX/NVIDIA drivers want you to disable all kernel drivers that take over the console.)

Hmm... I guess this is post 5000 for me, means nothing!


i compiled with bootup logo, and i have intel 4 gen gpu...
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7130
Location: almost Mile High in the USA

PostPosted: Mon Sep 12, 2016 4:53 pm    Post subject: Reply with quote

If you're not using X11, you may either need to make sure FBCON is enabled for Intel or use the DRM (for X11) driver in the kernel.

If X11 is working on this computer and it's not showing, then something very wrong is going on...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum