Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libi2c-dev on Gentoo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Mon Aug 15, 2016 8:14 pm    Post subject: libi2c-dev on Gentoo Reply with quote

An meiner Arbeit arbeite ich mit Debian. Ich habe ein Program, was libi2c-dev verwendet, Funktionien wie i2c_smbus_write_byte_data.

Auf Debian wird /usr/include/linux/i2c-dev.h von libi2c-dev installiert und dort sind die ioctls und die i2c_smbus_* (als inline) definiert. Auf meinem Gentoo wird /usr/include/linux/i2c-dev.h von sys-kernel/linux-headers-4.3 installiert, aber die Dateien sind nicht gleich.

Die Gentoo Version ist viel kleiner und hat die i2c_smbus_* Funktionen nicht.

Meine Frage: welches Gentoo Paket installiert dieselbe i2c-dev.h Version wie libi2c-dev? Oder sind i2c_smbus_* deprecated und es gibt ein neues Interface für i2c?
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon Aug 15, 2016 11:46 pm    Post subject: Reply with quote

Code:
eix i2c
ergibt
Code:
sys-apps/i2c-tools


keine ahnung ob das das richtige ist, aber probieren kannste mal.
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Aug 16, 2016 12:36 am    Post subject: Reply with quote

ja, das habe ich, das hat nicht geholfen.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3630
Location: Germany

PostPosted: Tue Aug 16, 2016 11:27 am    Post subject: Reply with quote

Hm, klingt nach Bug 488654
Sorry, ne Idee wie man das aktuell am besten löst hab ich zZt leider nicht :-/
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Tue Aug 16, 2016 12:13 pm    Post subject: Reply with quote

vllt. ebuild in eigenes overlay und die rm -rf zeile entfernen
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Aug 16, 2016 12:31 pm    Post subject: Reply with quote

Josef.95 wrote:
Hm, klingt nach Bug 488654
Sorry, ne Idee wie man das aktuell am besten löst hab ich zZt leider nicht :-/


Intressant, das ist genau das Problem. Danke für den Link zum bug report.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
theborg0815
n00b
n00b


Joined: 14 Mar 2006
Posts: 6

PostPosted: Tue Aug 30, 2016 5:15 pm    Post subject: Reply with quote

Moin bei den normalen i2c-tools Paket muss man das smbus USE-Flag setzen vielleicht ist das bei dem dev paket auch so,
_________________
Gentoo => Allwinner H3, 1GB RAM, 16GB MRAM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum